Can't use Kindle Cloud Reader in Firefox OS browser

RESOLVED DUPLICATE of bug 964167

Status

Tech Evangelism
Mobile
RESOLVED DUPLICATE of bug 964167
3 years ago
3 years ago

People

(Reporter: kanru, Unassigned)

Tracking

({foxfood})

unspecified
x86_64
Linux
foxfood

Firefox Tracking Flags

(b2g-v1.4 affected, b2g-v2.0 affected, b2g-v2.1 affected)

Details

(Whiteboard: [webcompat], b2g, URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Tested on Flame.

The webapp doesn't seem to response to the touch or click event. And the page is not scrollable.
QA Wanted for branch checks.
Keywords: qawanted

Updated

3 years ago
QA Contact: ddixon
Kan-Ru Chen, 

I accessed the URL you provided.  However, more information regarding your environmental variables would be very helpful. 

What branch and build did you see this issue in?   

What memory setting are you testing with on your Flame device?  512 or 319 MB?  

What web page are you seeing this issue after logging into (https://read.amazon.com/)?    

Thanks you!
Flags: needinfo?(kchen)
(Reporter)

Comment 3

3 years ago
Created attachment 8478766 [details]
2014-08-26-10-25-52.png

(In reply to Duane Dixon [:ddixon] from comment #2)
> Kan-Ru Chen, 
> 
> I accessed the URL you provided.  However, more information regarding your
> environmental variables would be very helpful. 
> 
> What branch and build did you see this issue in?

Latest mozilla-central

Gaia      e424c85eda87a40c0fa64d6a779c3fa368bf770b
Gecko     https://hg.mozilla.org/mozilla-central/rev/daa84204a11a
BuildID   20140824160205
Version   34.0a1
ro.build.version.incremental=108
ro.build.date=Tue Jun 10 19:40:40 CST 2014
B1TC20011210
 
> What memory setting are you testing with on your Flame device?  512 or 319
> MB?  

512 MB

> What web page are you seeing this issue after logging into
> (https://read.amazon.com/)?    

Screenshot attached. This page requires you to have a Amazon account in order to login. After login the URL is still https://read.amazon.com

It renders correctly but I can't interact with it except long-click brings a pop-up.
Flags: needinfo?(kchen)
Branch Check

Issue DOES occur in Flame 2.1, 2.0, 1.4, and 2.1 Open_C

Actual Results: After logging into web page: (https://read.amazon.com/), user cannot scroll the page and at times page is unresponsive to touch commands. 

Device: Flame Master
BuildID: 20140822010750
Gaia: afcdd36f13e75adcdebe57d842a277fd587faf28
Gecko: 0b9dd32d1e16
Version: 34.0a1 (Master) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
-------------------------------------------------------
Device: Flame 2.0
BuildID: 20140825185056
Gaia: a51633e29a7826b6bf07cb1c5ad81b3217b9820a
Gecko: fdac649a65ac
Version: 32.0 (2.0) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
-------------------------------------------------------
Device: Flame 1.4
BuildID: 20140825062151
Gaia: cf9d74da6653efeb43d9653e81c61aa00e693a67
Gecko: cdcb73d0febc
Version: 30.0 (1.4) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
-------------------------------------------------------
Device: Open_C Master 
BuildID: 20140825062151
Gaia: cf9d74da6653efeb43d9653e81c61aa00e693a67
Gecko: cdcb73d0febc
Version: 30.0 (1.4) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v1.4: --- → affected
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → affected
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)

Comment 5

3 years ago
FWIW this affects flatfish too.

After selecting a book, two pages display but is impossible to page forward or back or summon the menu.

I've filed a support request about this bug with Amazon.

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]

Comment 6

3 years ago
This has worsened, now I can't even tap on the book covers =(

Is this an actual bug on Firefox OS or poor web making from Amazon? The site works fine on Firefox.
Flags: needinfo?(kdubost)
Whiteboard: [webcompat]

Comment 7

3 years ago
Alex, I don't know.
One way to investigate would be to fake Chrome UA on Gecko.
and fake Firefox OS UA on Blink. 

And see what is working or not.
Flags: needinfo?(kdubost)
So on the new Foxfood phones, I can click covers and load a book but I can't turn pages. The page also renders oddly zoomed in with no way to zoom out or turn pages.
Keywords: foxfood
kats, can it be related to apz?
Flags: needinfo?(bugmail.mozilla)
This has come up before - see bug 1036964 and bug 964167. Looks like amazon just doesn't want to support mobile web browsers. Unless something has changed this is likely not an APZ issue.
Flags: needinfo?(bugmail.mozilla)
Flags: needinfo?(nhirata.bugzilla)
QA Whiteboard: [QAnalyst-Triage+][lead-review+] → [QAnalyst-Triage+][lead-review+] [top-dogfood]
Component: General → Mobile
Flags: needinfo?(nhirata.bugzilla)
Product: Firefox OS → Tech Evangelism
Whiteboard: [webcompat] → [webcompat], b2g
Mike, can you take a look or redirect to someone who can please?
Flags: needinfo?(miket)
Hi Noaki,

I agree with Kats, Amazon just doesn't seem interested in supporting mobile browsers. 

Exactly 0 mobile browsers having a working read.amazon.com web experience. They *all* link to a page that describes "Kindle for Android" (even iOS Safari). It just so happens that Amazon probably doesn't recognize the B2G UA string and so it passes it through to the Desktop site which is not designed for a responsive mobile experience.

I've cc'd Hallvord if he wants to dig in and figure out why synthetic click events aren't working here (I don't see any touch handlers at all), but I don't think we're going to get very far with Amazon even if we do figure it out. :(
If it's up to me we close it as dup of bug 964167.
Agreed.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 964167
Duplicate of this bug: 1178112
You need to log in before you can comment on or make changes to this bug.