transform-origin with percent value doesn't seem to work on SVG elements

RESOLVED DUPLICATE of bug 923193

Status

()

Core
SVG
RESOLVED DUPLICATE of bug 923193
3 years ago
3 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
STR:
 1. Load attached testcase

EXPECTED RESULTS:
No red should be visible. (The lime rect's CSS transform should rotate it around its center point, per its "transform-origin" property.)

ACTUAL RESULTS:
Red is visible. My "transform-origin" doesn't seem to have had any effect on the lime rect -- it's rotating about its 0,0 point instead of about its 50%,50% point.

Devtools show that the computed "transform-origin" is to 0,0 -- so, it looks like the percentage isn't resolving against anything.

http://dev.w3.org/csswg/css-transforms/#transform-origin-property says:
  "Percentages:	refer to the size of bounding box"

Chrome 36 gives me EXPECTED RESULTS.
Firefox Nightly gives me ACTUAL RESULTS.

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 923193
(Reporter)

Comment 2

3 years ago
Created attachment 8477448 [details]
testcase 1

Here's the testcase, though I see this is a dupe (thanks, longsonr).

(I think I put too much trust in enter_bug.cgi's possible-dupe-finder UI. :))
You need to log in before you can comment on or make changes to this bug.