Subscribe UI unable to subscribe/unsubscribe to non-ASCII imap folders

VERIFIED FIXED in mozilla0.9.9

Status

MailNews Core
Internationalization
P2
normal
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: ji, Assigned: Bienvenu)

Tracking

({intl})

Trunk
mozilla0.9.9
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
****Observed with 10-17-0.9.4 builds*****

Uncheck on a non-ASCII imap folder on subscribe window doesn't stay.

Steps to reproduce:
1. Have a non-ASCII folder in your imap account, like tëst.
2. Select File | Subscribe, you can see all the imap folders are subscribed
initially.
3. Uncheck on the non-ASCII folder and click on OK.
4. Select File | Subscribe again to go back to the subscribe window, you can see
the non-ASCII folder is still checked (subscribed).
I don't see this problem with an ASCII folder.
(Reporter)

Comment 1

17 years ago
Nominating for nsbeta1, since it's a basic functionality.
Keywords: intl, nsbeta1

Comment 2

17 years ago
Reassign to putterman.
Is this a regression?
Assignee: nhotta → putterman

Comment 3

17 years ago
reassigning to sspitzer and cc'ing bienvenu.  I don't know if this is a backend
or frontend issue.
Assignee: putterman → sspitzer
(Reporter)

Comment 4

17 years ago
No, it's reproducible with 6.1.
(Assignee)

Comment 5

17 years ago
almost certainly an imap mod-utf7 or escaping problem.
Assignee: sspitzer → bienvenu

Updated

16 years ago
Keywords: nsbeta1 → nsbeta1+

Updated

16 years ago
Priority: -- → P2

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.9
(Assignee)

Comment 6

16 years ago
Correcting summary - you can neither subscribe or unsubscribe to non-ascii
folders, or folders whose mod-utf7 name is different from their display name.
Summary: Unable to unsubscrible non-ASCII imap folders → Subscribe UI unable to subscribe/unsubscribe to non-ASCII imap folders
(Assignee)

Comment 7

16 years ago
Created attachment 69117 [details] [diff] [review]
proposed fix

need to convert utf-7 encoded folder name back to unicode before calling
subscribe routine.
(Assignee)

Comment 8

16 years ago
cc'ing Navin for review

Comment 9

16 years ago
Comment on attachment 69117 [details] [diff] [review]
proposed fix

sr=mscott
Attachment #69117 - Flags: superreview+

Comment 10

16 years ago
Comment on attachment 69117 [details] [diff] [review]
proposed fix

r=naving
Attachment #69117 - Flags: review+
(Assignee)

Comment 11

16 years ago
fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

16 years ago
Verified with 03/20 builds. it's fixed.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.