[Ubuntu Firefox] Gets stuck in tight poll loop/ -1 EAGAIN (Resource temporarily unavailable)

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
--
critical
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: Doug Royer, Unassigned)

Tracking

({hang})

31 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140715214335

Steps to reproduce:

From time to time firefox seems to hang. A strace -p <the firefox pid>, sometimes for minutes it shows:

clock_gettime(CLOCK_MONOTONIC, {1280899, 1320152}) = 0
clock_gettime(CLOCK_MONOTONIC, {1280899, 1376167}) = 0
recvmsg(4, 0xbff36344, 0)               = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=5, events=POLLIN}, {fd=4, events=POLLIN}, {fd=7, events=POLLIN|POLLPRI}, {fd=9, events=POLLIN}, {fd=25, events=POLLIN}, {fd=27, events=POLLIN}], 6, 0) = 0 (Timeout)
clock_gettime(CLOCK_MONOTONIC, {1280899, 1650843}) = 0
clock_gettime(CLOCK_MONOTONIC, {1280899, 1724592}) = 0
recvmsg(4, 0xbff36344, 0)               = -1 EAGAIN (Resource temporarily unavailable)
  .
  .
  .


Actual results:

Firefox hangs and taks lots of CPU resources.

On:
Ubuntu 13.10 (GNU/Linux 3.11.0-13-generic i686)

31.0
Mozilla Firefox for Ubuntu 
canonical-1.0



Expected results:

Perhaps thread what ever is FD=4, block signals on that thread, and let it hang while the other threads still run.

Comment 1

3 years ago
> Mozilla Firefox for Ubuntu

If it wasn't for this, you could have run "kill -ILL" on it to get some crash reports…
Severity: normal → critical
QA Whiteboard: [bugday-20140825]
Keywords: hang
Summary: Gets stuck in tight poll loop/ -1 EAGAIN (Resource temporarily unavailable) → [Ubuntu Firefox] Gets stuck in tight poll loop/ -1 EAGAIN (Resource temporarily unavailable)

Comment 2

3 years ago
(In reply to [:Aleksej] from comment #1)
> > Mozilla Firefox for Ubuntu
> 
> If it wasn't for this, you could have run "kill -ILL" on it to get some
> crash reports…

Indeed. Can you try this, please?
Flags: needinfo?(douglasroyer)
(Reporter)

Comment 3

3 years ago
Sent in crash report 9387ae2c-02fb-4dbf-b1c9-88dde2140828
Flags: needinfo?(douglasroyer)
I've looked for the crash signature in Socorro, and no joy related to the latest versions so I'm inclined to resolve this bug as works for me.
However Doug, I would advice to update your canonical version, or if you did so and you still notice issues that offer us more actual information to act upon, do not hesitate to reopen this issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

2 years ago
I have not seen the bug in a while - thanks!

Comment 6

2 years ago
My bug 1274731 looks like this one. It has a stacktrace.
You need to log in before you can comment on or make changes to this bug.