Content process crashes sometimes not reported

RESOLVED FIXED in mozilla35

Status

()

Core
DOM: Content Processes
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: billm, Assigned: billm)

Tracking

unspecified
mozilla35
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
Created attachment 8477785 [details] [diff] [review]
fix-crash-reporting

While debugging bug 1056340, I discovered a case where the tab crash page was appearing but without the option to submit a report. I looked into it and the onAboutTabCrashedLoad function is not being called. That code is called from here:
http://mxr.mozilla.org/mozilla-central/source/browser/base/content/browser.js#4087

We do actually reach that code when loading about:tabcrashed. However, the URL is reported as about:blank for some reason. I couldn't figure out why. The docshell seems to have pretty weird behavior for these error pages (it doesn't fire load events for them, for example). Rather than dig into it, I just decided to fire an event when the page is loaded. In theory, random content pages could fire this event, but doing so shouldn't cause any problems.

This patch makes the crash reporting checkbox appear reliably for me.
Attachment #8477785 - Flags: review?(felipc)
Comment on attachment 8477785 [details] [diff] [review]
fix-crash-reporting

Review of attachment 8477785 [details] [diff] [review]:
-----------------------------------------------------------------

I was trying to think if there's a better way to do it, but let's land go ahead with it, specially due to 1063680.

If you check the documentURI on this event, is it still reported as about:blank? If at that point it is accurate as about:tabcrashed we should try to use that to prevent webpages from being able to do this. Or we can also ignore this event for non-e10s windows, so that on an e10s window, if the page was properly loaded remotely, the parent process would never see this event if generated by a webpage.
Attachment #8477785 - Flags: review?(felipc) → review+
(Assignee)

Comment 2

3 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/9062496f4127

I wasn't able to reproduce the crash anymore that caused this to happen, so I left the patch as-is. Sorry :-(.
https://hg.mozilla.org/mozilla-central/rev/9062496f4127
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
You need to log in before you can comment on or make changes to this bug.