Closed Bug 1057774 Opened 6 years ago Closed 6 years ago

bzAPI landing page gives a 404

Categories

(bugzilla.mozilla.org :: Extensions, defect)

Production
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: hemanth.hm, Assigned: dkl)

References

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:34.0) Gecko/20100101 Firefox/34.0 (Beta/Release)
Build ID: 20140823030201

Steps to reproduce:

https://bugzilla.mozilla.org/bzapi gives a 404


Actual results:


Object Not Found

The requested URL was not found on this server.
Error 404

bugzilla.mozilla.org



Expected results:

It must give the API docs?
(In reply to hemanth from comment #0)
> https://bugzilla.mozilla.org/bzapi gives a 404

Why do you think it should do something else? 
If you found that URL somewhere, you might want to tell where you found it.
(In reply to Andre Klapper from comment #1)
> (In reply to hemanth from comment #0)
> > https://bugzilla.mozilla.org/bzapi gives a 404
> 
> Why do you think it should do something else? 
> If you found that URL somewhere, you might want to tell where you found it.

It must behave like https://api-dev.bugzilla.mozilla.org/latest/ and this is being used in a node module I have been working on.
(In reply to hemanth from comment #2)
> (In reply to Andre Klapper from comment #1)
> > (In reply to hemanth from comment #0)
> > > https://bugzilla.mozilla.org/bzapi gives a 404
> > 
> > Why do you think it should do something else? 
> > If you found that URL somewhere, you might want to tell where you found it.
> 
> It must behave like https://api-dev.bugzilla.mozilla.org/latest/ and this is
> being used in a node module I have been working on.

What exactly are you looking for in the return data? Are you just checking for 200 OK and not a 404?
Status: UNCONFIRMED → ASSIGNED
Component: API → Extensions: BzAPI Compatibility
Ever confirmed: true
Flags: needinfo?(hemanth.hm)
See Also: → 1036225
Assignee: nobody → dkl
I have added a data structure that is returned when not requesting any specific data that gives some information and a status of 200 OK. The returned data will look like this:

{
   "documentation" : "https://wiki.mozilla.org/Bugzilla:BzAPI",
   "ref" : "https://bugzilla.mozilla.org/bzapi/",
   "version" : "4.2.9+"
}

To ssh://gitolite3@git.mozilla.org/webtools/bmo/bugzilla.git
   bfc1cfe..b888aaa  master -> master

To ssh://gitolite3@git.mozilla.org/webtools/bmo/bugzilla.git
   b888aaa..c3b24d4  master -> master
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Flags: needinfo?(hemanth.hm)
Resolution: --- → FIXED
this fix has been pushed to production, however

https://bugzilla.mozilla.org/bzapi still returns 404
https://bugzilla.mozilla.org/bzapi/ returns a valid page.

i'm not sure if this is the intended behaviour.
Component: Extensions: BzAPI Compatibility → Extensions
You need to log in before you can comment on or make changes to this bug.