[Loop][KK]In logcat qdhwcomposer reports many errors about a screen height 0

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: JMercado, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 affected)

Details

(Whiteboard: [mobile app][not blocking][2.0-exploratory-kk])

Attachments

(2 attachments)

Created attachment 8478553 [details]
logcat screenshot.png

Description:
When using a logcat the user sees lots of errors reporting screen height 0 by qdhwcomposer.  This only occurs on the Flame KitKat Base.


Repro Steps:
1) Update a Flame to 20140825132332 on the v165 KitKat Base
2) Install the Loop app
3) Begin a logcat
4) Open the Loop app


Actual:
The following error is repeatedly output when viewing the logcat.
1445  1477 E qdhwcomposer: prepare: wrong params for display screen_w=480                          src_crop_width=818 screen_h=0 src_crop_height=0


Expected:
The error is not shown.

Environmental Variables:
Device: Flame 2.0 (319 MB)
Build ID: 20140825132332
Gaia: 4c8b5ced1966079086d86dec3098ecf340881306
Gecko: 6329352ca531b977979451e77e5862af485388b2
Version: 32.0 (2.0)
Firmware Version: v165 (319 MB)
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Loop Version: b934abe


Repro frequency: 100%
Link to failed test case:
See attached: screenshot, logcat
This issue does occur on Flame 2.0 (512 MB) running the v165 base.
The error message is seen repeatedly.

Environmental Variables:
Device: Flame 2.0 (512 MB)
Build ID: 20140825132332
Gaia: 4c8b5ced1966079086d86dec3098ecf340881306
Gecko: 6329352ca531b977979451e77e5862af485388b2
Version: 32.0 (2.0)
Firmware Version: v165 
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0




This issue does not occur on 2.0 Flame (319MB) on the v123 base, 2.1 Flame, or 2.0 OpenC.
No error message is seen.

Environmental Variables:
Device: Flame 2.0 (319 MB)
BuildID: 20140825000201
Gaia: 4c8b5ced1966079086d86dec3098ecf340881306
Gecko: b0545e46d08b
Version: 32.0 (2.0) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Environmental Variables:
Device: Flame Master
BuildID: 20140825040204
Gaia: e424c85eda87a40c0fa64d6a779c3fa368bf770b
Gecko: daa84204a11a
Version: 34.0a1 (Master) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Environmental Variables:
Device: Open_C 2.0
BuildID: 20140825000201
Gaia: 4c8b5ced1966079086d86dec3098ecf340881306
Gecko: b0545e46d08b
Version: 32.0 (2.0) 
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Loop Version: b934abe
Created attachment 8478554 [details]
logcat with errors.txt
Jayme - Can you add QAnalyst-Triage? & needinfo your lead?
Flags: needinfo?(jmercado)
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado) → needinfo?(ktucker)
Jayme, please cc Massimo on all loop issues.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage-]
Flags: needinfo?(ktucker) → needinfo?(jmercado)
Flags: needinfo?(jmercado)
The 2.1 Flame build was tested with 319 MB.  Updated variables below.

Environmental Variables:
Device: Flame Master (319 MB)
BuildID: 20140825040204
Gaia: e424c85eda87a40c0fa64d6a779c3fa368bf770b
Gecko: daa84204a11a
Version: 34.0a1 (Master) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage-] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
KitKat base specific error showing in logcat with the loop app. We are not seeing anything out of the ordinary occurring however in the app itself so not nominating this to block.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Not blocking for the time being, adding ni to :dwilson just in case this could be linked to any performance issue
Whiteboard: [2.0-exploratory-kk] → [mobile app][not blocking][2.0-exploratory-kk]
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
Oscar, can you have a look at this bug to check if it's still happening?
Flags: needinfo?(opatinobugzilla)
The error doesn't show now. It's not happening
Flags: needinfo?(opatinobugzilla)
Thanks a lot Oscar!! Closing it as Worksforme.
Jayme, be free to reopen it if you detect it again :)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.