Closed Bug 1058312 Opened 6 years ago Closed 5 years ago

[Contacts] Individual Contact Field "Company" cannot be removed after being updated.

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.1+, b2g-v1.4 unaffected, b2g-v2.0 unaffected, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S4 (12sep)
blocking-b2g 2.1+
Tracking Status
b2g-v1.4 --- unaffected
b2g-v2.0 --- unaffected
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: onelson, Assigned: jorgep)

References

()

Details

(Keywords: regression, Whiteboard: [2.1-flame-test-run-1])

Attachments

(2 files, 1 obsolete file)

Attached file logcat
Description:
When the user adds a Company to any of their contacts, they will observe that upon editing the contact to attempt to remove the Company field, erasing it will have no effect as the Company field will still carry over for the contact upon updating. 
Company field can be CHANGED but cannot be REMOVED
   
Repro Steps:
1) Update a Flame device to BuildID: 20140825040204
2) Open the Contacts app.
3) Create new contact, include a Company field.
4) Edit the contact and delete the company field.
5) Update the contact and observe the company field after attempting to delete.
  
Actual:
Company field remains on the contact.
  
Expected: 
Company field is removed from the contact.
  
Environmental Variables:
Device: Flame 2.1 Master (319mb)
BuildID: 20140825040204
Gaia: e424c85eda87a40c0fa64d6a779c3fa368bf770b
Gecko: daa84204a11a
Version: 34.0a1 (2.1 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

  
Repro frequency: 
5/5 - 100%

Link to failed test case: https://moztrap.mozilla.org/manage/case/5181/
See attached: 
Logcat and youtube video
https://www.youtube.com/watch?v=CXMhYsoOIFI
Issue DOES repro in flame 2.1 (512 mem), open-c 2.1:
Device: Flame Master (512mb)
BuildID: 20140825040204
Gaia: e424c85eda87a40c0fa64d6a779c3fa368bf770b
Gecko: daa84204a11a
Version: 34.0a1 (2.1 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Device: Open_C Master
Build ID: 20140825040204
Gaia: e424c85eda87a40c0fa64d6a779c3fa368bf770b
Gecko: daa84204a11a
Version: 34.0a1 (Master)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Actual Results:
Company field remains on the contact after user attempted deleting.





Issue DOES NOT repro in flame 1.4 (319 mem), flame 2.0 (319 mem), open-c 1.4, open-c 2.0:
Device: Flame 1.4 (319mb)
BuildID: 20140825063013
Gaia: cf9d74da6653efeb43d9653e81c61aa00e693a67
Gecko: cdcb73d0febc
Version: 30.0 (1.4)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Device: Flame 2.0 (319mb)
BuildID: 20140825000201
Gaia: 4c8b5ced1966079086d86dec3098ecf340881306
Gecko: b0545e46d08b
Version: 32.0 (2.0) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Device: Open_C 1.4
BuildID: 20140825063013
Gaia: cf9d74da6653efeb43d9653e81c61aa00e693a67
Gecko: cdcb73d0febc
Version: 30.0 (1.4)
Firmware: P821A10v1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Device: Open_C 2.0
Build ID: 20140825000201
Gaia: 4c8b5ced1966079086d86dec3098ecf340881306
Gecko: b0545e46d08b
Version: 32.0 (2.0)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Actual Results:
Company field is removed from the contact after user deleted.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
[Blocking Requested - why for this release]:

This is a regression from 2.0. The user should be able to delete the contact's company without issue. This could frustrate the end user so nominating this 2.1?
blocking-b2g: --- → 2.1?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Assignee: nobody → jpruden92
Target Milestone: --- → 2.1 S3 (29aug)
Status: NEW → ASSIGNED
Attached file 23317.html (obsolete) —
Attachment #8478988 - Flags: review?(anthony)
QA Contact: ckreinbring
Regression window
Last working
BuildID: 20140818071415
Gaia: aa8aace12d65956dd9525da5dac66e0d3b28597f
Gecko: 1338cfd64cc6
Platform Version: 34.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

First broken
BuildID: 20140818072913
Gaia: ba1992f2addc5a84afc2eab426f222a6bf2962ba
Gecko: bf27e27c994d
Platform Version: 34.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Working Gaia / Broken Gecko = No repro
Gaia: aa8aace12d65956dd9525da5dac66e0d3b28597f
Gecko: bf27e27c994d
Broken Gaia / Working Gecko = Repro
Gaia: ba1992f2addc5a84afc2eab426f222a6bf2962ba
Gecko: 1338cfd64cc6
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/aa8aace12d65956dd9525da5dac66e0d3b28597f...ba1992f2addc5a84afc2eab426f222a6bf2962ba


B2G inbound
Last working
BuildID: 20140818041415
Gaia: deb73e71e32ccc26261de33d9f857ce5d429e2f6
Gecko: b6b405a253d9
Platform Version: 34.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

First broken
BuildID: 20140818041915
Gaia: 9f9e2d948104e0173a7cb145b96661f80d55ff9a
Gecko: 104a51033ef9
Platform Version: 34.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Working Gaia / Broken Gecko = No repro
Gaia: deb73e71e32ccc26261de33d9f857ce5d429e2f6
Gecko: 104a51033ef9
Broken Gaia / Working Gecko = Repro
Gaia: 9f9e2d948104e0173a7cb145b96661f80d55ff9a
Gecko: b6b405a253d9
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/deb73e71e32ccc26261de33d9f857ce5d429e2f6...9f9e2d948104e0173a7cb145b96661f80d55ff9a
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Broken by bug 1048160 ? Can you take a look Francisco?
Blocks: 1048160
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(francisco)
Attachment #8478988 - Flags: review?(anthony) → review?(francisco)
Comment on attachment 8478988 [details]
23317.html

Could you include some testing for this?

Perhaps integration ones?

I'm giving here the r+, if you don't feel confortable adding that test, please open a follow up bug to add it.

Thanks
Attachment #8478988 - Flags: review?(francisco) → review+
Flags: needinfo?(francisco)
Target Milestone: 2.1 S3 (29aug) → 2.1 S4 (12sep)
Hello Francisco,

I have already done the integration tests. I have been learning how do them.

I have done the "organization filed" tests, but i think that we should open a new bug to do the tests from the other fields because they don't exist.

You can see the change that I have done on the PR.

Thanks!
Flags: needinfo?(francisco)
Amazing job!

Jorge, thanks a lot for adding the integration tests. You are contributing to make our code more and more robust.

I still didn't merge since we got a fail in our unit tests, (not the new integration one), I've relaunched this unit test and will merge once everything is green.

Thx
Flags: needinfo?(francisco)
triage: identifiable regression
blocking-b2g: 2.1? → 2.1+
Attached file 23701.html
Attachment #8478988 - Attachment is obsolete: true
Comment on attachment 8484060 [details]
23701.html

Hello Francisco,

I have already repaired the problems and all unit tests pass.
Attachment #8484060 - Flags: review?(francisco)
Comment on attachment 8484060 [details]
23701.html

Excellent job!

Thanks a lot, also loving that we have more tests than code, which I love.
Attachment #8484060 - Flags: review?(francisco) → review+
Landed:

https://github.com/mozilla-b2g/gaia/commit/5b957fc0d7d12f56d4840abbb5049ec6d536635c
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8484060 [details]
23701.html

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
New contact form redesign
[User impact] if declined:
User cannot edit properly a contact
[Testing completed]:
Added integration tests, smoke test done.
[Risk to taking this patch] (and alternatives if risky):
Not risky, change is 1 line of code and we are adding tons of test for this :)
[String changes made]:
Attachment #8484060 - Flags: approval-gaia-v2.1?(fabrice)
Comment on attachment 8484060 [details]
23701.html

thanks for the additional tests here!
Attachment #8484060 - Flags: approval-gaia-v2.1?(fabrice) → approval-gaia-v2.1+
This issue is verified fixed on Flame 2.2 & Flame 2.1

Device: Flame 2.2 Master KK (319mb) (Full Flash)
BuildID: 20141010040202
Gaia: 1036b544b7e102592bd9fab95cd9317329ac1293
Gecko: 50b689feab5f
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Device: Flame 2.1 KK (319mb) (Full Flash)
BuildID: 20141010000201
Gaia: bc8eb493311c58f1f311a56b8b645b52bfbd2f71
Gecko: 72c13d8631ff
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Deleting the company name of a contact in edit mode then updating functions correctly. The company name no longer appears in contact after being deleted.
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.