Create Configure.pl script for Bugzilla

RESOLVED WONTFIX

Status

()

Bugzilla
Installation & Upgrading
P2
enhancement
RESOLVED WONTFIX
17 years ago
4 years ago

People

(Reporter: zach, Assigned: zach)

Tracking

Dependency tree / graph

Details

(Assignee)

Description

17 years ago
Have a configure script which looks 
at various config info, tries to figure things out, and asks questions (but 
has a defaults mode for cronjobs to run non-interactively). Once the 
questions have been asked, it generates a Makefile and other config files.
(Assignee)

Comment 1

17 years ago
cc'ing all cc's from the meta bug
(Assignee)

Updated

17 years ago
Blocks: 44659
(Assignee)

Comment 2

17 years ago
Ok, we have a configure system designed to do what we need for now. 
The only problem is that it does nothing useful since we have no 
questions at the moment (since we need to know what the questions 
are...). Right now it has all the hooks and API foo (Conf.pm) and outputs a 
file with the configuration to load defaults into later and parses a 
Makefile.in into a Makfile. All vars like **somevar** become whatever 
somevar was set to in Configure $main::c{somevar}. It still has some 
issues, doesn't use strict, etc, but that will be dealt with in due course. 
The important thing is that we now have a stable enough configure 
platform to let the Configure Scene come to a close and let the Makefile.in 
Scene begin. When the Makefile people (which I am NOT NOT NOT (I am 
Makefile challenged) need Configure input, they can post the question 
here and I will add that to configure.

--Zach
(Assignee)

Comment 3

17 years ago
Ok, we have a configure system (on the branch, bugzilla_newinstall) 
designed to do what we need for now. The only problem is that it does 
nothing useful since we have no questions at the moment (since we 
need to know what the questions are...). Right now it has all the hooks 
and API foo (Conf.pm) and outputs a file with the configuration to load 
defaults into later and parses a Makefile.in into a Makfile. All vars like **
somevar** become whatever somevar was set to in Configure 
$main::c{somevar}. It still has some issues, doesn't use strict, etc, but 
that will be dealt with in due course. The important thing is that we now 
have a stable enough configure platform to let the Configure Scene come 
to a close and let the Makefile.in Scene begin. When the Makefile people 
(which I am NOT NOT NOT (I am Makefile challenged) need Configure 
input, they can post the question here and I will add that to configure.

--Zach
Priority: -- → P2
Target Milestone: --- → Bugzilla 2.18
(Assignee)

Comment 4

16 years ago
*** Bug 109312 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

16 years ago
Blocks: 147776
(Assignee)

Comment 5

16 years ago
I made pretty good progress on Configure.pl, Conf.pm and friends during my
escape to Australia. I think I'll make a new branch and land those changes there
in the coming week after I get some bugs worked out. Also, I need to get some
more details about newinstall out for comments. Don't worry, this hasn't been
forgotten. Stand by.
(Assignee)

Comment 6

16 years ago
We need to fix 171674 (File::Temp and 5.6.0) in newinstall as well. If you 
haven't yet, check out the newinstall branch: things are happening. cvs -z3 co -
d bugzilla -rbugzilla_newinstall Bugzilla
Depends on: 171674

Comment 7

15 years ago
Unloved bugs targetted for 2.18 but untouched since 9-15-2003 are being
retargeted to 2.20
If you plan to act on one immediately, go ahead and pull it back to 2.18.
Target Milestone: Bugzilla 2.18 → Bugzilla 2.20

Comment 8

14 years ago
Wow... now what ever happened to *this*? I don't fully understand what sort of
improvement this is over checksetup, from the comments here on this bug.
Severity: normal → enhancement
OS: other → All
Hardware: Other → All
Summary: Create configure script for bugzilla → Create a script that deals with all configuration details
(Assignee)

Comment 9

14 years ago
This is/was a tracking bug for newinstall, a new (perhaps stalledinstall would
be a better name though) installation system which uses the more normal
"Configure.pl && make && make test && make install process" and many other
improvements. Of course, someone needs to actually finish this system, but
that's what this bug is from. 
Summary: Create a script that deals with all configuration details → Create Configure.pl script for Bugzilla

Comment 10

14 years ago
Ahh.

For the record, I don't see the advantage of using a Makefile install. :-)
Makefiles are complex nightmares, used for compiling code and dependencies. Perl
is nice for the sort of stuff that we need to set up and configure. Also, more
of the developers understand and can use Perl, making it much easier to modify a
wholly perl-based installation system.

From what I can see, in fact, newinstall stalled partly on the fact that nobody
had Makefile skills.

Comment 11

13 years ago
I vote to WONTFIX this, at this point.
Target Milestone: Bugzilla 2.20 → ---

Updated

12 years ago
QA Contact: mattyt-bugzilla → default-qa

Comment 12

12 years ago
I suggest WONTFIX too. checksetup.pl is working really well; it doesn't make sense to restart from scratch.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.