Closed Bug 1058759 Opened 5 years ago Closed 5 years ago

Change default URL of about:home snippets service

Categories

(Firefox :: General, defect)

defect
Not set
Points:
1

Tracking

()

RESOLVED FIXED
Firefox 35
Iteration:
35.2

People

(Reporter: osmose, Assigned: avp)

References

Details

Attachments

(1 file)

Currently, the about:config setting browser.aboutHomeSnippets.updateUrl has the hardcoded domain 'https://snippets.mozilla.com' in it. We'd like to update this to point to 'https://snippets.cdn.mozilla.net' instead, so users are requesting snippets from our CDN.
Points: --- → 1
Flags: firefox-backlog+
Flags: qe-verify?
Blocks: 1046297
Assignee: nobody → abhishekp.bugzilla
Attachment #8486295 - Flags: review?(mkelly)
Comment on attachment 8486295 [details] [diff] [review]
Changed default URL of about:home snippets service to Mozilla's CDN

Review of attachment 8486295 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me, r+ :D
Attachment #8486295 - Flags: review?(mkelly) → review+
Flags: qe-verify? → qe-verify+
Is this ready to be checked in?
Flags: needinfo?(mkelly)
Yep, this is good to go!
Flags: needinfo?(mkelly)
Status: NEW → ASSIGNED
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/347d06afb237
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 35
Gavin: Is this change a candidate for uplifting?
Flags: needinfo?(gavin.sharp)
Sure. Where do you want it?
Flags: needinfo?(gavin.sharp)
(In reply to :Gavin Sharp [email: gavin@gavinsharp.com] from comment #8)
> Sure. Where do you want it?

I assume you mean when. :)

We would like to get these snippet performance issues wrapped up as we are holding from doing more advanced snippets given the performance caused by static assets. 

What's your timeline on getting it up on beta?
Iteration: --- → 35.2
I meant "which channel do you want it uplifted to". I can uplift it this week.
Please hold off on uplifting this off of nightly for at least a week, and after that, let's uplift to Aurora at least for another week. I don't want to just immediately uplift this to beta without at least a bit of time to see how the CDN affects load on the snippets service.
I guess the better question is: Is "spend a minimum of one week on Nightly, then uplift to Aurora once we've had a chance to look at the stats over that week, and then repeat that process prior to uplifting to Beta" a reasonable/possible plan?
Sure, whatever works best for you. We have a daily update cycle on Nightly/Aurora (though it can take roughly a week to migrate most users to the latest version), and new beta builds go out twice weekly (with a similar update lag). We don't want to uplift to beta too late in the cycle, and we're pretty much at the midpoint now, so if you want to hit the 33 release there's not much time for testing on beta left.
(In reply to :Gavin Sharp [email: gavin@gavinsharp.com] from comment #13)
> Sure, whatever works best for you. We have a daily update cycle on
> Nightly/Aurora (though it can take roughly a week to migrate most users to
> the latest version), and new beta builds go out twice weekly (with a similar
> update lag). We don't want to uplift to beta too late in the cycle, and
> we're pretty much at the midpoint now, so if you want to hit the 33 release
> there's not much time for testing on beta left.

Let's give it some time on nightly and jump over to Aurora to get some more data. It is probably likely we'll pass the window for beta and will have to wait until the next release.
Cool, I'll update this bug when we're ready to uplift. Thanks!
I don't think the QA team needs to spend time verifying this manually, as you look at data anyhow to tell if the pref change works and what it brings us.
Flags: qe-verify+ → qe-verify-
After some testing of the effects, we've found the CDN won't solve some of our immediate problems, but still has benefits in it's use. It's good to ride the trains normally, but unless something changes (or I'm wrong), we won't be asking for this to be uplifted. Thanks!
See Also: → 1310118
You need to log in before you can comment on or make changes to this bug.