Closed Bug 1059032 Opened 5 years ago Closed 5 years ago

can't rearrange e10s tabs: JavaScript error: chrome://browser/content/tabbrowser.xml, line 3920: invalid 'in' operand draggedTab._dragData

Categories

(Firefox :: Tabbed Browser, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 34
Tracking Status
e10s + ---
firefox33 --- unaffected
firefox34 --- affected
firefox36 --- verified

People

(Reporter: cpeterson, Assigned: billm)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(1 file)

STR:
Try to drag and rearrange some tabs with e10s enabled.

RESULT:
You can rearrange tabs in the chrome process (like about:home or about:newtab), but you can't rearrange tabs in the content process.

I see tons of JS errors in the Browser Console:

JavaScript error: chrome://browser/content/tabbrowser.xml, line 3920: invalid 'in' operand draggedTab._dragData
JavaScript error: chrome://browser/content/tabbrowser.xml, line 4611: invalid 'in' operand draggedTab._dragData

* This seems to be a regression between good build 2014-08-19 and bad build 2014-08-24.
Regression window(m-i)
Good:
https://hg.mozilla.org/integration/mozilla-inbound/rev/72f6354159d5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0 ID:20140820124716
Bad:
https://hg.mozilla.org/integration/mozilla-inbound/rev/304619045d61
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0 ID:20140820125117
Puahlog;
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=72f6354159d5&tochange=304619045d61

Suspect: Bug 1051017
Blocks: 1051017
Attached patch fix-draggingSplinter Review
We were getting an exception trying to make the thumbnail and that prevented us from filling in the drag fields.
Assignee: nobody → wmccloskey
Status: NEW → ASSIGNED
Attachment #8480032 - Flags: review?(felipc)
Attachment #8480032 - Flags: review?(felipc) → review+
https://hg.mozilla.org/mozilla-central/rev/2692c5ae8581
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 34
Flags: qe-verify+
I was able to reproduce this bug on Nightly 36.0a1 (2014-08-26) using Ubuntu 14.04 x32 and Windows 8.1 x64.

Verified fixed on Ubuntu 14.04 x32, Windows 8.1 x64 and Mac OSX 10.8.5 using Latest Nightly 36.0a1 (2014-11-12)
Status: RESOLVED → VERIFIED
Depends on: 1163478
You need to log in before you can comment on or make changes to this bug.