Status

()

RESOLVED WORKSFORME
17 years ago
17 years ago

People

(Reporter: blackback, Assigned: jst)

Tracking

({helpwanted})

Trunk
mozilla1.1alpha
x86
Windows 98
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
Page is totally illegible. Graphics display properly but tables do not display
background colors or text properly. Page looks OK in MSIE 5.5 and Netscape 4.78.

This may be due to sub-standandard HTML or errors on the page itself or may be
an issue with Mozilla. Don't know.
(Reporter)

Comment 1

17 years ago
Created attachment 54414 [details]
screen shot from Mozilla 0.94 (0.95 looks the same)

Comment 2

17 years ago
Disabling JavaScript will make the page readable.

Comment 3

17 years ago
It only becomes readable because they've provided noscript alternatives.

Most of the page appears to be dynamically generated by document.write() calls
in javascript.  Including most of the colour information, which appears to be in
the form of dynamically-written <font color...> and <td bgcolor...> tags.

The only <body> tag I can find _anywhere_ is inside a <noscript></noscript> pair.
The only </body> tag I can see is dynamically written by JS.  So you'll get one
or the other, but not both.  Lovely.

I think this site in in need of some SERIOUS tech evangelism.  It boggles me
that any browser can cope with this.

HOWEVER.  If I obtain the processed source (i.e after all the javascript has
been  processed - NS 4.75 seems to give me this when I view source, and I'm not
going to argue right now) and view THAT in Moz, things are much improved.  Not
perfect, but waaaay better.  I'll attach that source in a sec...

Could this be another issue with dynamically-generated stuff (in this case, <td
bgcolor=...>) not being processed properly?

I'm pretty sure this ISN'T layout, but I've got no idea where it _should_ go...

Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

17 years ago
Created attachment 54424 [details]
post-JS-processing html of the page (looks OK in Moz)
-> DOM 0 (or maybe style system)?
Assignee: attinasi → jst
Component: Layout → DOM Level 0
QA Contact: petersen → amar
(Assignee)

Updated

17 years ago
Keywords: helpwanted
Target Milestone: --- → mozilla0.9.9
(Reporter)

Comment 6

17 years ago
I wote the author of the page and let him know I opened a bugzilla ticket. 
Apparently, the ball's in his court. Thanks.
(Assignee)

Comment 7

17 years ago
Pushing out to mozilla1.1.
Target Milestone: mozilla0.9.9 → mozilla1.1

Comment 8

17 years ago
OK, the author of this page has been busy.  The source now looks much better
(still no </body> tag, but otherwise much improved), and the page now renders
pretty well (win98SE, 2002050406, 1.0 Branch)

Since there's no testcase here for whatever problem in Moz this page may have
exposed, marking WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.