Closed Bug 1059096 Opened 8 years ago Closed 8 years ago

network error pages (about:neterror) have "XML Parsing Error: undefined entity" - due to Bug 1042196

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(firefox33 unaffected, firefox34+ fixed, fennec34+)

RESOLVED FIXED
Firefox 34
Tracking Status
firefox33 --- unaffected
firefox34 + fixed
fennec 34+ ---

People

(Reporter: capella, Assigned: wesj)

References

Details

(Keywords: regression)

Attachments

(2 files)

Currently on nightly when I go to page http://gifsforum.com/gifs/

I get : https://www.dropbox.com/s/gw50mkhdhd0vbh3/Screenshot_2014-08-27-02-51-32.png?dl=0

Looks like we missed a bit
Blocks: 1042196
tracking-fennec: --- → ?
Attached image screenshot.png
What's interesting as this was warned against in bug 1042196 heh.
I was going to add a patch to just rename the var correctly, but I'm still puzzled at the intent there ... after I changed it and tested it locally, it runs w/o failing, but the message opens a small window that's got scrollable content below screen level so-to-speak with the "try again" button etc.
Apparently not all references were renamed. e.g. https://hg.mozilla.org/mozilla-central/rev/8f00edcf2962#l2.17
Assignee: nobody → wjohnston
Duplicate of this bug: 1059444
In particular, we removed the entity "connectionFailure.longDesc" from the .dtd file:
>-<!ENTITY connectionFailure.longDesc "&sharedLongDesc2;">
>+<!ENTITY connectionFailure.longDesc2 "&sharedLongDesc3;">
http://hg.mozilla.org/mozilla-central/rev/8f00edcf2962#l5.12

...but we didn't remove its usage here in netError.xhtml:
>         <div id="ed_connectionFailure">&connectionFailure.longDesc;</div>
http://hg.mozilla.org/mozilla-central/rev/8f00edcf2962#l2.17
Keywords: regression
Summary: Regression: wifi toggle widget on error pages - due to Bug 1042196 → network error pages (about:neterror) have "XML Parsing Error: undefined entity" - due to Bug 1042196
Version: unspecified → Trunk
Flags: needinfo?(wjohnston)
Yeah, its linked in multiple places in netError. I only fixed one of 'em. Testing a fix.
Flags: needinfo?(wjohnston)
Attached patch PatchSplinter Review
Attachment #8480079 - Flags: review?(markcapella)
Comment on attachment 8480079 [details] [diff] [review]
Patch

Review of attachment 8480079 [details] [diff] [review]:
-----------------------------------------------------------------

wfm ... verify that https://www.dropbox.com/s/totb7tmwvo35xo8/netError.mp4?dl=0 is the desired UI experience? (small / scrollable "Unable to connect' box) ?
Attachment #8480079 - Flags: review?(markcapella) → review+
For now yeah. We should file something about making these responsive to small heights maybe.
Duplicate of this bug: 1059538
[Tracking Requested - why for this release]: noticeable regression, might be needed if this fix bounces off 34 nightly
tracking-fennec: ? → 34+
https://hg.mozilla.org/mozilla-central/rev/c2946ccbe3ff
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 34
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.