"hidden" css style does not hide select element scroll bar

RESOLVED DUPLICATE of bug 92333

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 92333
17 years ago
17 years ago

People

(Reporter: Thomas Passin, Assigned: Marc Attinasi)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Mozilla 0.9.5. css style with visibility:hidden does not hide the scroll bar of
a select element.  Same code works correctly in Internet Explorer.  Here is a
page that demonstrates the problem:


<html>
<head><title>Hidden Style Bug Demo</title>
<style type='text/css'>
    #div1 {background-color:lightblue;
        border:solid black;border-width:thin;
        visibility:visible}
</style>

<script type='text/javascript'>
    var stylesheet,rules,ruleDiv1
    stylesheet=document.styleSheets[0]
    rules=stylesheet.rules||stylesheet.cssRules // IE or Moz
    ruleDiv1=rules.item(0)

	var next_state=new Array()
	next_state['visible']='hidden'
	next_state['hidden']='visible'

	function toggle(){
		with (ruleDiv1.style){
			visibility=next_state[visibility]
		}
	}	
</script>
</head>

<body>

<div id='div1'>
<h3>Div1</h3>
<form><select size='10'></select>
</form>
</div>

<br>
<form>
	<input type='button' 
		value='Toggle Visibility' onclick='toggle()'>
</form>

</body>
</html>
duplicate of "Select box scrollbar is not hidden with visibility:hidden
property."

*** This bug has been marked as a duplicate of 92333 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.