[Flame][Intermittent]Switching from Contacts to Dialer is causing issues while navigating through them

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Dialer
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: Marcela Oniga, Unassigned)

Tracking

({regression})

unspecified
x86
Linux
regression

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.1 affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8480062 [details]
2014-08-27-21-58-23.png

Steps to reproduce:
1. Open Phone app and click to Contacts
2. Open Contacts settings, click Done and then quickly open Dialer


Expected results:
Dialer should be opened.

Actual results:
Button is pressed but there is Contacts displayed instead of Dialer, please see the attached screenshot.

Note: This is an intermittent issue, happening 2/3 times.

Gaia   6e804a42ab90f4251c7fe8c68731dc1c6abd8006
SourceStamp 0753f7b93ab7
BuildID 20140827040203
Version 34.0a1
I repro'd it on 2.1 easily since the first try. I didn't manage on 2.0 though (tried 10 times). I did it with the same dataset of contacts (about 450).

Looks like a minor regression to me.
status-b2g-v2.0: --- → unaffected
status-b2g-v2.1: --- → affected
Keywords: regression
Yeah I've noticed that but also some less than reactive tabs in general. A logcat or a regression window may help.
(Reporter)

Comment 3

4 years ago
Created attachment 8483622 [details]
log.txt

Logcat output attached
This looks very suspicious:

E/GeckoConsole( 1443): [JavaScript Error: "TypeError: this._contactsHome is not a function" {file: "app://communications.gaiamobile.org/dialer/gaia_build_defer_index.js" line: 102}]

Updated

4 years ago
Blocks: 1036516
(Reporter)

Comment 5

4 years ago
I was able to reproduce the issue using Aurora 2.1, same steps:

Gaia   a47ecb6368c015dd72148acde26413fd90ba3136
SourceStamp 757931d0149e
BuildID 20140904000203
Version 34.0a2
I can't reproduce this anymore with the STR in comment 0. Reopen the bug if this is still a problem.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.