port NPAPI tester plugin to other platforms

RESOLVED DUPLICATE of bug 386676

Status

()

P4
normal
RESOLVED DUPLICATE of bug 386676
17 years ago
10 years ago

People

(Reporter: serhunt, Assigned: jaas)

Tracking

({platform-parity})

Trunk
Future
platform-parity
Points:
---
Bug Flags:
wanted1.9.0.x +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PL2:P4])

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
We nees a convenient tool which would allow to issue NPAPI calls and log the 
result for testing purposes. The place is mozilla/modules/plugin/tools/tester.

Comment 1

17 years ago
Tester plugin is there on windows and works pretty good.

Changing summary to port tester plugin to other platforms :)
Keywords: pp
Summary: Create a tester plugin → port NPAPI tester plugin to other platforms

Comment 2

17 years ago
Created attachment 75699 [details] [diff] [review]
patch to support NPN_ReqestRead() testing

I used it as a test case for bug 115891, bug 120411
av, peter would you please review this?
(Reporter)

Comment 3

17 years ago
Comment on attachment 75699 [details] [diff] [review]
patch to support NPN_ReqestRead() testing

Wow! I even forgot I did not implement this. This is great. I guess the
following is not terribly necessary:

-DWORD convertStringToNPPVariable1(DWORD * pdw1);
+DWORD convertStringToNPPVariable1(DWORD * pdw1);;

And you can take a full advantage of the project not being part of the regular
build, just mention this fact in check in comments.
Attachment #75699 - Flags: review+
(Reporter)

Comment 4

17 years ago
Comment on attachment 75699 [details] [diff] [review]
patch to support NPN_ReqestRead() testing

Sorry, forgot... r=av

Comment 5

17 years ago
on the trunk w/o extra ; in tester/include/strconv.h
thanks.

Comment 6

17 years ago
reassigning to anthony, Anthony you'll need to get the scoop from serge, av and
peterl
Assignee: av → anthonyd
Severity: normal → minor
Priority: -- → P4
Whiteboard: [PL2:P4]
Target Milestone: --- → Future

Updated

17 years ago
Severity: minor → normal

Comment 7

16 years ago
--->peterl
Assignee: anthonyd → peterlubczynski
(Assignee)

Updated

13 years ago
Assignee: peterlubczynski-bugs → joshmoz
We have zero (none, bupkiss) plugin test coverage in our automated suite.  Poking this on the off chance that it still has the right assignee.
Flags: wanted1.9.0.x?

Comment 9

11 years ago
I will offer to mentor a student willing to write/fix/extend the NPAPI tester plugin for the Google Summer of Code: http://wiki.mozilla.org/Community:SummerOfCode08:Brainstorming#Mozilla_Platform

I especially want comprehensive tests of the scriptable NPAPI.
Not going to block a minor release on this.
Flags: wanted1.9.0.x? → wanted1.9.0.x-
I didn't ask for it to block, I asked for it to be marked "wanted" as an indication that we'd take such a fix on the branch to give us some shred of test coverage there. :(
Flags: wanted1.9.0.x- → wanted1.9.0.x?
Wanted, but is anyone working on this? Josh?
Flags: wanted1.9.0.x? → wanted1.9.0.x+
QA Contact: shrir → plugins

Updated

10 years ago
Depends on: 471759
Duping forward, we have a test plugin now. File new bugs for specific capabilities that would improve testing.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 386676
You need to log in before you can comment on or make changes to this bug.