Bustage: > 0:34.61 MSVCRT.lib(crtexe.obj) : error LNK2019: unresolved external symbol _main referenced in function ___tmainCRTStartup

RESOLVED FIXED in mozilla36

Status

defect
--
blocker
RESOLVED FIXED
5 years ago
4 months ago

People

(Reporter: masayuki, Assigned: jimm)

Tracking

({regression})

Trunk
mozilla36
x86_64
Windows 8.1
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

fix
747 bytes, patch
alessarik
: review+
Details | Diff | Splinter Review
>  0:34.61 Executing: link -NOLOGO -OUT:CommandExecuteHandler.exe -PDB:CommandExecuteHandler.pdb -SUBSYSTEM:CONSOLE,5.01 -LARGEADDRESSAWARE -NXCOMPAT -DYNAMICBASE -SAFESEH -DEBUG -DEBUGTYPE:CV @a:\mozilla\mc-c\fx-dbg\browser\metro\shell\commandexecutehandler\tmp1ro9an.list module.res kernel32.lib user32.lib gdi32.lib winmm.lib wsock32.lib advapi32.lib secur32.lib netapi32.lib kernel32.lib user32.lib ole32.lib shlwapi.lib propsys.lib advapi32.lib wininet.lib
>  0:34.61 a:\mozilla\mc-c\fx-dbg\browser\metro\shell\commandexecutehandler\tmp1ro9an.list:
>  0:34.61     CEHHelper.obj
>  0:34.61     CommandExecuteHandler.obj
>  0:34.61
>  0:34.61 MSVCRT.lib(crtexe.obj) : error LNK2019: unresolved external symbol _main referenced in function ___tmainCRTStartup
>  0:34.61
>  0:34.61 CommandExecuteHandler.exe : fatal error LNK1120: 1 unresolved externals
>  0:34.61
>  0:34.62 a:/mozilla/mc-c/src/config/rules.mk:676: recipe for target 'CommandExecuteHandler.exe' failed
>  0:34.62 mozmake.EXE[5]: *** [CommandExecuteHandler.exe] Error 1120
>  0:34.63 a:/mozilla/mc-c/src/config/recurse.mk:85: recipe for target 'browser/metro/shell/commandexecutehandler/target' failed
>  0:34.63 mozmake.EXE[4]: *** [browser/metro/shell/commandexecutehandler/target] Error 2
>  0:34.63 mozmake.EXE[4]: *** Waiting for unfinished jobs....

I can reproduce this with current m-c. I couldn't reproduce this yesterday's m-c.
FYI: If --enable-metro is not specified, this bug isn't reproduced.
I'll take a look, I haven't built w/metro code in a couple weeks. :/
maybe this is regression of bug 1001332?
(In reply to Jim Mathies [:jimm] from comment #2)
> I'll take a look, I haven't built w/metro code in a couple weeks. :/
Do you need help for this bug? We realy need to synchronize bug 977003 to project/metro branch.
Blocks: 1042108
(In reply to Maksim Lebedev from comment #4)
> (In reply to Jim Mathies [:jimm] from comment #2)
> > I'll take a look, I haven't built w/metro code in a couple weeks. :/
> Do you need help for this bug? We realy need to synchronize bug 977003 to
> project/metro branch.

waiting on a resolution to bug 1071568.
(In reply to Masayuki Nakano (:masayuki) (Mozilla Japan) from comment #0)
> >  0:34.61 Executing: link -NOLOGO -OUT:CommandExecuteHandler.exe -SUBSYSTEM:CONSOLE,5.01
> >  0:34.61 MSVCRT.lib(crtexe.obj) : error LNK2019: unresolved external symbol _main
Some investigation:
Maybe the issue is in wrong -SUBSYSTEM:CONSOLE,5.01
Maybe the correct value is -SUBSYSTEM:WINDOWS,5.01
Because CommandExecuteHandler.cpp contains "int APIENTRY wWinMain" function
Some investigation:
Maybe we should #define flag MOZ_WINCONSOLE as 0
Posted patch fix (obsolete) — Splinter Review
stole this from plugin-container.exe.
Assignee: nobody → jmathies
Attachment #8507423 - Flags: review?(alessarik)
Comment on attachment 8507423 [details] [diff] [review]
fix

I might have something cleaner.
Attachment #8507423 - Flags: review?(alessarik)
Posted patch fixSplinter Review
Attachment #8507423 - Attachment is obsolete: true
Comment on attachment 8507507 [details] [diff] [review]
fix

can you check this to be sure it addresses the problem? I had to do a mach build to get it to kick in.
Attachment #8507507 - Flags: review?(alessarik)
Comment on attachment 8507507 [details] [diff] [review]
fix

(In reply to Jim Mathies [:jimm] from comment #11)
> can you check this to be sure it addresses the problem? I had to do a mach
> build to get it to kick in.
Yes. Patch fixed issue. I got file CommandExecureHandler.exe
Attachment #8507507 - Flags: review?(alessarik) → review+
https://hg.mozilla.org/mozilla-central/rev/99e0716c5d66
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla36
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.