navy.mil - popup window incorrectly claims ``Clock requires Netscape''

RESOLVED INVALID

Status

Tech Evangelism
Desktop
--
minor
RESOLVED INVALID
16 years ago
3 years ago

People

(Reporter: dcary, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.5) Gecko/20011011
BuildID:    2001101117

When I see the claim ``Clock requires Netscape'',
I'm almost certain that Mozilla can do it also.


Reproducible: Always
Steps to Reproduce:
1. Go to http://tycho.usno.navy.mil/what1.html
2. click the button ``CST/DST''.


Actual Results:  Then a popup window appears saying ``Clock requires Netscape''
with a ``Stop'' button.


Expected Results:  I expected Mozilla to display an animated
clock (with the seconds incrementing).


I *think* the ``CST/DST'' button is merely trying to open page
  http://tycho.usno.navy.mil/ctclock.html
.
Workaround: If I manually go to page
  http://tycho.usno.navy.mil/ctclock.html
then Mozilla correctly displays the animated clock.

(So maybe this is an actual JavaScript bug, not evangelism ?)
That text is actually the ALT text for an animated gif... do you have animated
gifs turned off?
worksforme.  Reporter, please reopen if you still see this once you have made 
sure you are not blocking images from any relevant servers
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

16 years ago
I just installed
Mozilla 1.0 Release Candidate 3
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0rc3) Gecko/20020523
and I still see this bug. But I've discovered that *sometimes* that clock works
for me now. Here's a longer sequence of steps that seems to be more reproducible.

1. Completely exit Mozilla.
2. Start Mozilla, and go to http://tycho.usno.navy.mil/what1.html
3. click the button ``CST/CDT'' once.
4. Close the small window by clicking on the word ``stop''. (Is this different
than clicking the X in the window title bar ?).
5. click the button ``CST/CDT'' once again.
6. With Mozilla still open, go directly to
http://tycho.usno.navy.mil/cgi-bin/nph-usnoclock.gif?zone=CST;ticks=31

Before step 5, everything works as expected. A small window pops up and displays
the time. I see the seconds count away.

After step 5,
The small window pops up again, but this time I see the
``Clock requires Netscape'' error message.
I expected to see the same clock (with a slightly later time, of course) after
step 5 that I saw I saw after step 3.

Step 6 gives me this message:
--
  The image
“http://tycho.usno.navy.mil/cgi-bin/nph-usnoclock.gif?zone=CST;ticks=31” cannot
be displayed, because it contains errors.
--
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 4

16 years ago
Your description is correct in every detail. I actually save the file given by
the last link. Also my image viewer complaint, it would be an invalid format. So
there is nothing Mozilla could display. Marking WFM.

pi
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

14 years ago
Re-opening. Today I should see a running clock, but instead I (still) see the
text "Clock requires Netscape".

I agree with Piwinger that the bug is almost certainly at the server end, not
with the Mozilla browser software. This sort of bug needs to be filed under
"Tech Evangelism", not "WorksForMe", right ?
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 6

14 years ago
this works for me in mozilla 2003081809/win2k. if this does not work for you
please provide more details on your build/operating system etc. if you are using
something older than mozilla 1.4 or are using a older 1.5a build, please update
to a newer build before reopening.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago14 years ago
Resolution: --- → WORKSFORME

Comment 7

14 years ago
dcary is correct. When you open the window a seceond time the error occurs.

pi
Status: RESOLVED → UNCONFIRMED
OS: Windows 98 → All
Hardware: PC → All
Resolution: WORKSFORME → ---

Comment 8

14 years ago
Confirming.

pi
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 9

14 years ago
Ok. I see it now. 

1. Click on any of the buttons to display the clock.
2. Click on the close window X
3. Click on the same button again to display the clock.
4. Click stop / exit (depending on button) to close the window
5. Click on the button again.

The animated clock works until you do step 5 when the image fails to display and
you get the ALT text.

The difference is the Exit / Stop button does win = window.close(). I am
assuming something is leaked and the nph output for the image is not received.

jst, what do you think? I think this is a bug in the browser either in DOM 0
(because of the window.close interaction) or something in netwerk or images.
Summary: popup window incorrectly claims ``Clock requires Netscape'' → navy.mil - popup window incorrectly claims ``Clock requires Netscape''

Comment 10

14 years ago
->default
Assignee: bc → english-us
QA Contact: zach → english-us

Comment 11

13 years ago
problem still exists
seems to work fine

Comment 13

7 years ago
The tag ALT="Clock requires Netscape" of the above mentioned GIF is still there but the popup is displayed just fine. Plus, the "How to" page (http://tycho.usno.navy.mil/howclock.html) states the following:

>> "A note about browsers...
>> The running GIF clock was developed for browsers that support
>> 
>>     Content-type:  multipart/x-mixed-replace
>>     
>> 
>> Netscape and Mozilla do this correctly. Internet Explorer does not." 

So this is WFM.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.9) Gecko/20100824 Firefox/3.6.9
→ ping tycho.usno.navy.mil
PING tycho.usno.navy.mil (199.211.133.239): 56 data bytes
Request timeout for icmp_seq 0
Request timeout for icmp_seq 1
Request timeout for icmp_seq 2
Request timeout for icmp_seq 3
Request timeout for icmp_seq 4
Request timeout for icmp_seq 5
Assignee: english-us → nobody
Status: NEW → RESOLVED
Last Resolved: 14 years ago3 years ago
Component: English US → Desktop
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.