Closed Bug 1059822 Opened 6 years ago Closed 6 years ago

[LockScreen] SIM pin request page in front of camera when rebooting, sim pin on and unlock to camera

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S4 (12sep)
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- verified
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: echang, Assigned: gduan)

Details

(Keywords: regression, Whiteboard: [system-platform])

Attachments

(6 files)

Attached image 2014-08-28-08-46-16.png
### STR
1. Turn SIM pin on, lock screen on. 
2. Reboot.
3. Slide to Camera

### Actual
SIM pin page shown on top of camera
2014-08-28-08-46-16.png

### Version 
Gaia      3a838afca295c9db32e1a3ec76d49fb7fe7fd2d2
Gecko     https://hg.mozilla.org/mozilla-central/rev/5f0b5cc8f78d
BuildID   20140827160207
Version   34.0a1
ro.build.version.incremental=110
ro.build.date=Fri Jun 27 15:57:58 CST 2014
B1TC00011230
Hi Alive, Could you take a look at this, thank you.

[Blocking Requested - why for this release]: SIM pin request is unnecessary for accessing camera here.
blocking-b2g: --- → 2.1?
Flags: needinfo?(alive)
Looks like a regression, please help to find out the regression window.
Flags: needinfo?(alive)
I cannot reproduce with latest master.
Last good build
https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/nightly/mozilla-central-flame-eng/2014/05/2014-05-29-04-02-01/

20140523160204 okay
20140527160201 okay
20140529040201 okay
20140529113510 fail
20140529160204 fail
20140531160201 fail

20140827160207 fail
I'm unable to reproduce this issue on Flame 2.1 and Flame 2.0.

Observed behavior: After reboot, sliding LEFT to launch camera from lockscreen is successful - no SIM pin is requested in this scenario. Repro rate 0/6 on 2.1, and 0/3 on 2.0.

Tested on:
Device: Flame
BuildID: 20140829061359
Gaia: 007f3c50cf69f044628a23c2376c6d88aa45f617
Gecko: d728b2f31c56
Version: 34.0a1 (2.1 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Device: Flame
BuildID: 20140827201151
Gaia: ee5cf3aff7e66ec5e899bdffa27ef51bfa40f0f0
Gecko: 218771782328
Version: 32.0 (2.0)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
Flags: needinfo?(jmitchell)
Eric - several people have not been able to repro on the latest master - your tests indicated testing from 2 days ago - when you get the time would you mind checking in the latest build?
Flags: needinfo?(jmitchell) → needinfo?(echang)
I still can reproduce this with today's master, firmware 123, 1GB ram, I've asked help from Alive to see what goes wrong.

Gaia      2be78d83a760fa3b9638fe51c266b442d14597f1
Gecko     https://hg.mozilla.org/mozilla-central/rev/1db35d2c9a2f
BuildID   20140831160203
Version   34.0a1
ro.build.version.incremental=110
ro.build.date=Fri Jun 27 15:57:58 CST 2014
B1TC00011230
Flags: needinfo?(echang) → needinfo?(alive)
(In reply to Eric Chang [:ericcc] [:echang] from comment #7)
> I still can reproduce this with today's master, firmware 123, 1GB ram, I've
> asked help from Alive to see what goes wrong.
> 
> Gaia      2be78d83a760fa3b9638fe51c266b442d14597f1
> Gecko     https://hg.mozilla.org/mozilla-central/rev/1db35d2c9a2f
> BuildID   20140831160203
> Version   34.0a1
> ro.build.version.incremental=110
> ro.build.date=Fri Jun 27 15:57:58 CST 2014
> B1TC00011230

Please apply this patch and give me logcat when u repro it.
https://github.com/mozilla-b2g/gaia/pull/23552
Flags: needinfo?(alive) → needinfo?(echang)
QA Contact: rpribble
blocking-b2g: 2.1? → 2.1+
Whiteboard: [system-platform]
Note:
1. Flashing gaia.zip from PVT -> reproducible
2. $GAIA_OPTIMIZE=1 Make reset-gaia from github -> reproducible
3. $Make reset-gaia from github -> Not reproducible

Log collected from method 2.

(In reply to Alive Kuo [:alive][NEEDINFO!][PTO until 9/9] from comment #8)
> (In reply to Eric Chang [:ericcc] [:echang] from comment #7)
> > I still can reproduce this with today's master, firmware 123, 1GB ram, I've
> > asked help from Alive to see what goes wrong.
> > 
> > Gaia      2be78d83a760fa3b9638fe51c266b442d14597f1
> > Gecko     https://hg.mozilla.org/mozilla-central/rev/1db35d2c9a2f
> > BuildID   20140831160203
> > Version   34.0a1
> > ro.build.version.incremental=110
> > ro.build.date=Fri Jun 27 15:57:58 CST 2014
> > B1TC00011230
> 
> Please apply this patch and give me logcat when u repro it.
> https://github.com/mozilla-b2g/gaia/pull/23552
Flags: needinfo?(echang)
Keywords: regression
B2G Inbound Last Working:
Device: Flame 2.1
BuildID: 20140828230659
Gaia: f087c45c328f16bf6f8d5a4d9452fa9a27aa6c7b
Gecko: 2162e10743be
Version: 34.0a1 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

B2G Inbound First Broken:
Device: Flame 2.1
BuildID: 20140828234459
Gaia: f087c45c328f16bf6f8d5a4d9452fa9a27aa6c7b
Gecko: a57d1aa27da9
Version: 34.0a1 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Swap:
First broken gecko/Last working gaia - Issue DOES reproduce
Gaia: f087c45c328f16bf6f8d5a4d9452fa9a27aa6c7b
Gecko: a57d1aa27da9

First broken gaia/Last working gecko - Issue DOES NOT reproduce
Gaia: f087c45c328f16bf6f8d5a4d9452fa9a27aa6c7b
Gecko: 2162e10743be

Gecko pushlog:
http://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=2162e10743be&tochange=a57d1aa27da9

Possibly broken by:
Bug 1013847
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Eric - Why isn't this nominated to 2.0 if 2.0 is affected?
Flags: needinfo?(echang)
Broken by  Bug 1013847 ?  Edgar - can you take a look?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(echen)
(In reply to Joshua Mitchell [:Joshua_M] from comment #12)
> Broken by  Bug 1013847 ?  Edgar - can you take a look?

I can reproduce this issue on BuildID:20140829040202 (master) [1] which doesn't include the fix of bug 1013847.
It seems there is nothing related to bug 1013847.

[1] https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/nightly/mozilla-central-flame/2014/08/2014-08-29-04-02-02/
Flags: needinfo?(echen)
I missed that.
[Blocking Requested - why for this release]: SIM pin request is unnecessary for accessing camera here.
(In reply to Jason Smith [:jsmith] from comment #11)
> Eric - Why isn't this nominated to 2.0 if 2.0 is affected?
blocking-b2g: 2.1+ → 2.0?
Flags: needinfo?(echang)
blocking-b2g: 2.0? → 2.0+
Flagging window wanted again since this reproduces without the fix in bug 1013847.
QA Whiteboard: [QAnalyst-Triage+]
QA Contact: rpribble → aalldredge
Hi Alive, can you be the owner of this?
Flags: needinfo?(alive)
(In reply to Eric Chang [:ericcc] [:echang] from comment #9)
> Created attachment 8483344 [details]
> v2.1_CAMERA_LOCKSCREEN.LOG
> 
> Note:
> 1. Flashing gaia.zip from PVT -> reproducible
> 2. $GAIA_OPTIMIZE=1 Make reset-gaia from github -> reproducible
> 3. $Make reset-gaia from github -> Not reproducible
> 
> Log collected from method 2.
> 
> (In reply to Alive Kuo [:alive][NEEDINFO!][PTO until 9/9] from comment #8)
> > (In reply to Eric Chang [:ericcc] [:echang] from comment #7)
> > > I still can reproduce this with today's master, firmware 123, 1GB ram, I've
> > > asked help from Alive to see what goes wrong.
> > > 
> > > Gaia      2be78d83a760fa3b9638fe51c266b442d14597f1
> > > Gecko     https://hg.mozilla.org/mozilla-central/rev/1db35d2c9a2f
> > > BuildID   20140831160203
> > > Version   34.0a1
> > > ro.build.version.incremental=110
> > > ro.build.date=Fri Jun 27 15:57:58 CST 2014
> > > B1TC00011230
> > 
> > Please apply this patch and give me logcat when u repro it.
> > https://github.com/mozilla-b2g/gaia/pull/23552

This log does not tell anything because you didn't use my patch. Please do it again because I have difficulty to repro it anyway.
Flags: needinfo?(alive)
(In reply to Alive Kuo [:alive][NEEDINFO!] from comment #17)
> (In reply to Eric Chang [:ericcc] [:echang] from comment #9)
> > Created attachment 8483344 [details]
> > v2.1_CAMERA_LOCKSCREEN.LOG
> > 
> > Note:
> > 1. Flashing gaia.zip from PVT -> reproducible
> > 2. $GAIA_OPTIMIZE=1 Make reset-gaia from github -> reproducible
> > 3. $Make reset-gaia from github -> Not reproducible
> > 
> > Log collected from method 2.
> > 
> > (In reply to Alive Kuo [:alive][NEEDINFO!][PTO until 9/9] from comment #8)
> > > (In reply to Eric Chang [:ericcc] [:echang] from comment #7)
> > > > I still can reproduce this with today's master, firmware 123, 1GB ram, I've
> > > > asked help from Alive to see what goes wrong.
> > > > 
> > > > Gaia      2be78d83a760fa3b9638fe51c266b442d14597f1
> > > > Gecko     https://hg.mozilla.org/mozilla-central/rev/1db35d2c9a2f
> > > > BuildID   20140831160203
> > > > Version   34.0a1
> > > > ro.build.version.incremental=110
> > > > ro.build.date=Fri Jun 27 15:57:58 CST 2014
> > > > B1TC00011230
> > > 
> > > Please apply this patch and give me logcat when u repro it.
> > > https://github.com/mozilla-b2g/gaia/pull/23552
> 
> This log does not tell anything because you didn't use my patch. Please do
> it again because I have difficulty to repro it anyway.


Correction: From comment it seems this only happen in production build. Investigating.
Assignee: nobody → alive
Assignee: alive → gduan
I think it doesn't matter if it's GAIA_OPTIMIZE=1 or not. I can reproduce it on both.

I can reproduce it on today's central build but cannot on 20140823040201 with the same gaia.
I checked this regression window and came to the same results as the one that was posted by Rachel in Comment 10. Additionally, I was unable to reproduce this issue in the build mentioned in Comment 13 or the build previous to it.

Environmental Variables:
Device: Flame 2.1
BuildID: 20140829040202
Gaia: 007f3c50cf69f044628a23c2376c6d88aa45f617
Gecko: d697d649c765
Version: 34.0a1 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Repro Rate: 0/10

Environmental Variables:
Device: Flame 2.1
BuildID: 20140828040204
Gaia: 3a838afca295c9db32e1a3ec76d49fb7fe7fd2d2
Gecko: 3be45b58fc47
Version: 34.0a1 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Repro Rate: 0/5
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
(In reply to Jason Smith [:jsmith] from comment #15)
> Flagging window wanted again since this reproduces without the fix in bug
> 1013847.

Comment 19 and Comment 20 are indicating that this is not correct. Perhaps there is some other bug or flash process that is masking the repro here or changing the repro rate. I'm not sure.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Hi Edgar,
I tried to dump message here
https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/sim_lock.js#L35
and I found that, there's no simslot-cardstatechange event when boot up on 0823's gecko, but it does on latest gecko (same gaia). Is that expected?
Flags: needinfo?(echen)
Attached file PR to master
Hi Alive,
the root cause is timing issue of cardstatechange event, which is fired earlier than lockscreen when bootup, so simcarddialog is showed behind lockscreen and the height is not correct since lockscreen also have status bar's height.

My solution is to close SimPinDialog if we try to launch camera from lockscreen.
Please kindly check. Thanks.
Attachment #8486953 - Flags: review?(alive)
Comment on attachment 8486953 [details] [review]
PR to master

Great, thanks!
Attachment #8486953 - Flags: review?(alive) → review+
Thanks,
merge to master:
https://github.com/mozilla-b2g/gaia/commit/d0c806a1827f76977e72b39aa72cac54a4cf6cdd
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(echen)
Resolution: --- → FIXED
Please request Gaia v2.0 and v2.1 approval on this when you get a chance.
Flags: needinfo?(gduan)
Target Milestone: --- → 2.1 S4 (12sep)
Attached file PR to 2.0
NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Bug 1059822
[User impact] if declined: cause failure like attachment 8480603 [details]
[Testing completed]: unit test has updated
[Risk to taking this patch] (and alternatives if risky): None.
[String changes made]: None.
Attachment #8487660 - Flags: approval-gaia-v2.0?
Flags: needinfo?(gduan)
Attached file PR to 2.1
[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Bug 1059822
[User impact] if declined: cause failure like attachment 8480603 [details]
[Testing completed]: unit test has updated
[Risk to taking this patch] (and alternatives if risky): None.
[String changes made]: None.
Attachment #8487662 - Flags: approval-gaia-v2.1?
Comment on attachment 8487660 [details] [review]
PR to 2.0

Requesting QA verification once this lands on 2.0
Attachment #8487660 - Flags: approval-gaia-v2.0? → approval-gaia-v2.0+
Keywords: verifyme
Attachment #8487662 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
Thanks everyone.
Verified this patch on v2.0. Cannot reproduce it on latest Flame KK build.

* Build Information:
 - Gaia        7edd3b0b9f65c3dde235c732d270e43e055a1254
 - Gecko       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/13e04ab68621
 - BuildID     20140914162307
 - Version     32.0
 - Base image  Flame KK
 - ro.build.version.incremental=27
 - ro.build.date=Thu Sep  4 14:59:02 CST 2014
Status: RESOLVED → VERIFIED
Keywords: verifyme
This issue has been verified successfully on Flame2.0&2.1&2.2
Verify video:"verify_1059822.mp4".

Flame2.0 build
Gaia-Rev        8d1e868864c8a8f1e037685f0656d1da70d08c06
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/c756bd8bf3c3
Build-ID        20141201000201
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141201.034308
FW-Date         Mon Dec  1 03:43:18 EST 2014

Flame2.1 build:
Gaia-Rev        ccb49abe412c978a4045f0c75abff534372716c4
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/18fb67530b22
Build-ID        20141201001201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141201.034405
FW-Date         Mon Dec  1 03:44:15 EST 2014
Bootloader      L1TC00011880

Flame2.2 bulid:
Gaia-Rev        39214fb22c203e8849aaa1c27b773eeb73212921
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/08be3008650f
Build-ID        20141201040205
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141201.074509
FW-Date         Mon Dec  1 07:45:20 EST 2014
You need to log in before you can comment on or make changes to this bug.