Closed Bug 1059827 Opened 5 years ago Closed 5 years ago

[7'' Tablet] First-run window navigation buttons are hidden in landscape

Categories

(Firefox for Android :: Toolbar, defect)

34 Branch
All
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 35
Tracking Status
firefox32 --- unaffected
firefox33 --- unaffected
firefox34 --- verified
firefox35 --- verified

People

(Reporter: u421692, Assigned: liuche)

References

Details

Attachments

(2 files)

Attached image screenshot
Environment:
Device: Samsung Galaxy Tab 2(Android 4.2.2)
Build: Nightly 34.0a1(2014-08-28)

Steps to reproduce:
1. Open a fresh installed Nightly
2. Put the device in landscape mode
3. Observe the First-run window

Expected result:
First-run window is displayed without any issues

Actual result:
First-run window navigation buttons are not visible(see attached screenshot)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1059441
No longer blocks: firstrun
Depends on: firstrun
Landscape mode in Asus Nexus 7, Galaxy Note 8.0, Galaxy Tab 3

The dialog size is hard-coded for tablets - it makes the layout cleaner, but I think we just need to set height minimum by screen size.
Since the landscape/v2 mocks and design are still in progress, we should do a quick fix for the current landscape version and uplift so it's not broken on 7" tablets.

This just removes the hard-coding for the onboarding screen height so that we don't need to complicate the layouts that are currently shared between tablet/phone. The v2 for onboarding will have a design for the landscape orientation.
Assignee: nobody → liuche
Status: RESOLVED → REOPENED
Attachment #8487591 - Flags: review?(wjohnston)
Resolution: DUPLICATE → ---
Comment on attachment 8487591 [details] [diff] [review]
Patch: Don't hard-code dialog height

Review of attachment 8487591 [details] [diff] [review]:
-----------------------------------------------------------------

I'm a little worried by this. If the intro content is short enough, it seems like this would wrap it and the buttons. Maybe thats what we want though :) Looks fine locally.
Attachment #8487591 - Flags: review?(wjohnston) → review+
https://hg.mozilla.org/integration/fx-team/rev/155871851e7d
Target Milestone: --- → Firefox 35
Comment on attachment 8487591 [details] [diff] [review]
Patch: Don't hard-code dialog height

Approval Request Comment
[Feature/regressing bug #]: Landscape on small tablets not handled correctly by bug 1042809
[User impact if declined]: Landscape 7" tablets will have a cut off first run screen
[Describe test coverage new/current, TBPL]: local
[Risks and why]: very low, remove hard-coding for a resource dimension
[String/UUID change made/needed]: none
Attachment #8487591 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/155871851e7d
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
Verified as fixed in:
Build: Firefox for Android 35.0a1 (2014-09-14)
Device: Kindle Fire HD 7"
Comment on attachment 8487591 [details] [diff] [review]
Patch: Don't hard-code dialog height

Aurora+
Attachment #8487591 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified as fixed in:
Build: Firefox for Android 34.0a2 (2014-09-17)
Device: Kindle Fire HD 7"
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.