Regression in contacts startup 2014-08-28

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: wlach, Assigned: arcturus)

Tracking

unspecified
2.1 S5 (26sep)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [eideticker_regression][p=2])

Attachments

(1 attachment)

You now need to go a bit farther back to see the eideticker regression (obviously I need date range permalinks).

http://eideticker.mozilla.org/#/b2g/flame-512/b2g-inbound/b2g-contacts-startup/timetostableframe/30

There has been no action on this bug. I can guarantee that this is going to cause problems for 2.1 acceptance. Needinfo'ing contacts owners (per https://wiki.mozilla.org/Modules/FirefoxOS) to try to get some action going.
Flags: needinfo?(jmcf)
Flags: needinfo?(bkelly)
Flags: needinfo?(francisco)
Hi William,

thanks a lot for letting us know, we've been pretty busy with 2.1 FC, now we can take a look to this. We will schedule this ASAP.
Flags: needinfo?(francisco)
Assigning to myself to take care of it :)
Assignee: nobody → francisco

Comment 4

4 years ago
Francisco, 

let me know if you need any help with this

thanks
Flags: needinfo?(jmcf)
Jose,

right now I have a lot of things on my plate, so feel free to steal from me.
Flags: needinfo?(bkelly)

Comment 6

4 years ago
as this is not blocking and now we are swamped with blockers, reseting assignee for the moment
Target Milestone: --- → 2.1 S5 (26sep)
Whiteboard: [eideticker_regression] → [eideticker_regression][p=2]
I've started to take a look to this problem and found the following:

26th August, we landed the new gaia-headers web component. But all apps did as well at some point
28th August, we landed the ice group to be visible on the list. The generation of the list is happening after we render the list, but we have a new template to add, that may cause a bit of increase, but not that much.

In the 8th september we can see how performance increases, but we dont have any commit on our gaia code base.
Hi,

I forgot to add some more extra feedback.

I've been working on loading scripts at correct time, we had some scripts that were just bein loaded at initialization that we didn't need, here is the ongoing work:

https://github.com/mozilla-b2g/gaia/pull/24334

Separated commits for easy review. Right now just asking for feedback.

This is not the cause of the regression but a enhancement.

The regresion on the 28 could be a platform one, since it went down again on the 9/9, but we had again another spike on the 9/16, which could be related to some fixed to the deferred actions (which should run after the list is painted :(  )
Created attachment 8493643 [details] [review]
WIP: Enhancement, remove not needed scripts from the critical path
Attachment #8493643 - Flags: feedback?(sergi.mansilla)
Attachment #8493643 - Flags: feedback?(jmcf)

Comment 11

4 years ago
Comment on attachment 8493643 [details] [review]
WIP: Enhancement, remove not needed scripts from the critical path

LGTM but I would like to do some smoke testing once you have the final PR ready for reviewing
Attachment #8493643 - Flags: feedback?(jmcf) → feedback+
In order to proceed on this, since the attached WIP is an improvement of the existing code I'll open a different bug and block this one.
Depends on: 1071722
What's the reason we have the ICE refactors in the same PR as the performance improvements?

Once this is explained, it looks good to me, I just left another small comment in the PR.
(In reply to Sergi Mansilla [:sergi] (Telenor) from comment #13)
> What's the reason we have the ICE refactors in the same PR as the
> performance improvements?
> 
> Once this is explained, it looks good to me, I just left another small
> comment in the PR.

I've been checking the performance results and ICE doesn't add much extra, since it's happening at the end of the list rendering.

Thanks for taking a look!
I will rename this bug since the regression happening in the 28th August is part of the one which all apps have been throug (discussed in dev-gaia).

Also it got fixed around 9th September.

The one that I'm seeing is the regression in performance generated on September 16th.
Forgot to mention that this regression I'm talking about is happening in KitKat version.
I think is better to open a new bug for the new regresion and close this one as worksfor me
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
Blocks: 1073009
You need to log in before you can comment on or make changes to this bug.