Closed Bug 10600 Opened 21 years ago Closed 21 years ago

NECKO: Problems loading component libraptorhtml.so

Categories

(Core :: Networking, defect, P3)

x86
Linux
defect

Tracking

()

VERIFIED DUPLICATE of bug 8849

People

(Reporter: andreas.otte, Assigned: gagan)

Details

current build as of 07-27-99 linux 2.2.5/egs 1.1.2, necko enabled

1) Starting with a deleted component all goes well the first time starting
apprunner.

2) Shut down apprunner

3) Starting apprunner second time:

GFX: dpi=96 t2p=0.0666667 p2t=15 depth=16
**************************************************
nsComponentManager:

Load(/home/mozilla/mozilla/dist/bin/components/libraptorhtml.so) FAILED with
error: /home/mozilla/mozilla/dist/bin/components/libraptorhtml.so: undefined
symbol:
GetNextPrevLineFromeBlockFrame__7nsFrameP15nsIFocusTracker11nsDirectionP8nsIFrameiiPP10nsIContentPiSc
**************************************************
ProfileName : mozProfile
ProfileDir  : /home/mozilla/.mozilla/mozProfile
Got the event queue from the service
Calling gdk_input_add with event queue

no-window, nothing ...

4) stopping

5) starting apprunner third time:

GFX: dpi=96 t2p=0.0666667 p2t=15 depth=16
**************************************************
nsComponentManager:
Load(/home/mozilla/mozilla/dist/bin/components/libraptorhtml.so) FAILED with
error: /home/mozilla/mozilla/dist/bin/components/libraptorhtml.so: undefined
symbol:
Init__17nsSplittableFrameR14nsIPresContextP10nsIContentP8nsIFrameP15nsIStyleContextT3
**************************************************
ProfileName : mozProfile
ProfileDir  : /home/mozilla/.mozilla/mozProfile
Got the event queue from the service
Calling gdk_input_add with event queue

6) stopping apprunner

7) starting apprunner:

GFX: dpi=96 t2p=0.0666667 p2t=15 depth=16
**************************************************
nsComponentManager:
Load(/home/mozilla/mozilla/dist/bin/components/libraptorhtml.so) FAILED with
error: /home/mozilla/mozilla/dist/bin/components/libraptorhtml.so: undefined
symbol: HandlePress__7nsFrameR14nsIPresContextP10nsGUIEventR13nsEventStatus
**************************************************
ProfileName : mozProfile
ProfileDir  : /home/mozilla/.mozilla/mozProfile
Got the event queue from the service
Calling gdk_input_add with event queue

8) stopping

9) starting
GFX: dpi=96 t2p=0.0666667 p2t=15 depth=16
**************************************************
nsComponentManager:
Load(/home/mozilla/mozilla/dist/bin/components/libraptorhtml.so) FAILED with
error: /home/mozilla/mozilla/dist/bin/components/libraptorhtml.so: undefined
symbol: FirstChild__C16nsContainerFrameP7nsIAtomPP8nsIFrame
**************************************************
ProfileName : mozProfile
ProfileDir  : /home/mozilla/.mozilla/mozProfile
Got the event queue from the service
Calling gdk_input_add with event queue

10) stopping

11) starting

it worked !!!!!!!!!!!!!!!!!

12) stopping

13) starting

GFX: dpi=96 t2p=0.0666667 p2t=15 depth=16
**************************************************
nsComponentManager:
Load(/home/mozilla/mozilla/dist/bin/components/libraptorhtml.so) FAILED with
error: /home/mozilla/mozilla/dist/bin/components/libraptorhtml.so: undefined
symbol: List__C16nsContainerFrameP8_IO_FILEi
**************************************************
ProfileName : mozProfile
ProfileDir  : /home/mozilla/.mozilla/mozProfile
Got the event queue from the service
Calling gdk_input_add with event queue

14) stopping

15) starting
GFX: dpi=96 t2p=0.0666667 p2t=15 depth=16
**************************************************
nsComponentManager:
Load(/home/mozilla/mozilla/dist/bin/components/libraptorhtml.so) FAILED with
error: /home/mozilla/mozilla/dist/bin/components/libraptorhtml.so: undefined
symbol: SetNextSibling__7nsFrameP8nsIFrame
**************************************************
ProfileName : mozProfile
ProfileDir  : /home/mozilla/.mozilla/mozProfile
Got the event queue from the service
Calling gdk_input_add with event queue

16) stopping

17) starting

GFX: dpi=96 t2p=0.0666667 p2t=15 depth=16
**************************************************
nsComponentManager:
Load(/home/mozilla/mozilla/dist/bin/components/libraptorhtml.so) FAILED with
error: /home/mozilla/mozilla/dist/bin/components/libraptorhtml.so: undefined
symbol: GetNextSibling__C7nsFramePP8nsIFrame
**************************************************
ProfileName : mozProfile
ProfileDir  : /home/mozilla/.mozilla/mozProfile
Got the event queue from the service
Calling gdk_input_add with event queue

18) stopping

19) starting

GFX: dpi=96 t2p=0.0666667 p2t=15 depth=16
**************************************************
nsComponentManager:
Load(/home/mozilla/mozilla/dist/bin/components/libraptorhtml.so) FAILED with
error: /home/mozilla/mozilla/dist/bin/components/libraptorhtml.so: undefined
symbol: GetAdditionalChildListName__C7nsFrameiPP7nsIAtom
**************************************************
ProfileName : mozProfile
ProfileDir  : /home/mozilla/.mozilla/mozProfile
Got the event queue from the service
Calling gdk_input_add with event queue

20) stopping

21) starting
GFX: dpi=96 t2p=0.0666667 p2t=15 depth=16
**************************************************
nsComponentManager:
Load(/home/mozilla/mozilla/dist/bin/components/libraptorhtml.so) FAILED with
error: /home/mozilla/mozilla/dist/bin/components/libraptorhtml.so: undefined
symbol: QueryInterface__9PresShellRC4nsIDPPv
**************************************************
ProfileName : mozProfile
ProfileDir  : /home/mozilla/.mozilla/mozProfile
Got the event queue from the service
Calling gdk_input_add with event queue

22) stopping

I got tired, deleted component.reg again to get something done ...

All this symbols are defined in libraptorhtml.so. I hate this linking issues.
just verifed, this is not happening with necko disabled, now doing a clobber
build with necko defined and see what happens then
okay, this also happens after a clobber build ...
07-29-99: After NECKO landing shrike dep build on the tinderbox also seems to be
affected by this problem, although not in the intensity I encountered.
I think this is the same problem as #8849 (it's BAACCKK!)

I'm adding all of the 8849 to see if we can get confirmation on this. Anyone
agree?
Andreas, what glibc and kernel do you have? So far I've only heard of this
happening on glibc2.0.7 and Kernel 2.2. mscott@netscape.com doesn't see this
problem and the only difference I see is that he runs kernel 2.0.3something but
I've seen this on at least 3 glibc2/kernel 2.2 machines...
I just hit this one. I have been running fine so far. Suddenly of the blue, I
hit this.
I'm seeing this with glibc 2.0.7-29 and a 2.2.6 kernel, yet another data point
to add to Alec's assertion.
Re dp's "out of the blue": if I rebuild today's build and don't ever switch to
another mozilla tree, I seem to be okay; when I get problems is when I run in
another mozilla tree from a few days ago, then go back to today's tree and find
I can't start up any more.
The easiest way to tell is to install the glibc-2.0 SRPMS on your machine, and
then set a breakpoint in the "relocate" method (can't remember the _real_ name
off the top of my head). When you hit, "info threads" to see where your other
threads are. If you've got 2 threads in the dl code at the same time, you're
in for trouble. The trick is to do this _exactly_ before you crash (otherwise
you create a disturbance in The Force and are likely to not see the race
condition at all).
I´m using glibc 2.07 and kernel 2.2.5, seems to be a pattern here
Another supporting data point: mcafee doesn't see the problem on glibc 2.0.7-32
and a 2.0 kernel.
mscott is not seeing this on 2.0.36 and glibc-2.0.7-32
Gagan, I believe this bug is a duplicate of 8849.

You can probably mark it as a duplicate of that one.
After reading the about 8849, I also think this is a duplicate of 8849, but note
that this problem is not limited to RedHat 5.2. It also happens with SUSE 6.1.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 8849 ***
Status: RESOLVED → VERIFIED
Bulk move of all Necko (to be deleted component) bugs to new Networking

component.
You need to log in before you can comment on or make changes to this bug.