Firefox jumps backward when Flickr is loading image block

RESOLVED DUPLICATE of bug 60307

Status

()

defect
RESOLVED DUPLICATE of bug 60307
5 years ago
5 years ago

People

(Reporter: p_dare, Unassigned)

Tracking

32 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bugday-20140901])

Reporter

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0 (Beta/Release)
Build ID: 20140825202822

Steps to reproduce:

When loading someones images or favorites from the flickr.com website, flickr breaks the page into fourths, then proceeds to load the next fourth as you scroll down.   When this happens, firefox jumps backwards, rather than retaining current position on the page.   (works as it should when using Chrome)


Actual results:

Consistently, Firefox jumps backwards on a large block of images.


Expected results:

It should retain current position on the page, and let the rest of the page load.

Comment 1

5 years ago
Could you provide a Flickr webpage to test, please.

In addition, could you test:
1) in safe mode: https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
2) with a clean profile: https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(p_dare)
Reporter

Comment 2

5 years ago
(In reply to Loic from comment #1)
> Could you provide a Flickr webpage to test, please.
> 
> In addition, could you test:
> 1) in safe mode:
> https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-
> mode
> 2) with a clean profile:
> https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-
> firefox-profiles


Flickr web page to try:
https://www.flickr.com/photos/bautistany/favorites/

scroll from the top to the bottom at a medium speed using the mouse wheel.
Flags: needinfo?(p_dare)
Reporter

Comment 3

5 years ago
Tried safe mode with same result.
Reporter

Comment 4

5 years ago
Tried a new profile, and error still occurs.

Comment 5

5 years ago
Yes, I was able to reproduce the issue with FF31 and some very old versions of FF.
The user needs to scroll the page to the middle enough fastly before the images load, and stops scrolling.
The scrollbar goes back, probably to point where the images are loading.

Comment 6

5 years ago
Confirming per comment 5.
Status: UNCONFIRMED → NEW
Component: Untriaged → General
Ever confirmed: true
Whiteboard: [bugday-20140901]

Updated

5 years ago
Product: Firefox → Core

Updated

5 years ago
Component: General → Document Navigation
Does the actual scrollTop change in the process?  Or does the content just get taller as the images come in, and end up pushing below the current scroll position?
Flags: needinfo?(epinal99-bugzilla)

Comment 8

5 years ago
(In reply to Boris Zbarsky [:bz] from comment #7)
> Does the actual scrollTop change in the process?  Or does the content just
> get taller as the images come in, and end up pushing below the current
> scroll position?
2nd answer, as the webpage is a huge picture wall, FF loads only elements "one by one", so if you scroll down fastly at the beginning, the page is small but after a few secs, it becomes taller and the scroll position is adjusted.
Flags: needinfo?(epinal99-bugzilla)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 60307
You need to log in before you can comment on or make changes to this bug.