Closed Bug 1060132 Opened 9 years ago Closed 5 years ago

libero.it desktop site instead of mobile site on Firefox OS

Categories

(Web Compatibility :: Mobile, defect, P5)

All
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: niccolocantu94, Unassigned, Mentored)

References

()

Details

(Whiteboard: [country-it] [serversniff] [sitewait])

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:34.0) Gecko/20100101 Firefox/34.0 (Beta/Release)
Build ID: 20140804060850

Steps to reproduce:

1. open browser
2. search "libero.it"


Actual results:

Desktop site is shown


Expected results:

mobile site is shown
OS: All → Gonk (Firefox OS)
Firefox Android and Safari on iPhone are redirected to http://m.libero.it/, Firefox OS not redirected

Selected HTTP response headers (Firefox OS, Firefox on Android, Safari on iPhone):

Response for: 'Mozilla/5.0 (Mobile; rv:29.0) Gecko/29.0 Firefox/29.0'
Response Status: 200
content-length: 257336
content-type: text/html; charset=iso-8859-1

Response for: 'Mozilla/5.0 (Android; Mobile; rv:26.0) Gecko/26.0 Firefox/26.0'
Response Status: 302
content-length: 0
location: http://m.libero.it/
content-type: text/html; charset=iso-8859-1

Response for: 'Mozilla/5.0 (iPhone; CPU iPhone OS 6_0 like Mac OS X) AppleWebKit/536.26 (KHTML, like Gecko) Version/6.0 Mobile/10A5376e Safari/8536.25'
Response Status: 302
content-length: 0
location: http://m.libero.it/
content-type: text/html; charset=iso-8859-1
Mentor: hsteen
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [country-it] [serversniff] [contactready]
Contacted by twitter the official account in italian https://twitter.com/Mte90Net/status/546340192375042048
Thank you! :)
Whiteboard: [country-it] [serversniff] [contactready] → [country-it] [serversniff] [sitewait]
resent the tweet because I could not find a contact form alternative to social pages
Confirmed, it redirects to desktop version.
Screenshot: http://i.imgur.com/yCgtDoQ.png
tweet sent again, we need to find a reference contact for this site
Priority: -- → P5
Closing as we are not working on Firefox OS anymore.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.