[DOGFOOD] Folder pane's account entry is gone after scrolling up & down

VERIFIED FIXED in M11

Status

SeaMonkey
MailNews: Message Display
P3
blocker
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: Ninoschka Baca, Assigned: scottputterman)

Tracking

Trunk
All
Windows NT
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [DOGFOOD] Mailnews needs this fixed for dogfood)

(Reporter)

Description

19 years ago
1999072615M9: Win32/NT4, Linux/Redhat 5.2, Mac 8.5.1

Overview Description: I've seen this for awhile. In the folder pane drag the
scroll bar down so that only one folder appears. Now scroll up to the top and
notice that the user@server entry is gone. It's difficult to know what account
you are on.

Steps to Reproduce:
1. Use an account which has many folders (POP or IMAP) or a combination of both
so that the scroll bar appears.
2. Start Mail
3. Expand the folders
4. In the folder pane hold the scroll bar down and drag it to the bottom so only
the last folder appears.
5. Now drag the scroll bar to the top to see the first folder.

Actual Results:The account entry is gone, it should show username on a
server(currently it displays user@server but this is reported in a different
bug). It shows the folders in the account but not the entry showing what account
you are in. If you don't see this then scroll down and up a couple of times.

Expected Results:I would expect the account folder to always remain. In the
following example user@server should always remain:

- Accounts
  - user@server
    - folder1
    - folder2

Additional Builds and Platforms Tested On: This has been present for awhile.

Updated

19 years ago
Assignee: phil → putterman
QA Contact: lchiang → nbaca
(Assignee)

Updated

19 years ago
Assignee: putterman → hyatt
(Assignee)

Comment 1

19 years ago
reassigning to hyatt.

This sounds like it might be similar to some of the other scrollbar bugs that
have been filed.
(Assignee)

Updated

19 years ago
Blocks: 11091
(Assignee)

Updated

19 years ago
Whiteboard: [DOGFOOD] Mailnews needs this fixed for dogfood
(Assignee)

Comment 2

19 years ago
I really don't want to update the status for every scrollbar bug.  This is part
of a class of bug relating to a misbehaving scrollbar that we need fixed in
order to be used for Dogfood.  M9 is nice, but M10 is fine.  I imagine that once
you start looking at these, most of these bugs will start going away.

Comment 3

19 years ago
Moving to M10.

Updated

19 years ago
Blocks: 12176
No longer blocks: 11091
Severity: normal → blocker

Comment 4

19 years ago
Severity -> blocker for mail/news M10

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 5

19 years ago
Fixed.
(Reporter)

Updated

19 years ago
Status: RESOLVED → REOPENED
(Reporter)

Comment 6

19 years ago
Still seeing the same problem where the accounts disappear and reappear
depending on how many times the scrollbar is moved. Let me know if you need more
details.
(Reporter)

Updated

19 years ago
Resolution: FIXED → ---

Comment 7

19 years ago
I believe nbaca was using a recent build when trying to verify this bug.
(Reporter)

Comment 8

19 years ago
Sorry for not being clear. I used the following builds when trying to verify:
1999090109M10: Win32/NT4,
1999083116M10: Linux/Redhat
1999083108M10: Mac 8.5.1

Comment 9

19 years ago
mass targetting m11

Updated

19 years ago
Blocks: 11091

Updated

19 years ago
No longer blocks: 12176

Comment 10

19 years ago
My hands have deteriorated to the point where I can no longer type.  I need
help.  If you think you can fix this bug on your own, please take it away from
me.  If you'd like to volunteer to be my hands for a specific bug, then I'll be
happy to come up to your cube and sit with you and fix the bug (assuming you
have the patience for that).
(Assignee)

Updated

19 years ago
Assignee: hyatt → putterman
Status: REOPENED → NEW
(Assignee)

Comment 11

19 years ago
I'll look into this.

Comment 12

19 years ago
I see the same problem in the bookmarks view in the sidebar, if I expand one of
the items in the top of the list and scroll up & down I see items from the tree
view disapearing/reapearing as I scroll!

Maybe this is a tree widget problem.

Example:

+ item 1
+ item 2
+ item 3
+ item 4
...

Expand item 2

+ item 1
- item 2
  # item 2.1
  # item 2.2
  # item 2.3
+ item 3
+ item 4
...

Scroll down and back up the tree looks like this

+ item 1
  # item 2.1
  # item 2.2
  # item 2.3
+ item 3
+ item 4
...

Ie "item 2" has disapeared...
(Assignee)

Updated

19 years ago
Blocks: 15008

Updated

19 years ago
Blocks: 16654

Updated

19 years ago
Summary: Folder pane's account entry is gone after scrolling up & down → [DOGFOOD] Folder pane's account entry is gone after scrolling up & down
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 13

19 years ago
I checked in the fix for this.
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 14

19 years ago
Build 1999110108M11: Win32/NT4, Linux/Redhat 6.0, Mac 8.5.1
Verified Fixed.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.