Closed Bug 1060386 Opened 7 years ago Closed 7 years ago

Mobile Client needs to report the number of shared URLs on FxOS

Categories

(Firefox OS Graveyard :: Gaia::Loop, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: oteo, Assigned: ferjm)

References

Details

User Story

As a product manager I want to know daily the number of shared URLs on FxOS  client so that I know how often users try to communicate via this fall-back process.

When we say "shared" in Loop Mobile Client, it means only URLs sent via e-mail or SMS

See also bug 1015988 for the sharing URLs tracking in Desktop client

Attachments

(2 files, 2 obsolete files)

As a product manager I want to know daily the number of shared URLs on FxOS  client so that I know how often users try to communicate via this fall-back process.

When we say "shared" in Loop Mobile Client, it means only URLs sent via e-mail or SMS.
Blocks: 1060389
User Story: (updated)
User Story: (updated)
OS: Mac OS X → Gonk (Firefox OS)
Hardware: x86 → ARM
Summary: Mobile Client needs to report number of shared URLs on FxOS → Mobile Client needs to report the number of shared URLs on FxOS
Assignee: nobody → ferjmoreno
Attached file WIP (obsolete) —
Attached file Example report (obsolete) —
This is an example of the reports that we are currently sending with the attached patch. I was able to test it locally running the telemetry server and I can see that the reports are being successfully logged.
(In reply to Fernando Jiménez Moreno [:ferjm] from comment #3)
> Created attachment 8494642 [details]
> Example report
> 
> This is an example of the reports that we are currently sending with the
> attached patch. I was able to test it locally running the telemetry server
> and I can see that the reports are being successfully logged.

It looks like you've used the "envelope" format that Telemetry uses to store payloads locally before uploading to the server.  The actual body of the submitted payload should only include the part inside the "payload" key.

Please also make the following changes:
- Add an "appName":"FirefoxOS" to the "info" part of the payload
- Remove the "submission_date" key (this is calculated server-side) 

Consider using "37e9e79" as the appBuildID (instead of a separate "loop_version" field). That will give you the ability to filter the submissions by this field when doing data analyses. If this value is highly volatile and unlikely to contain many submissions per version, it would be better to leave it as-is.
Comment on attachment 8494636 [details]
Link to Github pull-request: https://github.com/mozilla-b2g/firefoxos-loop-client/pull/120/files

LGTM. r=me

Please, do the naming of files and object as we agreed and have a look at a couple of comments I left con the PR. Thanks for taking care of it!
Attachment #8494636 - Flags: review?(josea.olivera) → review+
Attached file Example report
Attachment #8494642 - Attachment is obsolete: true
(In reply to Mark Reid [:mreid] from comment #4)
> (In reply to Fernando Jiménez Moreno [:ferjm] from comment #3)
> > Created attachment 8494642 [details]
> > Example report
> > 
> > This is an example of the reports that we are currently sending with the
> > attached patch. I was able to test it locally running the telemetry server
> > and I can see that the reports are being successfully logged.
> 
> It looks like you've used the "envelope" format that Telemetry uses to store
> payloads locally before uploading to the server.  The actual body of the
> submitted payload should only include the part inside the "payload" key.
> 
> Please also make the following changes:
> - Add an "appName":"FirefoxOS" to the "info" part of the payload
> - Remove the "submission_date" key (this is calculated server-side) 
> 
> Consider using "37e9e79" as the appBuildID (instead of a separate
> "loop_version" field). That will give you the ability to filter the
> submissions by this field when doing data analyses. If this value is highly
> volatile and unlikely to contain many submissions per version, it would be
> better to leave it as-is.

Thanks for the feedback Mark! I made the changes that you suggested and attached an updated example report. Please, let us know if any other change is required.

https://github.com/mozilla-b2g/firefoxos-loop-client/commit/2d1f1b7b9974f572c0194f2d1d9a683544ac541c
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1060405
Blocks: 1073516
You need to log in before you can comment on or make changes to this bug.