Closed Bug 1060621 Opened 5 years ago Closed 5 years ago

WorkerScope should CC mLocation and mNavigator

Categories

(Core :: DOM: Workers, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla35
Tracking Status
firefox33 --- fixed
firefox34 --- fixed
firefox35 --- fixed

People

(Reporter: bzbarsky, Assigned: baku)

References

Details

(Keywords: memory-leak, Whiteboard: [MemShrink:P2])

Attachments

(1 file, 1 obsolete file)

It doesn't, but that seems odd.  Why doesn't it?  Should at least be documented.
Flags: needinfo?(khuey)
Flags: needinfo?(bent.mozilla)
Attached patch cc.patch (obsolete) — Splinter Review
This fixes bug 1061720.
Attachment #8482785 - Flags: review?(bzbarsky)
Comment on attachment 8482785 [details] [diff] [review]
cc.patch

r=me; add the testcase?
Attachment #8482785 - Flags: review?(bzbarsky) → review+
Flags: needinfo?(khuey)
Flags: needinfo?(bent.mozilla)
Do we want this on branches? Should be rather safe patch.
Might not be a bad idea.  I guess this has been a problem for a while....
Assignee: nobody → amarchesini
OS: Mac OS X → All
Hardware: x86 → All
Summary: Should WorkerScope CC mLocation and mNavigator? → WorkerScope should CC mLocation and mNavigator
Can you also put in a test for an expando on location?
Duplicate of this bug: 1061720
Keywords: mlk
Whiteboard: [MemShrink]
(In reply to Andrew McCreight [:mccr8] from comment #6)
> Can you also put in a test for an expando on location?

ah sorry... I didn't see your comment. I'll do in the other patch about WorkerNavigator.location.
Whiteboard: [MemShrink] → [MemShrink:P2]
https://hg.mozilla.org/mozilla-central/rev/eeb169601087
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
Comment on attachment 8482815 [details] [diff] [review]
cc.patch

Approval Request Comment
[Feature/regressing bug #]: We need this to land bug 1062920 without leaking.
[User impact if declined]: We won't take bug 1062920
[Describe test coverage new/current, TBPL]: Worker code is well tested in automation.
[Risks and why]: Low risk
[String/UUID change made/needed]: N/A
Attachment #8482815 - Flags: approval-mozilla-beta?
Attachment #8482815 - Flags: approval-mozilla-aurora?
Attachment #8482815 - Flags: approval-mozilla-beta?
Attachment #8482815 - Flags: approval-mozilla-beta+
Attachment #8482815 - Flags: approval-mozilla-aurora?
Attachment #8482815 - Flags: approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.