Polish reveal location functionality.

VERIFIED FIXED in mozilla0.9.9

Status

Core Graveyard
File Handling
P2
enhancement
VERIFIED FIXED
16 years ago
a year ago

People

(Reporter: Peter Trudelle, Assigned: Bill Law)

Tracking

Trunk
mozilla0.9.9
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: 3 days, URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Polish Reveal Location Functionality
Improve UI wording ("Show File Location" for instance)
Highlight downloaded file in File Managerrequires independent Mac and Windows
implementations (see below under "Issues" for discussion of the situation on
Linux). I have taken a glance at the Win32 shell APIs and it seems that
selecting a file in a folder is possible. 3 days.
Component: XP Apps → File Handling
(Reporter)

Updated

16 years ago
Priority: -- → P2
Target Milestone: --- → mozilla0.9.9
(Assignee)

Comment 1

16 years ago
balancing bug lists
Keywords: nsbeta1+
Target Milestone: mozilla0.9.9 → mozilla1.0
(Reporter)

Comment 2

16 years ago
This 'balances' you at 27 days in 5 weeks.
Whiteboard: 3 days
Blocks: 102472
Depends on: 67001, 90008
*** Bug 113984 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

16 years ago
Target Milestone: mozilla1.0 → mozilla0.9.9
(Assignee)

Comment 4

16 years ago
Created attachment 70178 [details] [diff] [review]
Patch to nsLocalFileWin to select file after opening folder

This code uses some "undocumented" Win32 APIs that are documented at
http://www.geocities.com/SiliconValley/4942/index.html.

This code has been tested on Windows95, Windows98, and Windows 2000.

It fails sometimes because the lookup for the newly-opened folder window fails,
especially when the progress dialog is in the process of closing.  That may
require some fine-tuning.

Comment 5

16 years ago
Comment on attachment 70178 [details] [diff] [review]
Patch to nsLocalFileWin to select file after opening folder

r=sgehani  Dunno the Win32 APIs and IPC semantics but this looks right.
Attachment #70178 - Flags: review+

Comment 6

16 years ago
sr=hyatt
(Assignee)

Comment 7

16 years ago
Code has been checked in.  May need some tweaking to deal with fact that 
closing the progress dialog commandeers the focus and obscures the folder 
window.

I'd like a new bug for that, please.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
other than linux, this looks fine on win2k and mac 10.1.2. rs vrfy.
Status: RESOLVED → VERIFIED
(Assignee)

Comment 9

16 years ago
*** Bug 109595 has been marked as a duplicate of this bug. ***
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.