Closed Bug 1060903 Opened 6 years ago Closed 6 years ago

[Cost Control] Restore functionality in the widget after utility tray's visual refresh

Categories

(Firefox OS Graveyard :: Gaia::Cost Control, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
Tracking Status
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: salva, Assigned: gmarty)

References

Details

(Keywords: regression, Whiteboard: [systemsfe])

Attachments

(1 file)

Bug 1038723 introduces a regression in which the widget now display misleading information.

STR:
 1. Configure Cost Control and set a data limit of 10M
 2. Browse the Internet
 3. Display the utility tray

Expected:
The subtraction between the limit and the current usage should be displayed as available data.

Actual:
The amount of current data usage is displayed and labeled as available
Depends on: 1038723
Guillaume, please try to get this in before FL.
Assignee: nobody → gmarty
Whiteboard: [systemsfe]
Blocks: 1038723
No longer depends on: 1038723
Keywords: regression
[Blocking Requested - why for this release]: regression of bug 1038723.
blocking-b2g: --- → 2.1?
Fixed by backout, see bug 1038723 comment 37.
Status: NEW → RESOLVED
blocking-b2g: 2.1? → ---
Closed: 6 years ago
Resolution: --- → FIXED
The issue is verified fixed in Flame 2.1 and Flame 2.2:

Flame 2.2 KitKat Base (319mb)(Full Flash)

Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20141006040204
Gaia: 470826d13ae130a5c3d572d1029e595105485fb0
Gecko: e0d714f43edc
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Flame 2.1 KitKat Base (319mb)(Full Flash)

Environmental Variables:
Device: Flame 2.1
BuildID: 20141006000205
Gaia: 778ebac47554e1c4b7e9a952d73e850f58123914
Gecko: c4a4b04c617c
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

When a data limit has been set the amount available is displayed in the utility tray.
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.