Closed Bug 1060984 Opened 5 years ago Closed 5 years ago

Mac Xulrunner build broken by bug 1028588

Categories

(Core :: XPCOM, defect, blocker)

33 Branch
x86
macOS
defect
Not set
blocker

Tracking

()

RESOLVED FIXED
mozilla34
Tracking Status
firefox31 --- unaffected
firefox32 --- unaffected
firefox33 + verified
firefox34 --- fixed
firefox-esr24 --- unaffected
firefox-esr31 --- unaffected
b2g18 --- unaffected
b2g-v1.1hd --- unaffected
b2g-v1.2 --- unaffected
b2g-v1.3 --- unaffected
b2g-v1.3T --- unaffected
b2g-v1.4 --- unaffected
b2g-v2.0 --- unaffected
b2g-v2.1 --- unaffected

People

(Reporter: philor, Assigned: bjacob)

References

Details

(Keywords: regression)

You're going to love this. We only run Xulrunner as nightly builds, only on mozilla-central and mozilla-aurora, and hidden so that absolutely nobody ever looks at them, but, they are release deliverables so their failure is the very definition of a blocker.

https://tbpl.mozilla.org/php/getParsedLog.php?id=47125117&tree=Mozilla-Aurora is the latest Mac xulrunner build on mozilla-aurora, dying with the same dangerous destructor it has been dying with since the merge to mozilla-aurora on July 21st, and had been dying with on mozilla-central since July 7th (though trunk currently dies with a different failure, because we heard you liked bustage on your bustage).

In two days, aurora will merge to beta, we'll build a beta release, and one of the things that the beta release requires is a Mac xulrunner build, which ain't gonna build.

[Tracking Requested - why for this release]:
It's a release deliverable, until the long awaited bug 672509 finally gets rid of this insane "hidden tier-2 build is a release deliverable" situation.
Not sure how "nobody realized until now" is compatible with "this matters enough to block release" :-)
Because that's how we do it: we release it, but the owner doesn't want it to be a tier-1 build which runs on-push on every tree so it's hidden and nightly-only, and the entire project lusts to run so goddamn many broken things that the single person who ever once looked at hidden jobs, me, finally got sick of looking at them and stopped. You're just lucky I gave you two days from having looked at hidden for something else, the way of the future is going to be "releng does a merge, builds a beta, retriggers the busted xulrunner build a few times, and then says 'huh, that's been broken for a couple of months, and we need it fixed tonight so we can release this beta.'"
I'll see what I can do today, but this is a holiday (as it is for you) and I have lots of other things to take care of. No promises. This should be super easy though, once I get to reproduce locally --- just found Xulrunner build instructions at https://developer.mozilla.org/en-US/docs/Mozilla/Projects/XULRunner/Build_Instructions
Reproduced locally, and the trivial 1-line fix works, so I landed it on inbound, without review, on a CLOSED TREE:

https://hg.mozilla.org/integration/mozilla-inbound/rev/b6832df4a1c1

Let me know if I should land it on other trees as well.
Assignee: nobody → bjacob
Philor/Ryan/Ed: I'm defaulting to assuming that I should leave it for you guys to backport an unreviewed fix to any other trees than inbound...
Flags: needinfo?(ryanvm)
Flags: needinfo?(philringnalda)
Flags: needinfo?(emorley)
(In reply to Benoit Jacob [:bjacob] from comment #5)
> Philor/Ryan/Ed: I'm defaulting to assuming that I should leave it for you
> guys to backport an unreviewed fix to any other trees than inbound...

So ordinarily you'd require a patch with the relevant approval+ given, but this is only a xulrunner/* file change so can land with a=npotdb.

I believe these changes should get it on the necessary bug queries (I don't have those repos checked out at the moment, and beta is closed for uplift still).
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(emorley)
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: [checkin-needed for aurora and beta with a=npotdb]
Target Milestone: --- → mozilla34
Not beta, not unless it missed the merge - 32 is unaffected, if it was affected we'd still be trying to build beta1.

Strictly speaking it's not fixed on the trunk, since it hasn't merged from m-i yet, but then, there's bustage that kills the build before this bustage on the trunk so we aren't going to see whether or not this actually fixed the problem on the trunk until after bug 1060995 gets fixed. Close enough.

https://hg.mozilla.org/releases/mozilla-aurora/rev/1d9cbbf6af8c
Flags: needinfo?(ryanvm)
Flags: needinfo?(philringnalda)
Keywords: checkin-needed
Whiteboard: [checkin-needed for aurora and beta with a=npotdb]
Green on aurora :)
Duplicate of this bug: 1060787
You need to log in before you can comment on or make changes to this bug.