Cache does not honor the user_pref browser.cache.directory

VERIFIED DUPLICATE of bug 78480

Status

()

Core
Networking: Cache
VERIFIED DUPLICATE of bug 78480
17 years ago
14 years ago

People

(Reporter: Michael Koehn, Assigned: gordon)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.5+)
Gecko/20011022
BuildID:    2001102203

When I set the pref user.cache.directory by hand (editing prefs.js), about:cache
still shows the default cache directory and no cache files are created in the
specified directory.  I see this on NT4 and W2K

I see this problem in NS 6.1 as well, so it may have been around for a while.

Reproducible: Always
Steps to Reproduce:
1. Exit Moz/Netscape
2. Edit prefs.js, changing the value for browser.cache.directory
3. Save prefs.js
4. Run Mozilla
5. Browse some pages
6. Go to about:cache, notice the directory listed (not what you entered in 2).
7. Look at the cache directory you specified.  There are no new files there.

Actual Results:  Specified cache directory not used

Expected Results:  Mozilla should use the specified cache directory

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 46490 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 2

17 years ago
Yes, the prefs were not working properly for 6.1.  This has been fixed for
0.9.4, however the new preference is "browser.cache.disk.parent_directory".  The
disk cache device will create a cache folder in the specified directory, this
avoids most the worst side effects caused by users accidently specifying their
root directory or some other important directory.  On some platforms, cache
files used to get sprayed all over the place or important files could get
deleted when the cache was cleared.

Comment 3

17 years ago
This is a dupe of another bug.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 4

17 years ago
The pref is now called browser.cache.disk.parent_directory.

*** This bug has been marked as a duplicate of 78480 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 5

15 years ago
VERIFIED, dupe.
Status: RESOLVED → VERIFIED
QA Contact: tever → cacheqa

Updated

14 years ago
QA Contact: cacheqa → benc
You need to log in before you can comment on or make changes to this bug.