[Clock] Edit Alarm screen does not responding after adding Alarm continues(fast).

VERIFIED FIXED in 2.1 S5 (26sep)

Status

Firefox OS
Gaia::Clock
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Vishnu Dangi, Unassigned)

Tracking

unspecified
2.1 S5 (26sep)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [LibGLA,TD93225,QE1, B])

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
STR.
1.Open clock.
2.Click Add new Alarm icon.
3.Clock Done to save alarm.
4.Repeate step 2 and 3 continuously fast.
5.in NEW ALarm Screen "Cancel" and "Done" button did not respond.

Actual Result:in NEW ALarm Screen "Cancel" and "Done" button did not respond.
Expected Result: in NEW ALarm Screen "Cancel" and "Done" button should be respond.
(Reporter)

Updated

3 years ago
Flags: needinfo?(m)
Whiteboard: [LibGLA,TD93225,QE1, B]
Need software information, reproducibility on Flame device.

In any case, this case does not look blocking. Users dont set up multiple alarms for the same time.
(Reporter)

Comment 2

3 years ago
it is reproduce in master.
(Reporter)

Comment 3

3 years ago
Created attachment 8487822 [details] [diff] [review]
Done_and_Canceal_button_does_not_respond_on_EditAlarm_screen

please give your feedback about this patch for resolving this issue.
Attachment #8487822 - Flags: feedback?(m)
Hi Marcus -

Could you help to review the patch on Comment#3?

Thanks

Vance
Attachment #8487822 - Flags: feedback?(m) → feedback+
Flags: needinfo?(m)
looks good to me; can you make a Gaia PR to ensure the tests continue to pass?

Comment 6

3 years ago
Created attachment 8489820 [details] [diff] [review]
Done button not responding.patch

We have tried in another method. I have uploaded patch for this(Done button not responding.patch)
Can you please give your feedback about this patch.
Attachment #8489820 - Flags: feedback?(m)
Flags: needinfo?(m)
Comment on attachment 8489820 [details] [diff] [review]
Done button not responding.patch

Could you describe how this patch is supposed to work?  Looking at the diff, it's not clear to me what 'pendingVisible' is supposed to do.
Attachment #8489820 - Flags: feedback?(m)
Flags: needinfo?(m)

Comment 8

3 years ago
when add alarm and done buttons are clicked continuously we were not getting 'panel-visibilitychange' event. This is because of  ' if (state.visible !== value) { ' condition in view.js

So we used flag called 'pendingVisible', this is set when new alarm panel is not active. During transition flag is set to false.
So when user click on add new alarm icon, 'panel-visibilitychange' event is dispatched.

Comment 9

3 years ago
we have used 'pendingVisible' flag to dispatch 'panel-visibilitychange' event when both previous visible state and present visible state are same.

Please give your feedback on Done button not responding.patch
Flags: needinfo?(m)
Hi Marcus and Dylan, Could you please kindly provide your valuable feedbacks per comment9? 
Not sure if Marcus is occupied, ni Dylan as well.... if someone else could spare some time on this.

Thank you very much !
Flags: needinfo?(doliver)
Created attachment 8496962 [details] [review]
Gaia PR
Thanks, I've merged and landed the patch.

master: https://github.com/mozilla-b2g/gaia/commit/496cacad14dd243d03408fcdbda68324d8e8e85b
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(m)
Flags: needinfo?(doliver)
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S5 (26sep)
[Environment]
Gaia-Rev        83f495a1c12687970f7f2840c2729795c4b88177
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/0ed32d9a42d6
Build-ID        20141005160202
Version         35.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20140925.192608
FW-Date         Thu Sep 25 19:26:18 EDT 2014
Bootloader      L1TC10011800


[Result]
PASS
Status: RESOLVED → VERIFIED
QA Whiteboard: [COM=Gaia::Clock]
You need to log in before you can comment on or make changes to this bug.