Closed Bug 1061225 Opened 8 years ago Closed 8 years ago

Add contact transition issue

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(tracking-b2g:backlog)

RESOLVED FIXED
2.1 S5 (26sep)
tracking-b2g backlog

People

(Reporter: sharaf.tir, Unassigned)

Details

(Whiteboard: [LibGLA, TD-92337, QE1, C])

Attachments

(2 files, 3 obsolete files)

STR

1) Open dialer
2) Input any number
3) Select add contact -> new contact option
4) Enter any name in the contact form
5) Press "done" or Press the "X" button

Observation:
Transition is not proper while the contact activity is closed.
Whiteboard: [LibGLA, TD-92337, QE01, C]
Hi Alive,

This is always happens with add contact activity.
Did not observe it with other activities though.
Any thoughts?

ni? to alive
Flags: needinfo?(alive)
I totally don't understand what is not proper, please be more descriptive.
Is it related to keyboard?
Is it related to the contact main page->new contact page transition? If so, it's a contact bug.
Flags: needinfo?(alive)
Whiteboard: [LibGLA, TD-92337, QE01, C] → [LibGLA, TD-92337, QE1, C]
Hi Alive,

Please see my comment #0, I think I explained it well there. 
In the STR after step 5, when the add contact activity is closed the transition to the previous screen is not smooth, and feels like screen is flickering.

ni? to alive
Flags: needinfo?(alive)
(In reply to Sharaf from comment #3)
> Hi Alive,
> 
> Please see my comment #0, I think I explained it well there. 
> In the STR after step 5, when the add contact activity is closed the
> transition to the previous screen is not smooth, and feels like screen is
> flickering.
> 
> ni? to alive

Sorry, the term 'not smooth' could not be something fix-able because it's inaccurate.
Please provide practical data or video to compare 'smooth' and 'not smooth'.
Flags: needinfo?(alive)
Hi Alive,

Can you please let me know what exact data you want? 
Whenever I checked I am able to see this behavior. 
So I dont have a 'ok' and 'not ok' case comparison for this.

BTW If you just follow the STR in comment #0 you can see the behavior.

ni? to alive for his comments
Flags: needinfo?(alive)
I ask just because I cannot reproduce.
Flags: needinfo?(alive)
Keywords: qawanted
If i understand Sharef correctly, when a new contact is created with the Done button at step 5, the contact screen when dismissed seems to perform 3 different animations when closing. Zooming in then moving off screen as it fades away. It's during these animations that the issue is noticed.

Can be difficult to notice but there is slight flickering during the transition from Contact screen back to the Dialer screen when the contact is saved.

Cancelling the create contact screen does not cause much of an flicker. It's more noticeable when creating and saving the contact.

Tried to take a video but it was too hard to notice and the issue happens so quick that taking a video seemed useless.

Sharef, If this is not what you are seeing please feel free to correct me.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: croesch
Saw this on:

Environmental Variables: 
Device: Flame Master
BuildID: 20140903062451
Gaia: 52670853c17fc0d3d33065c667c0ce124c93b98f
Gecko: 5e9826980be5
Version: 35.0a1 (Master) 
Firmware Version: v123
Apologize for misspelling your name Sharaf.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
Hi Alive -

I attached a video that captures the problematic part, could you help to take a look at second 16 ~ 18? I believe you can see the problem more clearly with this video.

Thanks for your help

Vance
Flags: needinfo?(alive)
I believe this is a contact bug - it doesn't support inline activity correctly so when you click done button it will do a slidedown animation on its own but it's unnecessary.

Julien, please correct me if I am wrong.
Component: Gaia::System → Gaia::Contacts
Flags: needinfo?(alive) → needinfo?(felash)
Yeah, I believe you're right.

Francisco, I think it's a bug for you :)
Flags: needinfo?(felash) → needinfo?(francisco)
Absolutely, thanks Julien!

I've been readying the comments, and trying to figure out what's not working there, perhaps the fact that after pressing on done, contacts is trying to perform another transition from the form to the contacts list.

We can try to avoid this transition if we are being invoked as a web activity.
Flags: needinfo?(francisco)
blocking-b2g: --- → backlog
Hi,

I have made a patch based on your comments.
Please give your feedback.
Attachment #8489971 - Flags: feedback?(francisco)
Hi Francisco, could you help to revie the patch in Comment#15 ?

Thanks
Flags: needinfo?(francisco)
Comment on attachment 8489971 [details] [diff] [review]
Dont show transition when invoked as an activity

Hi,

thanks for the contribution, patch looking promising. I was thinking on totaly stoping any kind of navigation, but this looks good tool
Attachment #8489971 - Flags: feedback?(francisco) → feedback+
Flags: needinfo?(francisco)
Hi

Onbehalf of sharaf - https://github.com/mozilla-b2g/gaia/pull/24125/files

Please merge to master. Thanks
Flags: needinfo?(francisco)
Attached file Pointer to pull request (obsolete) —
please review it
Attachment #8490564 - Flags: review?(francisco)
Flags: needinfo?(francisco)
Comment on attachment 8490564 [details]
Pointer to pull request

Left a tiny comment on github, something to solve pretty easily before merging.

Thanks!
Attachment #8490564 - Flags: review?(francisco)
Attached file Pull Request (obsolete) —
Uploaded pull request please merge to master
Attachment #8491343 - Flags: review?(francisco)
Comment on attachment 8491343 [details]
Pull Request

Almost there, there is a lint error in the line 39, I think cause there should be a space between '?', like this:

ActivityHandler.currentlyHandling ? 'activity-popup' : 'popup';

Once solved, we can merge this.

Thanks!
Attachment #8491343 - Flags: review?(francisco)
Attached file Pull Request (obsolete) —
Please merge
Attachment #8491424 - Flags: review?(francisco)
Attached file Pointer to PR 24219
Just add the pr modified to not to have linting problems
Attachment #8490564 - Attachment is obsolete: true
Attachment #8491343 - Attachment is obsolete: true
Attachment #8491424 - Attachment is obsolete: true
Attachment #8491424 - Flags: review?(francisco)
Attachment #8492146 - Flags: review+
Landed:

https://github.com/mozilla-b2g/gaia/commit/9fdae5ccf8ce1e9d5e2784abde8e506bbec8f5e8
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S5 (26sep)
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.