api/project/mozilla-central/resultset/ returning ISE 500

RESOLVED FIXED

Status

Tree Management
Treeherder
P1
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: emorley, Assigned: jeads)

Tracking

Details

(Assignee)

Updated

4 years ago
Assignee: nobody → jeads
(Assignee)

Updated

4 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 1

4 years ago
edmorley, the urls provided are pointed at the treeherder development server (http://treeherder-dev.allizom.org). When I replace with the production host, https://treeherder.mozilla.org, in the url provided:

https://treeherder.mozilla.org/ui/#/jobs?repo=mozilla-central&revision=1db35d2c9a2f

Later API calls do not seem to be returning 500s after initial pageload and also after several minutes on the page. Maybe the wires got crossed on dev for awhile?

Can you try reproducing this on production?
Flags: needinfo?(emorley)
(Reporter)

Comment 2

4 years ago
Yeah I know the comment 0 link is dev - I was checking the recently landed but not pushed to prod changes hadn't broken anything :-)

This still repros on dev for me on, but doesn't on prod. If this is only a glitch in the dev DB then fair enough, however if it's due to recently landed changes then we need to figure it out before we deploy the next batch.

Note you need to wait ~2 mins, and another 500 occurs every 2 mins after that (guessing UI refresh?).
Flags: needinfo?(emorley)
(Assignee)

Comment 3

4 years ago
AutomatedTester ran into this on production. You can reproduce with this url

https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=8352094a1452
(Assignee)

Comment 4

4 years ago
This bug was fixed in https://github.com/mozilla/treeherder-service/pull/201
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.