Port |Bug 575283 - Cleanup mozconfig files on all platforms| to SeaMonkey

RESOLVED FIXED in seamonkey2.49

Status

defect
RESOLVED FIXED
5 years ago
3 years ago

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

Tracking

Trunk
seamonkey2.49
Dependency tree / graph

SeaMonkey Tracking Flags

(seamonkey2.45 wontfix, seamonkey2.46 fixed, seamonkey2.47 fixed, seamonkey2.48 fixed, seamonkey2.49esr fixed)

Details

Attachments

(2 attachments, 1 obsolete attachment)

Assignee

Description

5 years ago
Bug 575283 cleaned up the in-tree mozconfigs for m-c, removing invalid and redundant options. This ports those changes to SeaMonkey.
Attachment #8482436 - Flags: review?(bugspam.Callek)
Comment on attachment 8482436 [details] [diff] [review]
Remove invalid / redundant options from mozconfigs

Review of attachment 8482436 [details] [diff] [review]:
-----------------------------------------------------------------

r- purely because there is more stuff to do.

::: suite/config/mozconfigs/linux32/debug
@@ -14,4 @@
>  
>  # For NSS symbols
>  export MOZ_DEBUG_SYMBOLS=1
> -ac_add_options --enable-debug-symbols="-gdwarf-2"

should remove the comment and MOZ_DEBUG_SYMBOLS=1 as well. (elsewhere too)
Attachment #8482436 - Flags: review?(bugspam.Callek) → review-
Assignee

Comment 2

5 years ago
(In reply to Justin Wood (:Callek) from comment #1)
> Comment on attachment 8482436 [details] [diff] [review]
> Remove invalid / redundant options from mozconfigs
> 
> Review of attachment 8482436 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> r- purely because there is more stuff to do.
> 
> ::: suite/config/mozconfigs/linux32/debug
> @@ -14,4 @@
> >  
> >  # For NSS symbols
> >  export MOZ_DEBUG_SYMBOLS=1
> > -ac_add_options --enable-debug-symbols="-gdwarf-2"
> 
> should remove the comment and MOZ_DEBUG_SYMBOLS=1 as well. (elsewhere too)

As both TB and IB have kept this in their in-tree mozconfig files I thought it was best to keep in sync with them. If it is definitely no longer needed then I will remove it and spin off bugs to do it in TB and IB too.
Flags: needinfo?(bugspam.Callek)
Assignee

Comment 3

4 years ago
Callek: Ping
Assignee

Comment 4

3 years ago
Unbitrotted, for other products I have spun off the MOZ_DEBUG_SYMBOLS question into bug 1306959
Attachment #8482436 - Attachment is obsolete: true
Flags: needinfo?(bugspam.Callek)
Attachment #8796942 - Flags: review?(ewong)
Attachment #8796942 - Flags: review?(bugspam.Callek)
Assignee

Comment 5

3 years ago
Comment on attachment 8796942 [details] [diff] [review]
Remove invalid / redundant options from mozconfigs unbitrot

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: build bustage
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch: None
Attachment #8796942 - Flags: approval-comm-release?
Attachment #8796942 - Flags: approval-comm-beta?
Attachment #8796942 - Flags: approval-comm-aurora?
Assignee

Comment 6

3 years ago
Comment on attachment 8796942 [details] [diff] [review]
Remove invalid / redundant options from mozconfigs unbitrot

Rebased one for c-r in progress
Attachment #8796942 - Flags: approval-comm-release?
Assignee

Comment 7

3 years ago
[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: build bustage
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch: None
Attachment #8796945 - Flags: approval-comm-release?
Attachment #8796945 - Flags: approval-comm-release? → approval-comm-release+
Attachment #8796942 - Flags: review?(ewong) → review+
Blocks: SM2.46
Comment on attachment 8796945 [details] [diff] [review]
Remove invalid / redundant options from mozconfigs for c-r

in the release-l10n mozconfigs..  also need to make sure they
don't have the --with-ccache option.
Comment on attachment 8796942 [details] [diff] [review]
Remove invalid / redundant options from mozconfigs unbitrot

Review of attachment 8796942 [details] [diff] [review]:
-----------------------------------------------------------------

clearing r? since ewong reviewed. a+
Attachment #8796942 - Flags: review?(bugspam.Callek)
Attachment #8796942 - Flags: approval-comm-beta?
Attachment #8796942 - Flags: approval-comm-beta+
Attachment #8796942 - Flags: approval-comm-aurora?
Attachment #8796942 - Flags: approval-comm-aurora+
I think this is fixed with the push to c-b and c-a
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Keywords: leave-open
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.