Closed Bug 1061616 Opened 8 years ago Closed 8 years ago

call log is not showing recently dialled numbers

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S5 (26sep)
blocking-b2g 2.1+
Tracking Status
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: Bebe, Assigned: rik)

References

Details

(Keywords: regression, Whiteboard: [fromAutomation] [planned-sprint c=3][in-sprint=v2.1-S4][2.1-flame-test-run-2])

Attachments

(1 file)

Description:
After making a call and hanging up there are no calls found in the call log screen

Environment:
Gaia      84a5bf6632d559bb690d2134fc4b9ef19d9b78cc
Gecko     https://hg.mozilla.org/integration/b2g-inbound/rev/787cb7faa58b
BuildID   20140902024812
Version   34.0a1
ro.build.version.incremental=110
ro.build.date=Fri Jun 27 15:57:58 CST 2014
B1TC00011230


TEST-UNEXPECTED-FAIL | test_call_log_all_calls.py TestCallLogAllCalls.test_call_log_all_calls | AssertionError: 0 != 1

Traceback (most recent call last):
  File "/var/jenkins/1/workspace/flame.b2g-inbound.ui.adhoc/.env/local/lib/python2.7/site-packages/marionette_client-0.8.3-py2.7.egg/marionette/marionette_test.py", line 171, in run
    testMethod()
  File "/var/jenkins/1/workspace/flame.b2g-inbound.ui.adhoc/tests/python/gaia-ui-tests/gaiatest/tests/functional/dialer/test_call_log_all_calls.py", line 38, in test_call_log_all_calls
    self.assertEqual(call_log.all_calls_count, 1)




Reproducible manually: YES

STR:
1. Open the dialer app
2. Tap phone number (we use +18007072533)
3. tap call
4. wait for the call screen and tap hangup
5. open the call log


Expected:
5. call should be present in the call log

Actual:
5. no calls shown in the call log
Looking through the test history this test failed in the past with the same result:

It failed in build:

application_buildid: 20140831040205
application_changeset: 1db35d2c9a2f
application_display_name: B2G
application_name: B2G
application_repository: https://hg.mozilla.org/mozilla-central
application_version: 34.0a1
build_changeset: 74465af039d2809454afdfef285285bb63146e1b
device_firmware_date: 1409239766
device_firmware_version_incremental: eng.cltbld.20140828.112916
device_firmware_version_release: 4.3
device_id: flame
gaia_changeset: 2be78d83a760fa3b9638fe51c266b442d14597f1
gaia_date: 1409447416
gecko_changeset: c5b55f7c492664837cba920d256e8b54cc008de2
platform_buildid: 20140831040205
platform_changeset: 1db35d2c9a2f
platform_repository: https://hg.mozilla.org/mozilla-central
Keywords: regression
Whiteboard: [fromAutomation]
Whiteboard: [fromAutomation] → [fromAutomation] [planned-sprint]
Target Milestone: --- → 2.1 S4 (12sep)
Whiteboard: [fromAutomation] [planned-sprint] → [fromAutomation] [planned-sprint c=3]
Assignee: nobody → anthony
[Blocking Requested - why for this release]:

QA blocker & smoketest blocker
blocking-b2g: --- → 2.1?
Whiteboard: [fromAutomation] [planned-sprint c=3] → [fromAutomation] [planned-sprint c=3][xfail]
QA Contact: rpribble
I was able to repro this issue twice: one time while on today's v2.1 build 20140902040205, and once on v2.1 build 20140829122301. After flashing, I am unable to repro it any longer in these same builds out of 15 tries.

Device: Flame 2.1 Master
BuildID: 20140829122301
Gaia: 007f3c50cf69f044628a23c2376c6d88aa45f617
Gecko: 9b3fbc370631
Version: 34.0a1 (2.1 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Device: Flame 2.1 Master
BuildID: 20140829122301
Gaia: 007f3c50cf69f044628a23c2376c6d88aa45f617
Gecko: 9b3fbc370631
Version: 34.0a1 (2.1 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

A call will not display in the call history log.
Flags: needinfo?(jmitchell)
QA Contact: rpribble
Flags: needinfo?(jmitchell)
Keywords: qaurgent
blocking-b2g: 2.1? → 2.1+
I am having similar issues as Rachel did when attempting this issue.  I was only able to reproduce it on the first flash to today's nightly build.  I did not find a tinderbox build I could reproduce this issue on and also was unable to reproduce on the 8/29 build.  

Some more information that might help narrow down this issue is that when this issue occurred, I was able to reproduce this 100% for that session (until the phone was restarted).  When the issue reproduces the phone number is not listed on the active call screen and the dialer will NOT fill in the last number dialed by pressing the call button while its empty.  I was also unable to toggle airplane mode or the developer menu and volume changes were not taken into account until the applications were closed and restarted.

Restarting fixed all of these issues.

Environmental Variables:
Device: Flame Master
BuildID: 20140902040205
Gaia: 44bf2e3bc5ddea9db9a8c851bd353cb234aa883c
Gecko: c360f3d1c00d
Version: 34.0a1 (Master) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Flags: needinfo?(jmitchell)
Flags: needinfo?(jmitchell)
See Also: → 1062294
See Also: 1062294
(In reply to Jayme Mercado [:JMercado] from comment #4)
> I was also
> unable to toggle airplane mode or the developer menu and volume changes were
> not taken into account until the applications were closed and restarted.
That seems to indicate that this is not a Dialer issue specifically.
Comment 3 and Comment 4 indicate a significantly low repro so this issue might not qualify as a qa-blocker.

Comment 3 saw the issue twice over the span of two builds, but only on the initial try and then all subsequent pushes of the same build resulted in a no-repro - This repro rate is about 2/30 or 1/15

Comment 4 saw the issue only once across numerous builds - resulting in repro rate of 1/50


NI Peter to make sure it is safe to pull the smoke blocker keywords.
Flags: needinfo?(pbylenga)
Removing smoketest keyword since this is below the reproduction rate criteria for a smoketest blocker (< 50%)
Whiteboard: [fromAutomation] [planned-sprint c=3][xfail] → [fromAutomation] [planned-sprint c=3]
We could still use a regression window for this.
Doug - The reproduction rate on this bug is too low to pursue a window & at least two testers have already made attempts at it, but failed due to a low reproduction rate. As such, I think we need to remove keyword here.
Flags: needinfo?(drs+bugzilla)
Okay, thanks for the clarification. I wasn't sure if they were able to repro again after doing a full system flash or not.
Flags: needinfo?(drs+bugzilla)
Flags: needinfo?(pbylenga)
I'm seeing this error when reproducing:
E/GeckoConsole(  292): [JavaScript Error: "ReadOnlyError: A mutation operation was attempted in a READ_ONLY transaction." {file: "resource://gre/modules/SettingsRequestManager.jsm" line: 509}]

So maybe this is another manifestation of bug 1061510 ?
I'm inclined to let this bug wait till a fix for bug 1061510 lands. When it does, we can come back to this and see if it still reproduces.
See Also: → 1061510
Now that bug 1061510 landed, asking for qawanted to see if it is still reproducible sometimes.
Keywords: qawanted
Bug 1061510 has not landed to aurora yet, as it's still waiting on approval-mozilla-aurora. So this will still happen.
I was not able to reproduce this failure manually on latest aurora, by following STR in comment 0. The call log was displayed as expected.

Though, the automated test is failing intermittently when running it locally: https://pastebin.mozilla.org/6385253
Test test_call_log_all_calls.py also failed in the latest aurora build: http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame.mozilla-aurora.ui.functional.smoke/36/HTML_Report/ , with the same error described in comment 0.

Device firmware (date) 	31 Aug 2014 13:31:23
Device firmware (incremental) 	eng.cltbld.20140831.163113
Device firmware (release) 	4.3
Device identifier 	flame
Gaia date 	06 Sep 2014 11:06:20
Gaia revision 	a8e4d26555e5
Gecko build 	20140908000204
Gecko revision 	746f24f9d21d
Gecko version 	34.0a2
It's normal to still see it on Aurora since it has not been uplifted. Are we seeing the test failing intermittently on central?
Whiteboard: [fromAutomation] [planned-sprint c=3] → [fromAutomation] [planned-sprint c=3][in-sprint=v2.1-S4]
Target Milestone: 2.1 S4 (12sep) → 2.1 S5 (26sep)
Viorela: Is it possible to know if this is sometimes failing on central? That would help us know if the uplift of bug 1061510 will help.
Flags: needinfo?(viorela.ioia)
Anthony, I saw this test failing on yesterday's master build: http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-319.mozilla-central.ui.functional.smoke/152/HTML_Report/
It passed in today's master build though, so it looks like intermittent.
Flags: needinfo?(viorela.ioia)
Is it possible to obtain a logcat when this is failing?
Flags: needinfo?(viorela.ioia)
QA Whiteboard: [QAnalyst-Triage?]
Whiteboard: [fromAutomation] [planned-sprint c=3][in-sprint=v2.1-S4] → [fromAutomation] [planned-sprint c=3][in-sprint=v2.1-S4][2.1-flame-test-run-2]
Flags: needinfo?(dharris)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
I will attach a logcat of the issue
Flags: needinfo?(viorela.ioia)
Attached file log
Viorela: Thanks! Is it a logcat when running 2.1 or master? I'm seeing the error from bug 1061510 which has been uplifted two days ago. So we need to know if the logcat was captured with this patch included or not.
Flags: needinfo?(viorela.ioia)
The logcat is from when running on master, but it is not the latest master build. I used the build from comment 0 in order to get the logcat. Would you need a logcat based on latest build?
Flags: needinfo?(viorela.ioia)
Yes, we want to know why it is still intermittent with bug 1061510 fixed.
Flags: needinfo?(viorela.ioia)
The issue is not reproducible on latest master. The test passed locally and also on the adhoc I started: http://jenkins1.qa.scl3.mozilla.com/job/flame.ui.adhoc/155/console

Device firmware (date)     22 Sep 2014 04:55:31
Device firmware (incremental)     eng.cltbld.20140922.075522
Device firmware (release)     4.3
Device identifier     flame
Gaia date     19 Sep 2014 09:50:54
Gaia revision     c7ef0bf06ce1
Gecko build     20140922040204
Gecko revision     53f7f5b6d7bf
Gecko version     35.0a1
Flags: needinfo?(viorela.ioia)
Then let's close this.
Thanks!
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
issue has been resolved, cleaning up keywords
Keywords: qawanted
This issue is verified fixed on Flame 2.1 and Flame 2.2.

Environmental variables:
Device: Flame 2.2 Master KK (319mb) (Full Flash)
BuildID: 20141012040203
Gaia: 717ad4e8b7fc10ab8248500d00ba5ba0977fa8ab
Gecko: 44168a7af20d
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Device: Flame 2.1 KK (319mb) (Full Flash)
BuildID: 20141012001201
Gaia: d18e130216cd3960cd327179364d9f71e42debda
Gecko: 610ee0e6a776
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

The call log showed all calls that were placed.
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.