[Messages] Header shows wrong icons for back\close actions

VERIFIED FIXED in 2.1 S4 (12sep)

Status

VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: azasypkin, Assigned: yor)

Tracking

({regression})

unspecified
2.1 S4 (12sep)
ARM
Gonk (Firefox OS)
regression
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.1 verified, b2g-v2.2 verified)

Details

Attachments

(2 attachments)

PR
46 bytes, text/x-github-pull-request
kgrandon
: review+
Details | Review | Splinter Review
1.07 MB, video/mp4
Details
STR:
1. Open any message thread;
2. Observe "back" icon in the header - correct;
3. Long tap on message and go to the Report panel;
4. Observe "close" icon in the header - correct;
5. Go back to Thread panel and observe "back" icon.

Actual result: "close" icons is displayed (with <gaia-header action="back">)

Expected result: "back" icon should be displayed instead.

Looks like it was broken by patch for bug 1059833. It works fine with initial Messages gaia-header patch for bug 1011604 that was landed earlier.

[Blocking Requested - why for this release]: Regression
Wilson, Yan could you please look into it?
Flags: needinfo?(yor)
Flags: needinfo?(wilsonpage)
(Assignee)

Updated

5 years ago
Assignee: nobody → yor
Flags: needinfo?(yor)
(Assignee)

Comment 2

5 years ago
Created attachment 8482979 [details] [review]
PR

Kevin, can you review this fix?  Wilson is out on PTO and you are the next person most familiar with this code.  Thanks.
Attachment #8482979 - Flags: review?(kgrandon)
(Assignee)

Updated

5 years ago
Status: NEW → ASSIGNED
Comment on attachment 8482979 [details] [review]
PR

I didn't go through this specific STR, but since this is a simple patch I'll give it the benefit of the doubt. The code looks fine to me, thanks!
Attachment #8482979 - Flags: review?(kgrandon) → review+
(Assignee)

Comment 4

5 years ago
Tested the specific STR and behaves as expected with step #5 showing a back button.  Ready to land.
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
master: https://github.com/mozilla-b2g/gaia/commit/8e117ae14d06fc71ec8859d23769a69f6abdb922
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S4 (12sep)
Flags: needinfo?(wilsonpage)
Hey Yan,

Thanks for the fix, but I believe it has missed v2.1 train. Could you please request approval to uplift this fix to v2.1?

Thanks!
Flags: needinfo?(yor)
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → fixed
(Assignee)

Comment 7

5 years ago
Stephany,

What's the process for uplifting this to 2.1?
Flags: needinfo?(yor) → needinfo?(swilkes)

Comment 8

5 years ago
Yan, in the Attachment - Details, please sent approval-gaia-v2.1? and complete the questions that appear in the comment box. This requests uplift.
Flags: needinfo?(swilkes)
(Assignee)

Comment 9

5 years ago
Comment on attachment 8482979 [details] [review]
PR

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 1059833
[User impact] if declined: regression, wrong icon showing on 'back' button
[Testing completed]: Manually tested on device, TBPL green
[Risk to taking this patch] (and alternatives if risky): minimal risk
[String changes made]: none
Attachment #8482979 - Flags: approval-gaia-v2.1?
blocking-b2g: 2.1? → ---
Attachment #8482979 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+

Comment 11

4 years ago
This issue has been verified successfully on Flame2.1&2.2.
Reproducing rate: 0/5
See attachment: Verify_Flame_button.mp4

Flame2.1 build version:
Gaia-Rev        dbaf3e31c9ba9c3436e074381744f2971e15c7bf
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/ebce587d2194
Build-ID        20141203001205
Version         34.0

Flame2.2 build version:
Gaia-Rev        725685831f5336cf007e36d9a812aad689604695
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/2c9781c3e9b5
Build-ID        20141203040207
Version         37.0a1
Status: RESOLVED → VERIFIED
status-b2g-v2.1: fixed → verified
status-b2g-v2.2: fixed → verified

Comment 12

4 years ago
Created attachment 8531934 [details]
Verify_Flame_button.MP4
You need to log in before you can comment on or make changes to this bug.