[Flame][SMS] Unable to send sms

RESOLVED DUPLICATE of bug 1061510

Status

--
critical
RESOLVED DUPLICATE of bug 1061510
4 years ago
4 years ago

People

(Reporter: pensacola_m2000, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Platform version: 34.0a1
Build identifier: 20140901160203
OS version 2.1

Steps to reproduce:
1. Go to Messages and tap to send a sms

Expected results:
SMS should be sent

Actual results:
SMS could not be sent.Tapping on SEND button does not have any effect.
Hey Marcela,

Thanks for reporting this! I was able to reproduce this on the build you mentioned (without any stable STR though), but can't reproduce it on the latest build.

Could you please confirm that you still see this issue on the latest build?

Just some observations: I was able to debug this issue, looks like "navigator.mozSettings.createLock().get" doesn't call success\error callbacks, so multisim action button component doesn't have valid sim index and nothing happens when user taps on send button. I've seen similar issue with mozSettings recently in other places, but looks like something has fixed it recently.

Thanks!
Flags: needinfo?(pensacola_m2000)
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → ARM
(Reporter)

Comment 2

4 years ago
(In reply to Oleg Zasypkin [:azasypkin] from comment #1)
> Hey Marcela,
> 
> Thanks for reporting this! I was able to reproduce this on the build you
> mentioned (without any stable STR though), but can't reproduce it on the
> latest build.
> 
> Could you please confirm that you still see this issue on the latest build?
> 
> Just some observations: I was able to debug this issue, looks like
> "navigator.mozSettings.createLock().get" doesn't call success\error
> callbacks, so multisim action button component doesn't have valid sim index
> and nothing happens when user taps on send button. I've seen similar issue
> with mozSettings recently in other places, but looks like something has
> fixed it recently.
> 
> Thanks!

Hi Oleg,
I was able to reproduce the issue using: 

Gaia   44bf2e3bc5ddea9db9a8c851bd353cb234aa883c
SourceStamp c360f3d1c00d
BuildID 20140902040205
Version 34.0a1

Steps:
Updated (OTA) the device with the build mentioned and then performed some actions like opening phone app, contacts, searching for a contact, making some calls and so on. Everything works ok at the beginning. However after a while, I closed all the apps opened, re-open Messages app and try to send sms. This is when the issue is reproducing.
I've noticed that when I catch this bug I did not see on the SEND button the number 1 displayed anymore, please see the attached screenshot bug_sms.png. In case sms can be sent, it's displayed like in screenshot sms_works.png.

Please note that when I catch I cannot use phone app properly anymore. It seems that it reproduces the bug https://bugzilla.mozilla.org/show_bug.cgi?id=1061175 the only difference is that in this case the user is not receiving any call before, just making some calls.
(Reporter)

Comment 3

4 years ago
Created attachment 8482922 [details]
bug_sms.png
(Reporter)

Comment 4

4 years ago
Created attachment 8482923 [details]
sms_works.png
(Reporter)

Comment 5

4 years ago
Created attachment 8482925 [details]
logs_device

Some logs attached from adb logcat
Flags: needinfo?(pensacola_m2000)
(In reply to Oleg Zasypkin [:azasypkin] from comment #1)
> Hey Marcela,
> 
> Thanks for reporting this! I was able to reproduce this on the build you
> mentioned (without any stable STR though), but can't reproduce it on the
> latest build.
> 
> Could you please confirm that you still see this issue on the latest build?
> 
> Just some observations: I was able to debug this issue, looks like
> "navigator.mozSettings.createLock().get" doesn't call success\error
> callbacks, so multisim action button component doesn't have valid sim index
> and nothing happens when user taps on send button. I've seen similar issue
> with mozSettings recently in other places, but looks like something has
> fixed it recently.
> 
> Thanks!

It seems that we do have this big issue recently: bug 1061510
See Also: → bug 1061510
Hi Marcela,

Looks like bug 1061510 that we suspected as the culprit has been landed on master. Sorry but could you please check again on the latest master b2g build?

Thanks!
Flags: needinfo?(pensacola_m2000)
(Reporter)

Comment 8

4 years ago
(In reply to Oleg Zasypkin [:azasypkin] from comment #7)
> Hi Marcela,
> 
> Looks like bug 1061510 that we suspected as the culprit has been landed on
> master. Sorry but could you please check again on the latest master b2g
> build?
> 
> Thanks!

In progress, since this was reproducing after doing some actions, it will take some time to test. What can i say is that at the moment I'm unable to reproduce it, but I'm pretty sure it needs more testing.
Flags: needinfo?(pensacola_m2000)
Got it, thanks Marcela!
(Reporter)

Comment 10

4 years ago
(In reply to Oleg Zasypkin [:azasypkin] from comment #9)
> Got it, thanks Marcela!

It seems that I cannot reproduce it anymore on latest master b2g build.
Great, thanks for testing !
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1061510
You need to log in before you can comment on or make changes to this bug.