Unable to change the wallpaper several times

VERIFIED FIXED in Firefox 34, Firefox OS v2.1

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: viorela, Assigned: qdot)

Tracking

({qablocker, regression})

unspecified
2.1 S4 (12sep)
ARM
Gonk (Firefox OS)
qablocker, regression
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.1+, firefox33 wontfix, firefox34 fixed, firefox35 fixed, b2g-v1.4 unaffected, b2g-v2.0 unaffected, b2g-v2.1 verified, b2g-v2.2 verified)

Details

(Whiteboard: [systemsfe][xfail], URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
After changing the wallpaper several times, the pick wallpaper button becomes unresponsive
The issue is reproducible manually on v2.1; it is not reproducible on v2.0.

#STR
1. Launch Settings app
2. Tap Display option
3. Tap Pick wallpaper button
4. Tap Wallpaper - then Select a wallpaper 
Repeat steps 3 and 4 a few times

#Expected results:
The wallpaper is changed each time we select a new wallpaper, pick wallpaper button is always available
 
#Actual results:
Pick wallpaper button becomes unavailable, tapping on it does nothing

#Build info:
Device firmware (date) 	28 Aug 2014 08:29:26
Device firmware (incremental) 	eng.cltbld.20140828.112916
Device firmware (release) 	4.3
Device identifier 	flame
Gaia date 	01 Sep 2014 11:20:22
Gaia revision 	44bf2e3bc5dd
Gecko build 	20140902040205
Gecko revision 	c360f3d1c00d
Gecko version 	34.0a1

This is causing test_change_wallpaper.py to fail: http://jenkins1.qa.scl3.mozilla.com/job/flame.mozilla-central.ui.functional.non-smoke/127/HTML_Report/
(Reporter)

Comment 1

4 years ago
Created attachment 8482764 [details]
logcat
We need better STR here - the test involved here does not change the wallpaper multiple times.
Keywords: qawanted

Updated

4 years ago
Keywords: qawanted → steps-wanted
I can reproduce it with the str from comment 0, using Flame and mozilla-central from today.
I got it reproduced once while changing the wallpaper 5 times and once 3 times.
Verified that this bug is able to reproduced in Settings AND on Homescreen. Possibly need to change title to just "Unable to change the wallpaper".

1. Tap Settings.
2. Tap Display.
3. Tap on the Wallpaper preview and Select Wallpaper
4. Tap any wallpaper.
5. Observe the current wallpaper and try to tap the wallpaper preview button again.

Actual Results: Often no change to the current wallpaper preview is seen. The wallpaper preview button does not function any more when tapped on.

Repro: 3/5

***NOTES: 
1. May have to repeat a couple times for bug to occur.
2. Rebooting device will fix this bug.

Environmental Variables:
Device: Flame Master
BuildID: 20140901224717
Gaia: 44bf2e3bc5ddea9db9a8c851bd353cb234aa883c
Gecko: c360f3d1c00d
Version: 34.0a1 (Master) 
Firmware Version: v123
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.1: --- → affected
Flags: needinfo?(jmitchell)
Keywords: steps-wanted
QA Contact: croesch
This also occurs on the Homescreen by following these STR's

1. Long press an empty spot on the homescreen.
2. Tap Change Wallpaper.
3. Choose a wallpaper.
4. See if wallpaper changed.
5. Repeat steps 1 and 2.

Actual results: Change Wallpaper option does not have any function any more.
QAnalyst-Triage:

based on comment 0 - no repro in 2.0

not nomming - low repro rate, low visibility
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
status-b2g-v2.0: --- → unaffected
Flags: needinfo?(jmitchell)
Keywords: regression
[Blocking Requested - why for this release]: After speaking with the QA tester (Cody) offline this has a higher visibility than I originally understood. Nomming based on visibility and it is a regression. 


QA-Wanted for branch check
blocking-b2g: --- → 2.1?
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage+]
This bug does NOT repro on: Flame 2.0, Flame 1.4, OpenC 2.1

Actual Result: No issues switching wallpaper through Home screen or Settings.

Repro Rate: 0/30 attempts

Environmental Variables:
Device: Flame 2.0
BuildID: 20140901103053
Gaia: 449d8db9b3ea1f9262db822c37ef2143477172b7
Gecko: 40d74e0bbcf5
Version: 32.0 (2.0) 
Firmware Version: v123
-----------------------------------------------
Environmental Variables:
Device: Flame 1.4
BuildID: 20140902105642
Gaia: 2ee5b00bfbb8a67a967094804390b4afce8ecf54
Gecko: 4ab16aed1410
Version: 30.0 (1.4) 
Firmware Version: v123
-----------------------------------------------
Environmental Variables:
Device: Open_C Master
BuildID: 20140902120804
Gaia: 7e469783859785a8bd4bf02a802f32561c84be7b
Gecko: 372ce1f36116
Version: 35.0a1 (Master) 
Firmware Version: P821A10V1.0.0B06_LOG_DL
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v1.4: --- → unaffected
Flags: needinfo?(jmitchell)
Keywords: qawanted
regression rate is too low to request a window - QA-triage complete
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
*repro rate....
I have verified this issue is not limited to default wallpapers. Gallery images also can have this problem as well as taking photos and having them set to wallpaper.
Please ignore the noise - after re-examing the repro rate it seems a regression-window is feasible here.
QA Whiteboard: [QAnalyst-Triage+]
Keywords: regressionwindow-wanted
QA Contact: croesch
QA Contact: jmercado
Bug 900551 seems to have caused this issue

B2g-inbound Regression Window

Last working 
Environmental Variables:
Device: Flame 2.1
BuildID: 20140829133157
Gaia: 3a95ab1c33084d110351a39eb86d49a18bcf39f3
Gecko: 6dc0a998af58
Version: 34.0a1 (2.1) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

First Broken 
Environmental Variables:
Device: Flame 2.1
BuildID: 20140829140157
Gaia: 3a95ab1c33084d110351a39eb86d49a18bcf39f3
Gecko: 6b1690ad2cf5
Version: 34.0a1 (2.1) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Last working gaia / First broken gecko - Issue DOES occur
Gaia: 3a95ab1c33084d110351a39eb86d49a18bcf39f3
Gecko: 6b1690ad2cf5

First broken gaia / Last working gecko - Issue DOES occur
Gaia: 3a95ab1c33084d110351a39eb86d49a18bcf39f3
Gecko: 6dc0a998af58

Gecko Pushlog:  http://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=6dc0a998af58&tochange=6b1690ad2cf5
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
Possibly broken by Bug 900551 - can you take a look Kyle?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(kyle)
A dreaded READ_ONLY appears!

Looks like yet another bit of fallout from bug 1061510, which has landed and greened, waiting to go to m-c/aurora.

That said, yup, it's all me. I'll take assignment, and close out when 1061510 merges.
Assignee: nobody → kyle
Flags: needinfo?(kyle)
same regression and poor ux
blocking-b2g: 2.1? → 2.1+
This should be fixed on trunk now. Can we confirm this?
Keywords: qawanted
Target Milestone: --- → 2.1 S4 (12sep)
(In reply to Jason Smith [:jsmith] from comment #18)
> This should be fixed on trunk now. Can we confirm this?

Confirmed fixed on latest trunk.

Repro rate when wallpaper is changed from Settings > Display : 0/10
Repro rate when wallpaper is changed from Homescreen: 0/10

Tested on:
Device: Flame
BuildID: 20140909070054
Gaia: 4abb193ddae0f9780ad12ffe5e31772feee3926a
Gecko: 4d1793da0b96
Version: 35.0a1 (2.2 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
Status: NEW → RESOLVED
Last Resolved: 4 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Resolution: --- → FIXED
status-b2g-v2.2: --- → fixed
status-firefox33: --- → wontfix
status-firefox34: --- → affected
status-firefox35: --- → fixed
(Reporter)

Comment 20

4 years ago
This issue is reproducible on latest v2.1 build. Can we uplift the fix from master? 

Device firmware (date)     31 Aug 2014 13:31:23
Device firmware (incremental)     eng.cltbld.20140831.163113
Device firmware (release)     4.3
Device identifier     flame
Gaia date     09 Sep 2014 17:52:40
Gaia revision     79dc972d637f
Gecko build     20140910000202
Gecko revision     0890010015a2
Gecko version     34.0a2
(In reply to Viorela Ioia [:viorela] from comment #20)

Bug 1061510 is waiting on a fix for bug 1064228 before it can be uplifted.

Updated

4 years ago
Keywords: qablocker
Whiteboard: [systemsfe] → [systemsfe][xfail]
status-b2g-v2.1: affected → fixed
status-firefox34: affected → fixed
This bug is verified fixed on the Flame 2.1 (319mb) and the Flame 2.2 (319mb)


Flame 2.2 Master KK (319mb) (Full Flash)

Device: Flame 2.2 Master
BuildID: 20141011040204
Gaia: 95f580a1522ffd0f09302372b78200dab9b6f322
Gecko: 3f6a51950eb5
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Flame 2.1 KK (319mb) (Full Flash)

Device: Flame 2.1
BuildID: 20141011000201
Gaia: f5d4ff60ffed8961f7d0380ada9d0facfdfd56b1
Gecko: d813d79d3eae
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Result: The wallpaper is changed each time a new wallpaper is selected, pick wallpaper button is always available
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-v2.1: fixed → verified
status-b2g-v2.2: fixed → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.