e10s: Memory measurements reported by telemetry are only for the chrome process

RESOLVED DUPLICATE of bug 1198209

Status

()

Toolkit
Telemetry
P3
normal
RESOLVED DUPLICATE of bug 1198209
4 years ago
2 years ago

People

(Reporter: njn, Unassigned)

Tracking

unspecified
Points:
---

Firefox Tracking Flags

(e10s+)

Details

(Whiteboard: [MemShrink:P2])

(Reporter)

Description

4 years ago
All the MEMORY_* telemetry measurements are measured in the parent process. When e10s is enabled, we'll be missing all the memory used by child processes.
(Reporter)

Updated

4 years ago
tracking-e10s: --- → ?
Whiteboard: [MemShrink]
(Reporter)

Updated

4 years ago
Duplicate of this bug: 695676
tracking-e10s: ? → +
(Reporter)

Comment 2

4 years ago
This might be subsumed by bug 1024021. Depends exactly how that bug is implemented, e.g. do we want parent and child process measurements to be added, or reported separately?
For the purposes of Win32 address space, the max of the two may be the most interesting, but generally we probably just want to add it up, in the current iteration of e10s that is just one parent and one child process for the most part.
(Reporter)

Updated

4 years ago
Depends on: 1024021
Whiteboard: [MemShrink] → [MemShrink:P2]
Priority: -- → P3

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1198209
You need to log in before you can comment on or make changes to this bug.