[Ringtones] Some audios which list at My ringtones/alerts could not be set as default ringtone/alert

VERIFIED FIXED in Firefox OS v2.1

Status

Firefox OS
Gaia::System
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Alison Shiue, Assigned: qdot)

Tracking

unspecified
2.1 S5 (26sep)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 verified)

Details

(Whiteboard: [systemsfe])

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8483233 [details]
test_audios.zip

Gaia      fbb297c39aab5f17b179533d2a9a6c5166b2c197
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/fb5e796da813
BuildID   20140902160204
Version   34.0a2
Base image v123

STR:
1. Insert a SD card with some songs under /Notifications and /Ringtones folder
2. Go to Settings -> Sound
3. Under the "Tones" category, select "Manage Tones" 
4. Select "[AMR (audio)]test.amr" as default ringtone 
(please refer attachment test_audios.zip, the two audios have the same problem) 

Expect result:
The selected song become default ringtone successfully

Actual result:
Always show "Saving ringtone..." and could not set the audio as default ringtone (http://youtu.be/clVpvIXiL1c)
(Reporter)

Comment 1

3 years ago
Created attachment 8483235 [details]
saving_ringtone_issue.log
(Reporter)

Comment 2

3 years ago
[Blocking Requested - why for this release]:
This problem would let user feel frustrated
blocking-b2g: --- → 2.1?
QA Whiteboard: [COM=Gaia::Ringtones]

Updated

3 years ago
Attachment #8483235 - Attachment mime type: text/x-log → text/plain

Comment 3

3 years ago
Triage on 9/3

Blocking: User should be able to pick amr files to set as default ringtone as it is a supported format. Furthermore, the message shown is mis-leading; If we are unable to set a ringtone as default, UI should say so preferably with a reason and not just hang on "Saving Ringtone..."
blocking-b2g: 2.1? → 2.1+

Comment 4

3 years ago
Jim, please investigate this one.
Assignee: nobody → squibblyflabbetydoo

Updated

3 years ago
Target Milestone: --- → 2.1 S4 (12sep)

Comment 5

3 years ago
It seems like this happens if you open the settings app, receive a call, and then try to change the ringtone. File formats don't seem to matter, and even built-in ringtones can break this. I get a lot of this in the logcat when it happens:

I/Gecko   (  291): 
I/Gecko   (  291): ###!!! [Parent][MessageChannel] Error: Channel error: cannot send/recv
I/Gecko   (  291): 
I/Gecko   (  291): 
I/Gecko   (  291): ###!!! [Parent][MessageChannel] Error: Channel error: cannot send/recv

I'm guessing it's a Gecko regression, since I didn't see this on an earlier Gecko, but I'm going to redirect this to the system app for now. Maybe folks there will have some ideas.
Assignee: squibblyflabbetydoo → nobody
Component: Gaia::Ringtones → Gaia::System
Keywords: regressionwindow-wanted
Switching to qawanted first to do branch checks to confirm comment 5, then move forward with the window.
Keywords: regressionwindow-wanted → qawanted
(In reply to Jim Porter (:squib) from comment #5)
> It seems like this happens if you open the settings app, receive a call, and
> then try to change the ringtone. File formats don't seem to matter, and even
> built-in ringtones can break this. I get a lot of this in the logcat when it
> happens:
> 
> I/Gecko   (  291): 
> I/Gecko   (  291): ###!!! [Parent][MessageChannel] Error: Channel error:
> cannot send/recv
> I/Gecko   (  291): 
> I/Gecko   (  291): 
> I/Gecko   (  291): ###!!! [Parent][MessageChannel] Error: Channel error:
> cannot send/recv
> 
> I'm guessing it's a Gecko regression, since I didn't see this on an earlier
> Gecko, but I'm going to redirect this to the system app for now. Maybe folks
> there will have some ideas.

Kyle, could it be one of the settings regression ?
Flags: needinfo?(kyle)
I am unable to reproduce this issue and I cannot find the build that you reported it in. Was the initial build a nightly build? or a tinderbox build?

I did see a similar issue that involved "Saving..." being displayed. But it can be reproduced with any ringtone. If the phone times out or is locked on the "Sound" setting screen then the user switches ringtone it will display "Saving..." in the ringtone section and it will not go away until setting are restarted.

the build I was unable to reproduce your issue in but saw the above issue is:

Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20140910060915
Gaia: f108c706fae43cd61628babdd9463e7695b2496e
Gecko: 843332cc69af
Version: 35.0a1 (2.2 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
Flags: needinfo?(ashiue)
Could be settings, I'm seeing 

E/GeckoConsole(  314): [JavaScript Error: "ReadOnlyError: A mutation operation was attempted in a READ_ONLY transaction." {file: "resource://gre/modules/SettingsRequestManager.jsm" line: 509}]

messages which are fixed by bug 1061510, but which is blocked on uplift by bug 1064228. So once all that is out of the way, this will be worth retesting.
Flags: needinfo?(kyle)
Depends on: 1061510, 1064228
I have also tried reproducing this issue but could not reproduce it.  Leaving the qawanted tag for others to check again later.

Environmental Variables:
Device: Flame 2.2
BuildID: 20140912061053
Gaia: b72909030e214175144342f7e5df7e88a2b52fd4
Gecko: 59d4326311e0
Version: 35.0a1 (2.2) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
Assigning to you kyle if this is blocked by the settings bug that you linked. Apologies if this isn't correct
Assignee: nobody → kyle
Whiteboard: [sytemsfe]
Target Milestone: 2.1 S4 (12sep) → 2.1 S5 (26sep)

Updated

3 years ago
Depends on: 1065128
No longer depends on: 1064228
Whiteboard: [sytemsfe] → [systemsfe]
All dependent bugs landed to aurora today, need confirmation from QA on v2.1 before closing.
Changing to verifyme since patch already landed.
Keywords: qawanted → verifyme
(Reporter)

Comment 14

3 years ago
Verified on
[master]
Gaia-Rev        3c898380b47f298cd3b7a0dacb3a6529e94322d4
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/4cdc4b9e5832
Build-ID        20140922184244
Version         35.0a1
(*note: find another settings crashed issue on master, track on bug 1071431)

[2.1]
Gaia-Rev        3742913e11f69e789dcb0aa0dedf2e5572da0129
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-aurora/rev/df42b05782aa
Build-ID        20140922185144
Version         34.0a2
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(ashiue)
Resolution: --- → FIXED
(Reporter)

Updated

3 years ago
Status: RESOLVED → VERIFIED
status-b2g-v2.1: --- → fixed
status-b2g-v2.2: --- → fixed

Updated

3 years ago
status-b2g-v2.1: fixed → verified

Comment 15

3 years ago
Created attachment 8525783 [details]
video of verify issue

This issue has been successfully verified on Flame 2.1
See attachment: verify_video.MP4
Reproducing rate: 0/5
Flame 2.1 versions:
Gaia-Rev        1b231b87aad384842dfc79614b2a9ca68a4b4ff3
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/95fbd7635152
Build-ID        20141119001205
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141119.035246
FW-Date         Wed Nov 19 03:52:56 EST 2014
Bootloader      L1TC00011880

Comment 16

3 years ago
Hi Kevin, please help to verify if this patch is good on master
Flags: needinfo?(kevin.tucker)

Comment 17

3 years ago
This issue is verified fixed on Flame 2.2.

The set ringtone will save as the default ringtone.

Flame 2.2

Device: Flame 2.2  (319mb)(Kitkat Base)(Shallow Flash)
Build ID: 20141125040209
Gaia: 824a61cccec4c69be9a86ad5cb629a1f61fa142f
Gecko: acde07cb4e4d
Version: 36.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
QA Whiteboard: [COM=Gaia::Ringtones] → [COM=Gaia::Ringtones][QAnalyst-Triage?]
Flags: needinfo?(kevin.tucker) → needinfo?(ktucker)
Keywords: verifyme

Updated

3 years ago
status-b2g-v2.2: fixed → verified
QA Whiteboard: [COM=Gaia::Ringtones][QAnalyst-Triage?] → [COM=Gaia::Ringtones][QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Blocks: 1107982
You need to log in before you can comment on or make changes to this bug.