If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Layout problems in contact list (was Images in the contacts list are shifted to the right, overlapping letter shortcuts)

VERIFIED FIXED in Firefox OS v2.1

Status

Firefox OS
Gaia::Contacts
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: sergi, Assigned: sergi)

Tracking

({regression})

unspecified
2.1 S4 (12sep)
x86
Mac OS X
regression

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 fixed)

Details

Attachments

(4 attachments)

Comment hidden (empty)
Assignee: nobody → sergi.mansilla
blocking-b2g: --- → 2.1?
Target Milestone: --- → 2.1 S4 (12sep)
This bug is a simple CSS fix that impacts user experience in contacts a lot, and should make it into 2.1.
Created attachment 8483576 [details] [review]
Github PR
Attachment #8483576 - Flags: review?(francisco)
Duplicate of this bug: 1061945
Keywords: regression
triage: identifiable UI flaw. refer to below screenshot.
https://bug1061945.bugzilla.mozilla.org/attachment.cgi?id=8483702
blocking-b2g: 2.1? → 2.1+
Duplicate of this bug: 1062785

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected
Flags: needinfo?(dharris)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
Sorry for the late point.

Description of this bug was incomplete. We had some problems with the layout of the list, (shifting images to the right), but also with the top of the list.

I'm changing the description for this.

Sorry again for the late advice
Summary: Images in the contacts list are shifted to the right, overlapping letter shortcuts → Layout problems in contact list (was Images in the contacts list are shifted to the right, overlapping letter shortcuts)
Comment on attachment 8483576 [details] [review]
Github PR

Could we fix here the fact that the list it self is to close to the top (contacts search).

In the case of favourites you could even see how the icon is cut in the top. For normal letters you'll see as well how the fixed header with the letter is as well pretty close to the search.
Attachment #8483576 - Flags: review?(francisco)
Can you include example STR to generate this bug?
Flags: needinfo?(sergi.mansilla)
Francisco, I updated the list separation between the search box and the list.
Flags: needinfo?(sergi.mansilla)
Attachment #8483576 - Flags: review?(francisco)

Comment 10

3 years ago
Created attachment 8486986 [details]
ice contact.png

Hi Sergi, 
I also have same problem for ICE contacts. The icon is pretty close to the search bar as well. I hope we can have some space between the icon and the search bar like the spec I attached. Is this something can be fixed at here? 
Thanks!
Flags: needinfo?(sergi.mansilla)
Created attachment 8487072 [details]
Screenshot

Hi Fang,

It looks good to me, check the attachment I just added. Maybe Francisco can confirm about the space being correct. In case it is, do you give a green light to let this one in?

Thanks,
Sergi
Flags: needinfo?(sergi.mansilla)

Comment 12

3 years ago
(In reply to Sergi Mansilla [:sergi] (Telenor) from comment #11)
> Created attachment 8487072 [details]
> Screenshot
> 
> Hi Fang,
> 
> It looks good to me, check the attachment I just added. Maybe Francisco can
> confirm about the space being correct. In case it is, do you give a green
> light to let this one in?
> 
> Thanks,
> Sergi

Wow! looks great!! Thanks!!
Comment on attachment 8483576 [details] [review]
Github PR

Hi Sergi,

still can see the start image pretty close to the top:

http://imgur.com/3OAFbpo

Also, could you rebase the patch to have the ICE group in the top?

Thanks!
Attachment #8483576 - Flags: review?(francisco)
Comment on attachment 8483576 [details] [review]
Github PR

Solved the favorites header space and rebased to latest master
Attachment #8483576 - Flags: review?(francisco)
Comment on attachment 8483576 [details] [review]
Github PR

Perfect, thanks a lot for the changes.

Only thing before merging is that the linter job is red :( ... but cannot see anything why it should be tbh.
Attachment #8483576 - Flags: review?(francisco) → review+
Merged at 9cfd2a4278a9a4f56c11c5de25a79f89862ad001
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Please request Gaia v2.1 approval on this when you get a chance.
status-b2g-v2.2: affected → fixed
Flags: needinfo?(sergi.mansilla)
Comment on attachment 8483576 [details] [review]
Github PR

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
Feature landed
[User impact] if declined:
Horrible user experience, completely broken in contact list with images
[Testing completed]:
Smoke test passed
[Risk to taking this patch] (and alternatives if risky):
Pretty low, just modifying 2 lines of css
[String changes made]:
Attachment #8483576 - Flags: approval-gaia-v2.1?(bbajaj)
Comment on attachment 8483576 [details] [review]
Github PR

low risk css change fixing a 2.1 regression.
Attachment #8483576 - Flags: approval-gaia-v2.1?(bbajaj) → approval-gaia-v2.1+
v2.1: https://github.com/mozilla-b2g/gaia/commit/f2e27b2f8ddf262cdf79717495ca661ac86508f9
status-b2g-v2.1: affected → fixed
Flags: needinfo?(sergi.mansilla)
Tested and working
2.2
Flame 
User
Gecko-5cf7098
Gaia-700f481

2.1
Flame
User
Gecko-5cf7098
Gaia-700f481
Status: RESOLVED → VERIFIED

Updated

3 years ago
status-b2g-v2.1: fixed → verified

Comment 22

3 years ago
Created attachment 8525174 [details]
verify_screenshot

This issue can't repro on Flame 2.1
See attachment: verify_screenshot.png
Reproducing rate: 0/5
Flame 2.1 versions:
Gaia-Rev        1b231b87aad384842dfc79614b2a9ca68a4b4ff3
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/95fbd7635152
Build-ID        20141118001204
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141118.035447
FW-Date         Tue Nov 18 03:54:58 EST 2014
Bootloader      L1TC00011880
You need to log in before you can comment on or make changes to this bug.