TPS failure in test_tabs.js due to not existent testcase pages

RESOLVED FIXED in Firefox 33

Status

()

defect
RESOLVED FIXED
5 years ago
9 months ago

People

(Reporter: cosmin-malutan, Assigned: cosmin-malutan)

Tracking

({regression})

unspecified
mozilla35
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox32 wontfix, firefox33 fixed, firefox34 fixed, firefox35 fixed, firefox-esr31 wontfix)

Details

Attachments

(1 attachment)

Initially I thought this was a timing issue similar with the bug 990509, but after a more detailed debugging I found that the addresses we use in tabs for testing are not supported anymore and the tabs opens but they don't contain the title expected, because the page wasn't found.
http://hg.mozilla.org/automation/crossweave/raw-file/2d9aca9585b6/pages/page1.html
 
>15:20:32 System JS : WARNING resource://services-common/async.js:199 - mutating the [[Prototype]] of an object will cause your code to run very slowly; instead create the object with the correct initial [[Prototype]] value using Object.create
>15:20:32 System JS : WARNING resource://gre/modules/services-sync/engines/bookmarks.js:49 - mutating the [[Prototype]] of an object will cause your code to run very slowly; instead create the object with the correct initial [[Prototype]] value using Object.create
>15:20:33 CROSSWEAVE INFO: ----------event observed: weave:service:sync:finish
>15:20:34 CROSSWEAVE INFO: starting action: Tabs__verify
>15:20:34 CROSSWEAVE INFO: executing action VERIFY on tab {"uri":"http://hg.mozilla.org/automation/crossweave/raw-file/2d9aca9585b6/pages/page1.html","title":"Crossweave Test Page 1","profile":"profile1"}
>15:20:34 CROSSWEAVE ERROR: [phase2] Exception caught: ASSERTION FAILED! error locating tab No traceback available
>15:20:34 CROSSWEAVE INFO: ----------event observed: quit-application-requested
>15:20:34 CROSSWEAVE INFO: Wiping data from server.
>15:20:35 
>15:20:35 TEST-UNEXPECTED-FAIL | test_tabs.js | [phase2] Exception caught: ASSERTION FAILED! error locating tab No traceback available
>15:20:35 
>15:20:35 	phase1: PASS
>15:20:35 	phase2: FAIL
>15:20:35 Running test test_passwords.js
Posted patch patch v1.0Splinter Review
As a fix for this I used two pages from mozqa.com which are maintained by us.
Assignee: nobody → cosmin.malutan
Status: NEW → ASSIGNED
Attachment #8483396 - Flags: review?(hskupin)
Attachment #8483396 - Flags: review?(andrei.eftimie)
Ouch. This actually regressed due to bug 1052782. It's bad to have all those cross-references. Jonathan, do you still have a checkout of crossweave on your local disk? Not sure what else was part of this repository, which we have created.
Blocks: 1052782
Keywords: regression
Flags: needinfo?(jgriffin)
Not sure why this is filed under Testing / TPS. It's not related to the framework at all.
Component: TPS → Firefox Sync: Backend
Product: Testing → Mozilla Services
Comment on attachment 8483396 [details] [diff] [review]
patch v1.0

Review of attachment 8483396 [details] [diff] [review]:
-----------------------------------------------------------------

Looks like those are the only external references to web pages, which tps tests are using. Not sure about http://mxr.mozilla.org/mozilla-central/source/testing/tps/pages/ but those we can sort out when moving the tps framework out of the tree.
Attachment #8483396 - Flags: review?(hskupin)
Attachment #8483396 - Flags: review?(andrei.eftimie)
Attachment #8483396 - Flags: review+
Summary: TPS failure: test_tabs.js Exception caught: ASSERTION FAILED! error locating tab No traceback available → TPS failure in test_tabs.js due to not existent testcase pages
https://hg.mozilla.org/integration/mozilla-inbound/rev/e6d0e1681cc8

Next time please do not forget to also add the DONTBUILD suffix. There is no need to trigger any builds for tps related bugs.
Target Milestone: --- → mozilla35
I don't have a local copy of crossweave, but those pages were all moved to http://mxr.mozilla.org/mozilla-central/source/testing/tps/pages/, so you could update them accordingly.
Flags: needinfo?(jgriffin)
https://hg.mozilla.org/mozilla-central/rev/e6d0e1681cc8
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
(In reply to Jonathan Griffin (:jgriffin) from comment #6)
> I don't have a local copy of crossweave, but those pages were all moved to
> http://mxr.mozilla.org/mozilla-central/source/testing/tps/pages/, so you
> could update them accordingly.

Ah, alright. We will explore but we may leave the references to mozqa.com in this test. This server is in the same VLAN as our CI, so way better reachable as hg.m.o or mxr. The latter also experienced a lot of outages lately.
Flags: in-testsuite+
Component: Firefox Sync: Backend → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.