Closed Bug 1062415 Opened 5 years ago Closed 5 years ago

Reproducible Ghost Windows with latest Nightlys

Categories

(Core :: General, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1061202

People

(Reporter: stebs, Unassigned)

References

Details

Attachments

(2 files)

Attached file memory-report.json.gz
Ghost Windows are reproducible with Nightly and using new profile:
Browse to http://www.gamingonlinux.com/ and open several articles as new tabs.
Open another tab from another domain and close all gamingonlinux tabs.
After some time, those closed tabs are marked as ghost windows in about:memory

Memory report, Troubleshooting Information and verbose gc &cc logs follow as attachment.
Chances are this is the same issue as bug 1061202.
Depends on: 1061202
Stebs, thank you for reporting this!  Assuming the fix for bug 1061202 sticks, would you mind retesting in tomorrow's nightly?
Sure, will test again tomorrow.
BTW, gc&cc logs upload just canceled, 25 MB compressed are too large - will keep the file to send it upon request.
Summary: Reproducible Ghost Windows with latest Nightlys on linux → Reproducible Ghost Windows with latest Nightlys
Hmm, respin of nightly https://hg.mozilla.org/mozilla-central/rev/5e9826980be5 still produces ghost-windows, but checkin for the bug https://hg.mozilla.org/integration/mozilla-inbound/rev/10276ebe5711 should already be in?
Will check today's nightly as soon as it is out.
35.0a1 (2014-09-04) built from https://hg.mozilla.org/mozilla-central/rev/776fa9cf70cd
does no longer produce ghost windows.
I still don't get it why the respin didn't fix it, maybe I do not understand how to use "mozilla-inbound - shortlog" correctly!?
Anyway, marking this fixed as duplicate of 1061202, will keep an eye on about:memory for the next days though...
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1061202
> I still don't get it why the respin didn't fix it

The push to mozilla-central that respin was built from happened at "Wed Sep 03 13:23:59 2014".

The merge to m-c that included rev 10276ebe5711 was acbdce59da2f, which happened at "Wed Sep 03 20:38:59 2014".

> maybe I do not understand how to use "mozilla-inbound - shortlog" correctly

The important thing here is the mozilla-central pushlog, not what happened on inbound.

Thank you for double-checking, and again thanks for catching this and filing a bug!
You need to log in before you can comment on or make changes to this bug.