Closed Bug 1062452 Opened 5 years ago Closed 5 years ago

Firefox 32.0 crashes frequently in aticfx32.dll with switchable Intel+ATI graphics

Categories

(Core :: Graphics, defect, critical)

32 Branch
x86_64
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1063048
Tracking Status
firefox32 + fixed

People

(Reporter: info, Unassigned)

References

Details

(Keywords: crash)

Crash Data

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140825202822

Steps to reproduce:

It crashed very frequent, i am not even able to finalize this bug report.
bp-d9f07354-66e1-479e-8d26-0d7742140903	03.09.2014	19:51
bp-1f728422-ce43-449d-8a6d-136332140903	03.09.2014	19:46
bp-9c56f5cb-4587-400c-8953-c6f572140903	03.09.2014	19:36
bp-2750fcc9-c7bc-4ba6-89e8-f690c2140903	03.09.2014	19:31
bp-2dc2ac61-8cb0-4a86-9f83-6897c2140903	03.09.2014	19:26
bp-9c0091fc-8624-47fa-96dc-918562140903	03.09.2014	19:25
bp-31be5640-7106-4f2f-b17e-dd3212140903	03.09.2014	19:23
bp-48f30a05-061d-418a-a846-9a4682140903	03.09.2014	19:21
bp-e7c08671-90ce-4019-abff-eef162140902	02.09.2014	19:54
bp-4a8d8dd2-abc0-4a75-b287-2c1e42140902	02.09.2014	19:51
bp-ab32787a-3ec4-4389-9d32-7b59e2140902	02.09.2014	19:32
bp-6be65066-8220-49ff-911c-a8ff72140902	02.09.2014	19:27
bp-c3a16ab3-3790-4a49-8738-2eaff2140902	02.09.2014	19:23
bp-1d15382e-6a5d-4899-a545-9ffa52140902	02.09.2014	19:17
bp-63209acb-308d-484e-8aa8-a223c2140902	02.09.2014	19:00
bp-51254268-8451-4d1b-906d-62e2f2140902	02.09.2014	18:31
bp-ff16f7a2-bedc-410f-a100-dbb3c2140902	02.09.2014	18:27
Surely related to your GPU.

Type about:crashes in the location bar and paste the section "graphics".

In addition, disable HWA (see http://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration) and try to surf.

Does it fix the crashes?
Severity: normal → critical
Crash Signature: [@ aticfx32.dll@0x346d5 ]
Component: Untriaged → Graphics
Flags: needinfo?(info)
Keywords: crash
Product: Firefox → Core
Summary: firefox 32.0 crashes frequently → Firefox 32.0 crashes frequently in aticfx32.dll
Hi
thank you for the fast response.
I did disable the hardware acceleration, and there was no crash until now.
Flags: needinfo?(info)
Could you post the info from "graphics" in the about:support page, please.
Flags: needinfo?(info)
the graphics section info (note: the info is after disabling the hardware acceleration):

Grafik
DirectWrite aktiviert	false (6.2.9200.16571)
Geräte-ID	0x0126
GPU #2 aktiv	false
GPU-beschleunigte Fenster	0/1 Basic
Karten-Beschreibung	Mobile Intel(R) HD Graphics
Karten-RAM	Unknown
Karten-Treiber	igdumd64 igd10umd64 igd10umd64 igdumdx32 igd10umd32 igd10umd32
Treiber-Datum	3-24-2011
Treiber-Version	8.813.3.2000
Vendor-ID	0x8086
WebGL-Renderer	Google Inc. -- ANGLE (Mobile Intel(R) HD Graphics Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote	false
AzureCanvasBackend	skia
AzureContentBackend	cairo
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0
Flags: needinfo?(info)
Crash Signature: [@ aticfx32.dll@0x346d5 ] → [@ aticfx32.dll@0x346d5 ] [@ aticfx32.dll@0x34b85 ] [@ aticfx32.dll@0x34b65 ] [@ aticfx32.dll@0x59b9c ] [@ aticfx32.dll@0x346c5 ]
Confirming as we have multiple similar signatures in early crash stats.
Status: UNCONFIRMED → NEW
Ever confirmed: true
The crashes are at some bogus address, most often 0x7045007, but crash-stats attributes it to aticfx32 as the next frame down. This group of crashes is pretty much exclusive to 32.0, and it does not correlate with any recent aticfx32 version update. At this point I can't say whether this is an ATI corruption that FF32 exposed, or vice versa.

Despite ATI drivers, this is >99% VendorID 0x8086 (Intel). This must be on switchable-GPU laptops. Does the QA lab have an Intel+ATI machine to test?

Milan, were there any major gfx changes in 32 that could lead to this? Are there any prefs that could help with a diagnosis?
Crash Signature: [@ aticfx32.dll@0x346d5 ] [@ aticfx32.dll@0x34b85 ] [@ aticfx32.dll@0x34b65 ] [@ aticfx32.dll@0x59b9c ] [@ aticfx32.dll@0x346c5 ] → [@ aticfx32.dll@0x346b5 ] [@ aticfx32.dll@0x346c5 ] [@ aticfx32.dll@0x346d5 ] [@ aticfx32.dll@0x34705 ] [@ aticfx32.dll@0x34b65 ] [@ aticfx32.dll@0x34b85 ] [@ aticfx32.dll@0x59b9c ]
Flags: needinfo?(dmajor) → needinfo?(milan)
Summary: Firefox 32.0 crashes frequently in aticfx32.dll → Firefox 32.0 crashes frequently in aticfx32.dll with switchable Intel+ATI graphics
So, just to be sure - with hardware acceleration disabled, there is no crash?  If you re-enable hardware acceleration, but set gfx.direct2d.disabled to true (in about:config) and restart, is there a crash?
Flags: needinfo?(milan)
From looking at the crash reports, the Intel driver installed is 8.15.10.2342 and AdapterDeviceID: 0x0126 is Sandy Bridge.

https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=23764

The latest Intel graphics driver for Sandy Bridge is 9.17.10.3517 which has a lot of bugfixes but might not be able to install it due to the switchable graphics.
Peter, can you help with comment 8? If you re-enable hardware acceleration, does the crash come back? Are you able to update the graphics driver?
Flags: needinfo?(info)
Are there any switchable Intel/ATI notebooks in the lab? From our stats they are likely to be Lenovo but Dell and HP also show up a fair amount.
Flags: needinfo?(mschifer)
Juan, can you check to see if we have anything on hand that might have the required hardware? If not see if IT has anything in their old stock.
Flags: needinfo?(mschifer) → needinfo?(jbecerra)
Not much I can do here without having hardware. I currently don't have any device that fits this description.
Flags: needinfo?(bas)
Well, in the current state with this and bug 1063048, I can't vote for unthrottling 32.0 updates to the general public. Just punting because nobody has hardware does not work for issues like this.
(In reply to GMA from comment #9)
> From looking at the crash reports, the Intel driver installed is
> 8.15.10.2342 and AdapterDeviceID: 0x0126 is Sandy Bridge.
> 
> https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=23764
> 
> The latest Intel graphics driver for Sandy Bridge is 9.17.10.3517 which has
> a lot of bugfixes but might not be able to install it due to the switchable
> graphics.

Bas, we blacklisted a number of Intel cards/drivers combos with bug 988549, maybe we just need to expand the net to catch these ones as well?

I can't recall; if we were to temporarily add something to the downloadable blacklist, to see if it helps with the crashes, leave it there for a couple of days, could we take it back off that list and produce a 32.0.1 blacklist in the code?
Flags: needinfo?(bas)
(In reply to Milan Sreckovic [:milan] from comment #15)
> I can't recall; if we were to temporarily add something to the downloadable
> blacklist, to see if it helps with the crashes, leave it there for a couple
> of days, could we take it back off that list and produce a 32.0.1 blacklist
> in the code?

Would there be any need to create a 32.0.1 in that case? Why not just keep the driver in the downloadable blacklist for 32?
Just a question of timing.  If it's in the "official" downloadable blacklist, we can never remove it, even if it turns out it was a bug on our side and we eventually fix it.
(In reply to Marc Schifer [mschifer] from comment #12)
> Juan, can you check to see if we have anything on hand that might have the
> required hardware? If not see if IT has anything in their old stock.

We don't have any suitable hardware in the lab. I'll file a service request to see if we have anything in stock.
Flags: needinfo?(jbecerra)
Almost entirely Win7SP1:
 	6.1.7601 	12802 	96.57 %
 	6.1.7600 	447 	3.37 %

Some interesting driver correlations here, search "aticfx32.dll@" (warning large file): https://crash-analysis.mozilla.com/crash_analysis/20140907/20140907_Firefox_32.0-interesting-modules-with-versions.txt.gz

Basically the various crash offsets within aticfx32.dll are due to different versions. They are generally bracketed by 8.17.10.1063 to 8.17.10.1140. (I don't know if this is considered "the" driver version since e.g. atidxx32.dll uses a different numbering scheme)

Milan/Bas, does this offer any leads?
(In reply to juan becerra [:juanb] from comment #18)
> We don't have any suitable hardware in the lab. I'll file a service request
> to see if we have anything in stock.

At this point it would be worth just buying a machine if we don't have one. Comment 11 and comment 19 narrow down the software and hardware pretty well. Combining the signatures, this is easily the #2 crash, with more than 5% of crashes.
This crash has the same DriverVersionMismatch symptoms for which bjacob has just posted a patch in bug 1063048 comment 8.
(In reply to David Major [:dmajor] from comment #21)
> This crash has the same DriverVersionMismatch symptoms for which bjacob has
> just posted a patch in bug 1063048 comment 8.

Right, so for the same reason as explained there, the same backout patch is expected to also fix this. Kudos again David for spotting DriverVersionMismatch in the appnotes.
Can we close this now?
Depends on: 1063048
I just came back to this bug to ask the same question as comment 23. 

bjacob/dmajor - Can you please confirm that to the best of your knowledge this bug has been resolved for the fix in bug 1063048?
Flags: needinfo?(dmajor)
Flags: needinfo?(bjacob)
Probably, but I can't (yet) back it up with data. These crashes were really rare outside the release channel.
Flags: needinfo?(dmajor)
Yeah, the fact that the crash reports have DriverVersionMismatch means that the patch from bug 1063048 should really fix it, unless it doesn't work at all.
Flags: needinfo?(bjacob)
Looking at data, this is successfully gone from 32.0.1 as well, so the actual cause and fix is a duplicate of bug 1063048.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1063048
Flags: needinfo?(info)
You need to log in before you can comment on or make changes to this bug.