crash in java.lang.NullPointerException: at org.mozilla.gecko.RemoteTabsExpandableListAdapter.getChildView(RemoteTabsExpandableListAdapter.java)

VERIFIED FIXED in Firefox 34

Status

()

--
critical
VERIFIED FIXED
4 years ago
2 years ago

People

(Reporter: kairo, Assigned: nalexander)

Tracking

({crash})

unspecified
Firefox 35
All
Android
crash
Points:
---
Bug Flags:
qe-verify -

Firefox Tracking Flags

(firefox32 unaffected, firefox33 unaffected, firefox34+ verified, firefox35 verified)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
This bug was filed from the Socorro interface and is 
report bp-effd891d-063d-4ff9-a922-cd9242140903.
=============================================================

I'm seeing this crash reproducibly when trying to access remote tabs on nightly on my Nexus 10.

Updated

4 years ago
Blocks: 1057637
(Assignee)

Comment 1

4 years ago
This is interesting.  The offending code is at http://mxr.mozilla.org/mozilla-central/source/mobile/android/base/RemoteTabsExpandableListAdapter.java#142.

The two get() calls above through on index exceptions, so it's unlikely we're seeing a data corruption problem.  It's possible we have a null tab, but unlikely.  Everything's basically new and final; that would be quite hard to arrange.

That suggests that it's the titleView that's null.  If we inflate the view ourselves, it's very unlikely that we can't find R.id.title.  (I've checked the resource, and that's the correct id.)  That suggests that we're trying to convert a view and failing.  I wonder if we might get a convertView that's a group view, rather than a child view?  Investigating further.
(Assignee)

Updated

4 years ago
Assignee: nobody → nalexander
Status: NEW → ASSIGNED
(Assignee)

Comment 2

4 years ago
I've installed what looks like the offending build (based on buildid):

http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/2014-09-03-03-02-06-mozilla-central-android/fennec-35.0a1.multi.android-arm.json

I can't dupe on two devices.  I'm going to wait and see if we get more reports with this signature, and if kairo sees it with more Nightlies.
(Assignee)

Comment 3

4 years ago
I take it all back.  This is a legit issue: I forgot to update a file on tablets only.
status-firefox34: --- → affected
status-firefox35: --- → affected
(Assignee)

Comment 4

4 years ago
Created attachment 8483970 [details] [diff] [review]
Rename tabs to title on tablets as well. r=mcomella

This should fix a reproducible hard crash on tablets.
Attachment #8483970 - Flags: review?(michael.l.comella)
(Assignee)

Comment 5

4 years ago
This'll want local testing, a day to bake, and then immediate uplift to Aurora.

Updated

4 years ago
Attachment #8483970 - Flags: review?(michael.l.comella) → review+
(Assignee)

Comment 7

4 years ago
Comment on attachment 8483970 [details] [diff] [review]
Rename tabs to title on tablets as well. r=mcomella

Approval Request Comment

[Feature/regressing bug #]: https://bugzilla.mozilla.org/show_bug.cgi?id=1057637

[User impact if declined]: hard crash in Remote Tabs tray on tablets.

[Describe test coverage new/current, TBPL]: essentially none.  I can't make crash-reports differentiate tablets from phones, but I'm confident we're seeing this only on tablets.  Pretty clear oversight updating one file and not another.

[Risks and why]: Essentially none. I suppose I could have made a second mistake?

[String/UUID change made/needed]: none.
Attachment #8483970 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/9e9af9d273f0
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 35
status-firefox32: --- → unaffected
status-firefox33: --- → unaffected
status-firefox35: affected → fixed
tracking-firefox34: --- → +
Comment on attachment 8483970 [details] [diff] [review]
Rename tabs to title on tablets as well. r=mcomella

Aurora+
Attachment #8483970 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Marking this verified fixed since there are 0 crashes reported in the last week. However, I'm also flagging this qe-verify- since QE didn't actually do a verification here.
Status: RESOLVED → VERIFIED
status-firefox34: fixed → verified
status-firefox35: fixed → verified
Flags: qe-verify-
You need to log in before you can comment on or make changes to this bug.