Closed Bug 1062742 Opened 10 years ago Closed 8 years ago

[e10s] window.open breaks in xul.

Categories

(Core :: XUL, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
e10s + ---

People

(Reporter: pzhang, Assigned: mconley)

References

Details

(Whiteboard: XUL)

Attachments

(1 file)

Attached file Test Addon
In e10s-enabled Firefox, calling |window.open| in browser.xul fails, it could be reproduced by installing the test addon:
  - Enable e10s on latest Nightly and restart
  - Install the test addon and restart Nightly
  - Customize the toolbar button, drag the button with label "Your Toolbar Button" to the toolbar.
  - Click on the toolbar button

Expected result:
A new window is opened with https://www.firefox.com/

Actual result:
Nothing happened, only got a meaningless error message:
   NS_ERROR_FAILURE:      ff-overlay.js:12
Assignee: nobody → mconley
Flags: needinfo?(mconley)
Blocks: e10s-addons
tracking-e10s: --- → +
Flags: needinfo?(mconley)
The add-on opens a window correctly in the latest nightly.

However, I noticed that it took a very long time for the window to open the first few times I tried, and it looks like a non-e10s window is being opened. I don't know if that's expected behavior.
Whiteboard: XUL
I think this is now working properly on Nightly, and probably Aurora.

Going to close this as WFM.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: