Closed Bug 1062843 Opened 5 years ago Closed 5 years ago

toolkit/themes/osx/global/in-content/common.css uses broken @focusRingShadow@ - focused link styling on about:preferences et al. can't be parsed correctly

Categories

(Toolkit :: Themes, defect, critical)

x86
macOS
defect
Not set
critical
Points:
1

Tracking

()

VERIFIED FIXED
mozilla35
Iteration:
35.1
Tracking Status
firefox32 --- unaffected
firefox33 --- unaffected
firefox34 + verified
firefox35 --- verified

People

(Reporter: Gijs, Assigned: Gijs)

References

Details

(Keywords: access, regression)

Attachments

(1 file)

... which leads to CSS warnings showing up about the box-shadow rule being dropped.

This not being caught by our continuous integration is bug 1062821.
[Tracking Requested - why for this release]:
Serious keyboard access regression on our in-content prefs
I was wrong in comment #1 - this particular bug just affects seeing keyboard focus on in-content links. I guess there's a separate bug about keyboard focus being completely invisible on OS X. Filed bug 1062854 for that.
Summary: toolkit/themes/osx/global/in-content/common.css uses broken @focusRingShadow@ - can't see focused controls on about:preferences et al. → toolkit/themes/osx/global/in-content/common.css uses broken @focusRingShadow@ - can't see focused links on about:preferences et al.
For QA: to verify, check that there are no more CSS errors about a dropped box-shadow rule after this is fixed.

Marco, I'm picking this up because it's a regression and it's just made it up to aurora, and is trivial to fix (1 point), and I ran into it dealing with my other bugs for this iteration (bug 1035536).
Iteration: --- → 35.1
Points: --- → 1
Flags: qe-verify+
Flags: needinfo?(mmucci)
Flags: firefox-backlog+
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Summary: toolkit/themes/osx/global/in-content/common.css uses broken @focusRingShadow@ - can't see focused links on about:preferences et al. → toolkit/themes/osx/global/in-content/common.css uses broken @focusRingShadow@ - focused link styling on about:preferences et al. can't be parsed correctly
Added to It 35.1
Flags: needinfo?(mmucci)
Attachment #8484151 - Flags: review?(dao) → review+
remote:   https://hg.mozilla.org/integration/fx-team/rev/6629205c6f67
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/6629205c6f67
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → mozilla35
Florin, could you ask one of your team to verify this one? Thanks!
QA Contact: florin.mezei
Assigning this to Bogdan.
QA Contact: florin.mezei → bogdan.maris
Reproduced the issue on Nightly (2014-09-04), I get "Error in parsing value for 'box-shadow'. Declaration dropped.  common.css:656" in Browser console after loading about:preferences.
Verified that using latest Nightly (2014-09-11) on Mac OS X 10.9.4 I don`t get that in Browser console anymore.
Status: RESOLVED → VERIFIED
I *think* you're still interested in uplifting to Aurora. If so, can you please submit an approval request?
Flags: needinfo?(gijskruitbosch+bugs)
Comment on attachment 8484151 [details] [diff] [review]
include shared.inc to make @focusRingShadow@ be defined,

I think I overestimated the severity of this bug, but this is a safe uplift, so sure.

Approval Request Comment
[Feature/regressing bug #]: bug 1009370
[User impact if declined]: warnings in the console when opening in-content pages
[Describe test coverage new/current, TBPL]: n/a
[Risks and why]: very low
[String/UUID change made/needed]: none
Attachment #8484151 - Flags: approval-mozilla-aurora?
Flags: needinfo?(gijskruitbosch+bugs)
Comment on attachment 8484151 [details] [diff] [review]
include shared.inc to make @focusRingShadow@ be defined,

Aurora+
Attachment #8484151 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Also verified that the issue is no longer present using latest Aurora on Mac OS X 10.9.4
You need to log in before you can comment on or make changes to this bug.