Closed Bug 1062860 Opened 7 years ago Closed 7 years ago

Object.isSealed() should return true when given primitive values as input

Categories

(Core :: JavaScript: Standard Library, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla35

People

(Reporter: 446240525, Unassigned)

References

Details

(Keywords: dev-doc-complete, Whiteboard: [DocArea=JS])

Attachments

(1 file)

js> Object.isSealed("foo")
TypeError: "foo" is not an object
// should return true in ES6
Blocks: 1060870
Keywords: dev-doc-needed
Whiteboard: [DocArea=JS]
Attachment #8484159 - Flags: review?(till)
Comment on attachment 8484159 [details] [diff] [review]
a quick patch to fix this

Review of attachment 8484159 [details] [diff] [review]:
-----------------------------------------------------------------

Looks great, thanks.

I'd just land the patch, except I don't want to change the test file's license without your explicit consent. So if the change shown below is ok with you, just give me a quick ok and I'll do that change and land.

Also, I've given you more permissions in bugzilla.mozilla.org: you can now fully edit bugs. That means that your new bugs will start out as NEW instead of UNCONFIRMED, and you're able to close bugs and change their state more freely than until now.

::: js/src/tests/ecma_6/Object/isSealed.js
@@ +1,3 @@
> +/*
> + * Any copyright is dedicated to the Public Domain.
> + * http://creativecommons.org/licenses/publicdomain/

Based on recent discussions I saw, it'd be good if you could change this to https://creativecommons.org/publicdomain/zero/1.0/
Attachment #8484159 - Flags: review?(till) → review+
Status: UNCONFIRMED → NEW
Ever confirmed: true
Ziyunfei, can you give me confirmation that you're ok with the license being changed as proposed in comment 2? Once I have that confirmation, I can land the patch.
Flags: needinfo?(446240525)
(In reply to Till Schneidereit [:till] from comment #3)
> Ziyunfei, can you give me confirmation that you're ok with the license being
> changed as proposed in comment 2? Once I have that confirmation, I can land
> the patch.

Yes, I'm ok with that! sorry for the delay on responding here, I missed that bugmail from comment#2.

(In reply to Till Schneidereit [:till] from comment #2)
> Also, I've given you more permissions in bugzilla.mozilla.org: you can now
> fully edit bugs. That means that your new bugs will start out as NEW instead
> of UNCONFIRMED, and you're able to close bugs and change their state more
> freely than until now.

Thanks, Till.
Flags: needinfo?(446240525)
remote:   https://hg.mozilla.org/integration/mozilla-inbound/rev/7f06ae718751

(In reply to ziyunfei from comment #4)
> (In reply to Till Schneidereit [:till] from comment #3)
> > Ziyunfei, can you give me confirmation that you're ok with the license being
> > changed as proposed in comment 2? Once I have that confirmation, I can land
> > the patch.
> 
> Yes, I'm ok with that! sorry for the delay on responding here, I missed that
> bugmail from comment#2.

No worries - I should've used needinfo earlier - that's what it's there for.
Re-landed. Breakage was all caused by the other suspect.

https://hg.mozilla.org/integration/mozilla-inbound/rev/1c49dba274e4
https://hg.mozilla.org/mozilla-central/rev/7f06ae718751
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
You need to log in before you can comment on or make changes to this bug.