[MMS]When user attempts to play a sound file sent from MMS the Messaging app will lock up

RESOLVED DUPLICATE of bug 1058376

Status

Firefox OS
Gaia::SMS
RESOLVED DUPLICATE of bug 1058376
3 years ago
3 years ago

People

(Reporter: SalvadorR, Unassigned)

Tracking

(Blocks: 1 bug, {regression})

unspecified
ARM
Gonk (Firefox OS)
regression
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v1.4 unaffected, b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [2.1-exploratory], URL)

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8484568 [details]
logcat_20140903_1749.txt

Description:
When user receives an audio file through MMS and attempts to play the file in the Messaging app, the app will Freeze.
   
Repro Steps:
1) Update a Flame device to BuildID: 20140903000204
2) On a seperate device, send a audio file through MMS to the test device
3) On the test device, attempt to open the audio file in the Messaging app
4) Observe status of the Messaging app after attempting to open audio file
  
Actual:
Messaging app freezes after attempting to open the audio file
  
Expected: 
Messaging app works fine after opening the audio file
  
Environmental Variables:
Device: Flame 2.1 (319mb)
Build ID: 20140903000204
Gaia: fbb297c39aab5f17b179533d2a9a6c5166b2c197
Gecko: fb5e796da813
Version: 34.0a2
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
  
Repro frequency: 3/3
See attached: Video Clip, Logcat
https://www.youtube.com/watch?v=CfL7j6dJ1N8&edit=vd
(Reporter)

Comment 1

3 years ago
This issue occurs on Flame 2.1 (319 mb), Flame 2.1 (512 mb) and Flame 2.2

Actual: Messaging app freezes after attempting to open the audio file

Flame 2.1 (319 mb)

Environmental Variables:
Device: Flame 2.1 (319mb)
BuildID: 20140904000203
Gaia: a47ecb6368c015dd72148acde26413fd90ba3136
Gecko: 757931d0149e
Version: 34.0a2 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Flame 2.1 (512 mb)

Environmental Variables:
Device: Flame 2.1 (512mb)
BuildID: 20140904000203
Gaia: a47ecb6368c015dd72148acde26413fd90ba3136
Gecko: 757931d0149e
Version: 34.0a2 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Flame 2.2

Environmental Variables:
Device: Flame Master (319mb)
Build ID: 20140904040204
Gaia: 008026e932b64b4a70b9931c3da96986583bc8d4
Gecko: 776fa9cf70cd
Version: 35.0a1 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

-----------------------------------------------------------------------------

This issue does NOT occur on Flame 2.0, Flame 1.4, Open C 2.2, Open C 2.1, Open C 2.0 and Open C 1.4

Expected: Messaging app works fine after opening the audio file

Flame 2.0

Environmental Variables:
Device: Flame 2.0 (319mb)
BuildID: 20140904000202
Gaia: d056733f8a7a1a152f5458b323f092c47dbffa48
Gecko: 19383abee78a
Version: 32.0 (2.0)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Flame 1.4

Environmental Variables:
Device: Flame 1.4 (319mb)
Build ID: 20140904063007
Gaia: 2ee5b00bfbb8a67a967094804390b4afce8ecf54
Gecko: acb69ef9f3e4
Version: 30.0 (1.4)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Open C 2.2

Environmental Variables:
Device: Open_C Master
Build ID: 20140904040204
Gaia: 008026e932b64b4a70b9931c3da96986583bc8d4
Gecko: 776fa9cf70cd
Version: 35.0a1 (Master)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Open C 2.1

Environmental Variables:
Device: Open_C 2.1
BuildID: 20140904000203
Gaia: a47ecb6368c015dd72148acde26413fd90ba3136
Gecko: 757931d0149e
Version: 34.0a2 (2.1)
Firmware: P821A10v1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Open_C 2.0

Environmental Variables:
Device: Open_C 2.0 
Build ID: 20140904000202
Gaia: d056733f8a7a1a152f5458b323f092c47dbffa48
Gecko: 19383abee78a
Version: 32.0 (2.0)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Open C 1.4

Environmental Variables:
Device: Open_C 1.4
Build ID: 20140904063007
Gaia: 2ee5b00bfbb8a67a967094804390b4afce8ecf54
Gecko: acb69ef9f3e4
Version: 30.0 (1.4)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
(Reporter)

Comment 2

3 years ago
Please ignore comment 0's video link

Here is the updated youtube link http://youtu.be/D-csiybhcnQ
(Reporter)

Comment 3

3 years ago
This issue does Not occur on Flame 1.3 Base Image (v123)

Expected: Messaging app works fine after opening the audio file

Device: Flame 1.3
Build ID: 20140627162151
Gaia: 5c43d012a9351e8aaeacda0b87b0886b7f67d33d
Gecko: e181a36ebafaa24e5390db9f597313406edfc794
Version: 28.0 (1.3)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0
[Blocking Requested - why for this release]:

This is a regression from 2.0 and the user is put into a state where the buttons do not function so nominating this 2.1?
blocking-b2g: --- → 2.1?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
QA Contact: aalldredge
Mozilla Inbound Regression Window:

Last working:
Device: Flame 2.1
BuildID: 20140821223018
Gaia: afcdd36f13e75adcdebe57d842a277fd587faf28
Gecko: c365e93b8e42
Version: 34.0a1 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

First Broken:
Device: Flame 2.1
BuildID: 20140821224417
Gaia: afcdd36f13e75adcdebe57d842a277fd587faf28
Gecko: a9c2b0b7adac
Version: 34.0a1 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Last working Gaia First Broken Gecko: Issue DOES reproduce
Gaia: afcdd36f13e75adcdebe57d842a277fd587faf28
Gecko: a9c2b0b7adac

First Broken Gaia Last working Gecko: Issue does NOT reproduce
Gaia: afcdd36f13e75adcdebe57d842a277fd587faf28
Gecko: c365e93b8e42

Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=c365e93b8e42&tochange=a9c2b0b7adac

Caused by Bug 1040017
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
possibly broken by bug 1040017 - can you take a look Patrick?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(kk1fff)
Steve,
Can you take a look first? Not sure if this is SMS bug.
According to the video, it's a broken function.
blocking-b2g: 2.1? → 2.1+
Flags: needinfo?(schung)
I can not reproduce this issue on master, is this only reproducible on certain format of audio? If it's file format issue please provide the testing media, thanks.
Flags: needinfo?(schung)

Updated

3 years ago
Flags: needinfo?(srapanan)
QA Wanted - See comment 8.
QA Whiteboard: [QAnalyst-Triage+]
Keywords: qawanted
Blocks: 1026943
(Reporter)

Comment 10

3 years ago
Created attachment 8488024 [details]
woodpeck.amr

I was still able to get the issue to repro on today's build. I noticed a higher repro rate when you save the sound file, back out and attempt to play it again. Attached the sound file used for test.
Flags: needinfo?(srapanan)
I can reproduce this after I saved the received file, go back to message then play it again. It looks that this bug is caused by bug 1040017 as it affected device storage. Patch for bug 1058376 should be able fix this.
Flags: needinfo?(kk1fff)
Blocks: 1040017
Depends on: 1058376
We'll test again once bug 1058376 lands, and we'll eventually dupe if this is fixed in that bug.

Updated

3 years ago
Keywords: qawanted
bug 1058376 landed, can we test this again with a master build that has the fix to bug 1058376 ?
(I'm fine with waiting one more day, just to be sure we test with a build that has the fix :) ).

Thanks !
Keywords: qawanted
I was unable to reproduce this issue in the latest 2.2 Master with KK base.

Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20140919052449
Gaia: d170091ba1b5597b05f37fb259f6b8eb02568798
Gecko: 3475e6a1665a
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Repro rate: 0/20
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Thanks, let's dupe then :)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1058376
You need to log in before you can comment on or make changes to this bug.